aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-02-13 15:18:33 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-02-13 15:18:33 +0000
commit2a4a71b5088b541d645cc2e24d8a725c97a29c9e (patch)
treebf494d043f5e79816ca466572b0fcb5930e22a5f
parent8a2b51e72a962985617f686c163271e30de2105e (diff)
downloadports-2a4a71b5088b541d645cc2e24d8a725c97a29c9e.tar.gz
ports-2a4a71b5088b541d645cc2e24d8a725c97a29c9e.zip
Notes
-rw-r--r--mail/horde-turba/Makefile13
-rw-r--r--mail/horde-turba/files/patch-config::sources.php.dist137
-rw-r--r--mail/horde4-turba/Makefile13
-rw-r--r--mail/horde4-turba/files/patch-config::sources.php.dist137
-rw-r--r--mail/turba/Makefile13
-rw-r--r--mail/turba/files/patch-config::sources.php.dist137
6 files changed, 450 insertions, 0 deletions
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index c67ca3b72ee2..2621ef05451f 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -27,6 +27,8 @@ COMMENT= The Horde contact management application
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
#
+# - WITH_IMSP : run IMSP cyrus-imspd.
+#
#-----------------------------------------------------------------------
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
@@ -55,11 +57,22 @@ CONFDIR= ${TURBADIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
+.if exists(${LOCALBASE}/sbin/imspd)
+WITH_IMSP= yes
+.endif
+.if defined(WITH_IMSP)
+RUN_DEPENDS+= imspd:${PORTSDIR}/databases/cyrus-imspd
+.endif
+
pre-configure:
+ @${RM} ${WRKSRC}/config/sources.php.dist.orig
@${SED} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${FILESDIR}/httpd.conf.turba > ${WRKDIR}/httpd.conf.turba
@${REINPLACE_CMD} -e "s:/usr/bin/ldapadd:${LOCALBASE}/bin/ldapadd:" \
${WRKSRC}/scripts/ldap/addou.pl
+.if defined(WITH_IMSP)
+ @${REINPLACE_CMD} -e "s://UNCOMMENTIFIMSP ::" ${WRKSRC}/config/sources.php.dist
+.endif
do-install:
@${MKDIR} ${TURBADIR}
diff --git a/mail/horde-turba/files/patch-config::sources.php.dist b/mail/horde-turba/files/patch-config::sources.php.dist
new file mode 100644
index 000000000000..b3d2dca409fe
--- /dev/null
+++ b/mail/horde-turba/files/patch-config::sources.php.dist
@@ -0,0 +1,137 @@
+--- config/sources.php.dist.orig Tue Feb 8 21:43:47 2005
++++ config/sources.php.dist Sun Feb 13 15:54:12 2005
+@@ -454,72 +454,72 @@
+ * automatically populated with the current username.
+ */
+ // First, get the user name
+-$uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
+-$pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
+-if (!strlen($uid)) {
+- $uid = Auth::getAuth();
+- if (preg_match('/(^.*)@/', $uid, $matches)) {
+- $uid = $matches[1];
+- }
+- $pass = Auth::getCredential('password');
+-}
+-
+-$cfgSources['imsp'] = array(
+- 'title' => _("IMSP"),
+- 'type' => 'imsp',
+- 'params' => array(
+- 'server' => 'localhost',
+- 'port' => '406',
+- 'username' => $uid,
+- 'password' => $pass,
+- 'name' => $uid,
+- 'auth_method' => 'cram_md5',
+- 'group_id_field' => 'group',
+- 'group_id_value' => 'group',
+- 'contact_ownership' => false
+- ),
+- 'map' => array(
+- '__key' => 'name',
+- '__type' => '__type',
+- '__members' => '__members',
+- '__owner' => '__owner',
+- '__uid' => '__uid',
+- 'name' => 'fullname',
+- 'email' => 'email',
+- 'alias' => 'alias',
+- 'company' => 'company',
+- 'notes' => 'notes',
+- 'workPhone' => 'phone-work',
+- 'fax' => 'fax',
+- 'homePhone' => 'phone-home',
+- 'cellPhone' => 'cellphone',
+- 'freebusyUrl' => 'freebusyUrl'
+- ),
+- 'search' => array(
+- 'name',
+- 'email',
+- 'alias',
+- 'company',
+- 'homePhone'
+- ),
+- 'strict' => array(),
+- 'public' => false,
+- 'readonly' => false,
+- 'export' => true
+- );
++//UNCOMMENTIFIMSP $uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
++//UNCOMMENTIFIMSP $pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
++//UNCOMMENTIFIMSP if (!strlen($uid)) {
++//UNCOMMENTIFIMSP $uid = Auth::getAuth();
++//UNCOMMENTIFIMSP if (preg_match('/(^.*)@/', $uid, $matches)) {
++//UNCOMMENTIFIMSP $uid = $matches[1];
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP $pass = Auth::getCredential('password');
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP
++//UNCOMMENTIFIMSP $cfgSources['imsp'] = array(
++//UNCOMMENTIFIMSP 'title' => _("IMSP"),
++//UNCOMMENTIFIMSP 'type' => 'imsp',
++//UNCOMMENTIFIMSP 'params' => array(
++//UNCOMMENTIFIMSP 'server' => 'localhost',
++//UNCOMMENTIFIMSP 'port' => '406',
++//UNCOMMENTIFIMSP 'username' => $uid,
++//UNCOMMENTIFIMSP 'password' => $pass,
++//UNCOMMENTIFIMSP 'name' => $uid,
++//UNCOMMENTIFIMSP 'auth_method' => 'cram_md5',
++//UNCOMMENTIFIMSP 'group_id_field' => 'group',
++//UNCOMMENTIFIMSP 'group_id_value' => 'group',
++//UNCOMMENTIFIMSP 'contact_ownership' => false
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'map' => array(
++//UNCOMMENTIFIMSP '__key' => 'name',
++//UNCOMMENTIFIMSP '__type' => '__type',
++//UNCOMMENTIFIMSP '__members' => '__members',
++//UNCOMMENTIFIMSP '__owner' => '__owner',
++//UNCOMMENTIFIMSP '__uid' => '__uid',
++//UNCOMMENTIFIMSP 'name' => 'fullname',
++//UNCOMMENTIFIMSP 'email' => 'email',
++//UNCOMMENTIFIMSP 'alias' => 'alias',
++//UNCOMMENTIFIMSP 'company' => 'company',
++//UNCOMMENTIFIMSP 'notes' => 'notes',
++//UNCOMMENTIFIMSP 'workPhone' => 'phone-work',
++//UNCOMMENTIFIMSP 'fax' => 'fax',
++//UNCOMMENTIFIMSP 'homePhone' => 'phone-home',
++//UNCOMMENTIFIMSP 'cellPhone' => 'cellphone',
++//UNCOMMENTIFIMSP 'freebusyUrl' => 'freebusyUrl'
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'search' => array(
++//UNCOMMENTIFIMSP 'name',
++//UNCOMMENTIFIMSP 'email',
++//UNCOMMENTIFIMSP 'alias',
++//UNCOMMENTIFIMSP 'company',
++//UNCOMMENTIFIMSP 'homePhone'
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'strict' => array(),
++//UNCOMMENTIFIMSP 'public' => false,
++//UNCOMMENTIFIMSP 'readonly' => false,
++//UNCOMMENTIFIMSP 'export' => true
++//UNCOMMENTIFIMSP );
+
+ /**
+ * Get any other addressbooks this user might be privy to.
+ */
+-require_once 'Net/IMSP/Utils.php';
+-$result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
+-if (!is_a($result, 'PEAR_Error')) {
+- for ($i = 0; $i < count($result); $i++) {
+- $cfgSources[sprintf('imsp%d', $i + 1)] = $result[$i];
+- }
+-} else {
+- $notification->push($result);
+-}
++//UNCOMMENTIFIMSP require_once 'Net/IMSP/Utils.php';
++//UNCOMMENTIFIMSP $result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
++//UNCOMMENTIFIMSP if (!is_a($result, 'PEAR_Error')) {
++//UNCOMMENTIFIMSP for ($i = 0; $i < count($result); $i++) {
++//UNCOMMENTIFIMSP $cfgSources[sprintf('imsp%d', $i + 1)] = $result[$i];
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP } else {
++//UNCOMMENTIFIMSP $notification->push($result);
++//UNCOMMENTIFIMSP }
+
+ /* Begin Kolab sources. */
+ if (!empty($GLOBALS['conf']['kolab']['enabled'])) {
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index c67ca3b72ee2..2621ef05451f 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -27,6 +27,8 @@ COMMENT= The Horde contact management application
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
#
+# - WITH_IMSP : run IMSP cyrus-imspd.
+#
#-----------------------------------------------------------------------
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
@@ -55,11 +57,22 @@ CONFDIR= ${TURBADIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
+.if exists(${LOCALBASE}/sbin/imspd)
+WITH_IMSP= yes
+.endif
+.if defined(WITH_IMSP)
+RUN_DEPENDS+= imspd:${PORTSDIR}/databases/cyrus-imspd
+.endif
+
pre-configure:
+ @${RM} ${WRKSRC}/config/sources.php.dist.orig
@${SED} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${FILESDIR}/httpd.conf.turba > ${WRKDIR}/httpd.conf.turba
@${REINPLACE_CMD} -e "s:/usr/bin/ldapadd:${LOCALBASE}/bin/ldapadd:" \
${WRKSRC}/scripts/ldap/addou.pl
+.if defined(WITH_IMSP)
+ @${REINPLACE_CMD} -e "s://UNCOMMENTIFIMSP ::" ${WRKSRC}/config/sources.php.dist
+.endif
do-install:
@${MKDIR} ${TURBADIR}
diff --git a/mail/horde4-turba/files/patch-config::sources.php.dist b/mail/horde4-turba/files/patch-config::sources.php.dist
new file mode 100644
index 000000000000..b3d2dca409fe
--- /dev/null
+++ b/mail/horde4-turba/files/patch-config::sources.php.dist
@@ -0,0 +1,137 @@
+--- config/sources.php.dist.orig Tue Feb 8 21:43:47 2005
++++ config/sources.php.dist Sun Feb 13 15:54:12 2005
+@@ -454,72 +454,72 @@
+ * automatically populated with the current username.
+ */
+ // First, get the user name
+-$uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
+-$pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
+-if (!strlen($uid)) {
+- $uid = Auth::getAuth();
+- if (preg_match('/(^.*)@/', $uid, $matches)) {
+- $uid = $matches[1];
+- }
+- $pass = Auth::getCredential('password');
+-}
+-
+-$cfgSources['imsp'] = array(
+- 'title' => _("IMSP"),
+- 'type' => 'imsp',
+- 'params' => array(
+- 'server' => 'localhost',
+- 'port' => '406',
+- 'username' => $uid,
+- 'password' => $pass,
+- 'name' => $uid,
+- 'auth_method' => 'cram_md5',
+- 'group_id_field' => 'group',
+- 'group_id_value' => 'group',
+- 'contact_ownership' => false
+- ),
+- 'map' => array(
+- '__key' => 'name',
+- '__type' => '__type',
+- '__members' => '__members',
+- '__owner' => '__owner',
+- '__uid' => '__uid',
+- 'name' => 'fullname',
+- 'email' => 'email',
+- 'alias' => 'alias',
+- 'company' => 'company',
+- 'notes' => 'notes',
+- 'workPhone' => 'phone-work',
+- 'fax' => 'fax',
+- 'homePhone' => 'phone-home',
+- 'cellPhone' => 'cellphone',
+- 'freebusyUrl' => 'freebusyUrl'
+- ),
+- 'search' => array(
+- 'name',
+- 'email',
+- 'alias',
+- 'company',
+- 'homePhone'
+- ),
+- 'strict' => array(),
+- 'public' => false,
+- 'readonly' => false,
+- 'export' => true
+- );
++//UNCOMMENTIFIMSP $uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
++//UNCOMMENTIFIMSP $pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
++//UNCOMMENTIFIMSP if (!strlen($uid)) {
++//UNCOMMENTIFIMSP $uid = Auth::getAuth();
++//UNCOMMENTIFIMSP if (preg_match('/(^.*)@/', $uid, $matches)) {
++//UNCOMMENTIFIMSP $uid = $matches[1];
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP $pass = Auth::getCredential('password');
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP
++//UNCOMMENTIFIMSP $cfgSources['imsp'] = array(
++//UNCOMMENTIFIMSP 'title' => _("IMSP"),
++//UNCOMMENTIFIMSP 'type' => 'imsp',
++//UNCOMMENTIFIMSP 'params' => array(
++//UNCOMMENTIFIMSP 'server' => 'localhost',
++//UNCOMMENTIFIMSP 'port' => '406',
++//UNCOMMENTIFIMSP 'username' => $uid,
++//UNCOMMENTIFIMSP 'password' => $pass,
++//UNCOMMENTIFIMSP 'name' => $uid,
++//UNCOMMENTIFIMSP 'auth_method' => 'cram_md5',
++//UNCOMMENTIFIMSP 'group_id_field' => 'group',
++//UNCOMMENTIFIMSP 'group_id_value' => 'group',
++//UNCOMMENTIFIMSP 'contact_ownership' => false
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'map' => array(
++//UNCOMMENTIFIMSP '__key' => 'name',
++//UNCOMMENTIFIMSP '__type' => '__type',
++//UNCOMMENTIFIMSP '__members' => '__members',
++//UNCOMMENTIFIMSP '__owner' => '__owner',
++//UNCOMMENTIFIMSP '__uid' => '__uid',
++//UNCOMMENTIFIMSP 'name' => 'fullname',
++//UNCOMMENTIFIMSP 'email' => 'email',
++//UNCOMMENTIFIMSP 'alias' => 'alias',
++//UNCOMMENTIFIMSP 'company' => 'company',
++//UNCOMMENTIFIMSP 'notes' => 'notes',
++//UNCOMMENTIFIMSP 'workPhone' => 'phone-work',
++//UNCOMMENTIFIMSP 'fax' => 'fax',
++//UNCOMMENTIFIMSP 'homePhone' => 'phone-home',
++//UNCOMMENTIFIMSP 'cellPhone' => 'cellphone',
++//UNCOMMENTIFIMSP 'freebusyUrl' => 'freebusyUrl'
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'search' => array(
++//UNCOMMENTIFIMSP 'name',
++//UNCOMMENTIFIMSP 'email',
++//UNCOMMENTIFIMSP 'alias',
++//UNCOMMENTIFIMSP 'company',
++//UNCOMMENTIFIMSP 'homePhone'
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'strict' => array(),
++//UNCOMMENTIFIMSP 'public' => false,
++//UNCOMMENTIFIMSP 'readonly' => false,
++//UNCOMMENTIFIMSP 'export' => true
++//UNCOMMENTIFIMSP );
+
+ /**
+ * Get any other addressbooks this user might be privy to.
+ */
+-require_once 'Net/IMSP/Utils.php';
+-$result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
+-if (!is_a($result, 'PEAR_Error')) {
+- for ($i = 0; $i < count($result); $i++) {
+- $cfgSources[sprintf('imsp%d', $i + 1)] = $result[$i];
+- }
+-} else {
+- $notification->push($result);
+-}
++//UNCOMMENTIFIMSP require_once 'Net/IMSP/Utils.php';
++//UNCOMMENTIFIMSP $result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
++//UNCOMMENTIFIMSP if (!is_a($result, 'PEAR_Error')) {
++//UNCOMMENTIFIMSP for ($i = 0; $i < count($result); $i++) {
++//UNCOMMENTIFIMSP $cfgSources[sprintf('imsp%d', $i + 1)] = $result[$i];
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP } else {
++//UNCOMMENTIFIMSP $notification->push($result);
++//UNCOMMENTIFIMSP }
+
+ /* Begin Kolab sources. */
+ if (!empty($GLOBALS['conf']['kolab']['enabled'])) {
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
index c67ca3b72ee2..2621ef05451f 100644
--- a/mail/turba/Makefile
+++ b/mail/turba/Makefile
@@ -27,6 +27,8 @@ COMMENT= The Horde contact management application
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
#
+# - WITH_IMSP : run IMSP cyrus-imspd.
+#
#-----------------------------------------------------------------------
RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
@@ -55,11 +57,22 @@ CONFDIR= ${TURBADIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
+.if exists(${LOCALBASE}/sbin/imspd)
+WITH_IMSP= yes
+.endif
+.if defined(WITH_IMSP)
+RUN_DEPENDS+= imspd:${PORTSDIR}/databases/cyrus-imspd
+.endif
+
pre-configure:
+ @${RM} ${WRKSRC}/config/sources.php.dist.orig
@${SED} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${FILESDIR}/httpd.conf.turba > ${WRKDIR}/httpd.conf.turba
@${REINPLACE_CMD} -e "s:/usr/bin/ldapadd:${LOCALBASE}/bin/ldapadd:" \
${WRKSRC}/scripts/ldap/addou.pl
+.if defined(WITH_IMSP)
+ @${REINPLACE_CMD} -e "s://UNCOMMENTIFIMSP ::" ${WRKSRC}/config/sources.php.dist
+.endif
do-install:
@${MKDIR} ${TURBADIR}
diff --git a/mail/turba/files/patch-config::sources.php.dist b/mail/turba/files/patch-config::sources.php.dist
new file mode 100644
index 000000000000..b3d2dca409fe
--- /dev/null
+++ b/mail/turba/files/patch-config::sources.php.dist
@@ -0,0 +1,137 @@
+--- config/sources.php.dist.orig Tue Feb 8 21:43:47 2005
++++ config/sources.php.dist Sun Feb 13 15:54:12 2005
+@@ -454,72 +454,72 @@
+ * automatically populated with the current username.
+ */
+ // First, get the user name
+-$uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
+-$pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
+-if (!strlen($uid)) {
+- $uid = Auth::getAuth();
+- if (preg_match('/(^.*)@/', $uid, $matches)) {
+- $uid = $matches[1];
+- }
+- $pass = Auth::getCredential('password');
+-}
+-
+-$cfgSources['imsp'] = array(
+- 'title' => _("IMSP"),
+- 'type' => 'imsp',
+- 'params' => array(
+- 'server' => 'localhost',
+- 'port' => '406',
+- 'username' => $uid,
+- 'password' => $pass,
+- 'name' => $uid,
+- 'auth_method' => 'cram_md5',
+- 'group_id_field' => 'group',
+- 'group_id_value' => 'group',
+- 'contact_ownership' => false
+- ),
+- 'map' => array(
+- '__key' => 'name',
+- '__type' => '__type',
+- '__members' => '__members',
+- '__owner' => '__owner',
+- '__uid' => '__uid',
+- 'name' => 'fullname',
+- 'email' => 'email',
+- 'alias' => 'alias',
+- 'company' => 'company',
+- 'notes' => 'notes',
+- 'workPhone' => 'phone-work',
+- 'fax' => 'fax',
+- 'homePhone' => 'phone-home',
+- 'cellPhone' => 'cellphone',
+- 'freebusyUrl' => 'freebusyUrl'
+- ),
+- 'search' => array(
+- 'name',
+- 'email',
+- 'alias',
+- 'company',
+- 'homePhone'
+- ),
+- 'strict' => array(),
+- 'public' => false,
+- 'readonly' => false,
+- 'export' => true
+- );
++//UNCOMMENTIFIMSP $uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
++//UNCOMMENTIFIMSP $pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
++//UNCOMMENTIFIMSP if (!strlen($uid)) {
++//UNCOMMENTIFIMSP $uid = Auth::getAuth();
++//UNCOMMENTIFIMSP if (preg_match('/(^.*)@/', $uid, $matches)) {
++//UNCOMMENTIFIMSP $uid = $matches[1];
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP $pass = Auth::getCredential('password');
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP
++//UNCOMMENTIFIMSP $cfgSources['imsp'] = array(
++//UNCOMMENTIFIMSP 'title' => _("IMSP"),
++//UNCOMMENTIFIMSP 'type' => 'imsp',
++//UNCOMMENTIFIMSP 'params' => array(
++//UNCOMMENTIFIMSP 'server' => 'localhost',
++//UNCOMMENTIFIMSP 'port' => '406',
++//UNCOMMENTIFIMSP 'username' => $uid,
++//UNCOMMENTIFIMSP 'password' => $pass,
++//UNCOMMENTIFIMSP 'name' => $uid,
++//UNCOMMENTIFIMSP 'auth_method' => 'cram_md5',
++//UNCOMMENTIFIMSP 'group_id_field' => 'group',
++//UNCOMMENTIFIMSP 'group_id_value' => 'group',
++//UNCOMMENTIFIMSP 'contact_ownership' => false
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'map' => array(
++//UNCOMMENTIFIMSP '__key' => 'name',
++//UNCOMMENTIFIMSP '__type' => '__type',
++//UNCOMMENTIFIMSP '__members' => '__members',
++//UNCOMMENTIFIMSP '__owner' => '__owner',
++//UNCOMMENTIFIMSP '__uid' => '__uid',
++//UNCOMMENTIFIMSP 'name' => 'fullname',
++//UNCOMMENTIFIMSP 'email' => 'email',
++//UNCOMMENTIFIMSP 'alias' => 'alias',
++//UNCOMMENTIFIMSP 'company' => 'company',
++//UNCOMMENTIFIMSP 'notes' => 'notes',
++//UNCOMMENTIFIMSP 'workPhone' => 'phone-work',
++//UNCOMMENTIFIMSP 'fax' => 'fax',
++//UNCOMMENTIFIMSP 'homePhone' => 'phone-home',
++//UNCOMMENTIFIMSP 'cellPhone' => 'cellphone',
++//UNCOMMENTIFIMSP 'freebusyUrl' => 'freebusyUrl'
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'search' => array(
++//UNCOMMENTIFIMSP 'name',
++//UNCOMMENTIFIMSP 'email',
++//UNCOMMENTIFIMSP 'alias',
++//UNCOMMENTIFIMSP 'company',
++//UNCOMMENTIFIMSP 'homePhone'
++//UNCOMMENTIFIMSP ),
++//UNCOMMENTIFIMSP 'strict' => array(),
++//UNCOMMENTIFIMSP 'public' => false,
++//UNCOMMENTIFIMSP 'readonly' => false,
++//UNCOMMENTIFIMSP 'export' => true
++//UNCOMMENTIFIMSP );
+
+ /**
+ * Get any other addressbooks this user might be privy to.
+ */
+-require_once 'Net/IMSP/Utils.php';
+-$result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
+-if (!is_a($result, 'PEAR_Error')) {
+- for ($i = 0; $i < count($result); $i++) {
+- $cfgSources[sprintf('imsp%d', $i + 1)] = $result[$i];
+- }
+-} else {
+- $notification->push($result);
+-}
++//UNCOMMENTIFIMSP require_once 'Net/IMSP/Utils.php';
++//UNCOMMENTIFIMSP $result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
++//UNCOMMENTIFIMSP if (!is_a($result, 'PEAR_Error')) {
++//UNCOMMENTIFIMSP for ($i = 0; $i < count($result); $i++) {
++//UNCOMMENTIFIMSP $cfgSources[sprintf('imsp%d', $i + 1)] = $result[$i];
++//UNCOMMENTIFIMSP }
++//UNCOMMENTIFIMSP } else {
++//UNCOMMENTIFIMSP $notification->push($result);
++//UNCOMMENTIFIMSP }
+
+ /* Begin Kolab sources. */
+ if (!empty($GLOBALS['conf']['kolab']['enabled'])) {