aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-09-22 07:14:00 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-09-22 07:14:00 +0000
commit2de6d0986dae57ce2a2baf19795979345fcd04eb (patch)
tree8ee9853fe205829d45d09bb5071a0eb81239e5b4
parentbdd9216c88016e918329a645f08c54d9beaa6c16 (diff)
downloadports-2de6d0986dae57ce2a2baf19795979345fcd04eb.tar.gz
ports-2de6d0986dae57ce2a2baf19795979345fcd04eb.zip
Notes
-rw-r--r--archivers/pecl-rar/Makefile2
-rw-r--r--databases/pecl-cassandra/Makefile1
-rw-r--r--databases/pecl-couchbase/Makefile2
-rw-r--r--databases/pecl-memcached/Makefile1
-rw-r--r--databases/pecl-rrd/Makefile1
-rw-r--r--devel/ioncube/Makefile1
-rw-r--r--devel/pecl-APCu/Makefile1
-rw-r--r--devel/pecl-eio/Makefile2
-rw-r--r--devel/pecl-event/Makefile1
-rw-r--r--devel/pecl-msgpack/Makefile1
-rw-r--r--devel/pecl-mustache/Makefile1
-rw-r--r--devel/pecl-protobuf/Makefile1
-rw-r--r--devel/pecl-raphf2/Makefile1
-rw-r--r--devel/pecl-request/Makefile2
-rw-r--r--devel/pecl-weakref2/Makefile2
-rw-r--r--devel/pecl-xdebug/Makefile1
-rw-r--r--devel/pecl-yac/Makefile2
-rw-r--r--devel/pecl-yaconf/Makefile2
-rw-r--r--devel/pecl-zookeeper/Makefile1
-rw-r--r--devel/phabricator/Makefile1
-rw-r--r--graphics/php-geos/Makefile1
-rw-r--r--mail/nextcloud-mail/Makefile1
-rw-r--r--mail/pecl-mailparse/Makefile1
-rw-r--r--net/pecl-amqp/Makefile1
-rw-r--r--net/pecl-oauth2/Makefile1
-rw-r--r--net/pecl-yaz/Makefile2
-rw-r--r--security/nextcloud-passman/Makefile1
-rw-r--r--security/nextcloud-twofactor_totp/Makefile1
-rw-r--r--security/nextcloud-twofactor_u2f/Makefile1
-rw-r--r--textproc/php-mecab/Makefile1
-rw-r--r--www/nextcloud-calendar/Makefile1
-rw-r--r--www/nextcloud-contacts/Makefile1
-rw-r--r--www/nextcloud-notes/Makefile1
-rw-r--r--www/nextcloud-tasks/Makefile1
-rw-r--r--www/nextcloud/Makefile1
-rw-r--r--www/owncloud/Makefile1
-rw-r--r--www/pecl-http/Makefile1
-rw-r--r--www/pecl-solr/Makefile1
-rw-r--r--www/pecl-yaf/Makefile1
-rw-r--r--www/pecl-yar/Makefile1
-rw-r--r--www/phalcon/Makefile1
41 files changed, 41 insertions, 8 deletions
diff --git a/archivers/pecl-rar/Makefile b/archivers/pecl-rar/Makefile
index 33c935ed1468..3d080b79f9c7 100644
--- a/archivers/pecl-rar/Makefile
+++ b/archivers/pecl-rar/Makefile
@@ -12,7 +12,7 @@ LICENSE= PHP301
USES= php:pecl
USE_PHP= spl:build
-IGNORE_WITH_PHP= 73
+IGNORE_WITH_PHP= 73 74
CONFIGURE_ARGS= --enable-rar
diff --git a/databases/pecl-cassandra/Makefile b/databases/pecl-cassandra/Makefile
index bff5483a8f37..7fff232f7aa2 100644
--- a/databases/pecl-cassandra/Makefile
+++ b/databases/pecl-cassandra/Makefile
@@ -15,5 +15,6 @@ LIB_DEPENDS= libuv.so:devel/libuv \
libgmp.so:math/gmp
USES= php:pecl localbase
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/databases/pecl-couchbase/Makefile b/databases/pecl-couchbase/Makefile
index 0b9b0fc40c65..6a7bf70d855d 100644
--- a/databases/pecl-couchbase/Makefile
+++ b/databases/pecl-couchbase/Makefile
@@ -16,6 +16,6 @@ LIB_DEPENDS= libcouchbase.so:databases/libcouchbase
USES= php:pecl
USE_PHP= json:build
-IGNORE_WITH_PHP= 73
+IGNORE_WITH_PHP= 73 74
.include <bsd.port.mk>
diff --git a/databases/pecl-memcached/Makefile b/databases/pecl-memcached/Makefile
index 8d9c99bb8224..5c566a8e4741 100644
--- a/databases/pecl-memcached/Makefile
+++ b/databases/pecl-memcached/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= libmemcached.so:databases/libmemcached
USES= php:pecl pkgconfig
USE_PHP= json:build session:build
+IGNORE_WITH_PHP= 74
CONFIGURE_ARGS= --with-libmemcached-dir=${LOCALBASE}
diff --git a/databases/pecl-rrd/Makefile b/databases/pecl-rrd/Makefile
index 4ffc491e9e80..54c6bd3148e0 100644
--- a/databases/pecl-rrd/Makefile
+++ b/databases/pecl-rrd/Makefile
@@ -12,5 +12,6 @@ LICENSE= PHP301
LIB_DEPENDS= librrd.so:databases/rrdtool
USES= php:pecl localbase pkgconfig
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/devel/ioncube/Makefile b/devel/ioncube/Makefile
index 50f5dfd80461..9d52007f001d 100644
--- a/devel/ioncube/Makefile
+++ b/devel/ioncube/Makefile
@@ -23,6 +23,7 @@ IGNORE_DragonFly= is unsupported on DragonFly
ONLY_FOR_ARCHS= amd64 i386
NO_BUILD= yes
USES= php:flavors
+IGNORE_WITH_PHP= 74
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/pecl-APCu/Makefile b/devel/pecl-APCu/Makefile
index 6a7a8fb86915..bf5157e1906b 100644
--- a/devel/pecl-APCu/Makefile
+++ b/devel/pecl-APCu/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS_INSTALL= pecl-APC
USES= localbase php:pecl
+IGNORE_WITH_PHP= 74
PHP_MODNAME= ${PORTNAME:tl}
PLIST_FILES= ${DATADIR}/apc.php
diff --git a/devel/pecl-eio/Makefile b/devel/pecl-eio/Makefile
index a3aec8b2ee0f..a2c179181a9b 100644
--- a/devel/pecl-eio/Makefile
+++ b/devel/pecl-eio/Makefile
@@ -12,6 +12,6 @@ LICENSE= PHP301
CONFIGURE_ARGS= --enable-eio
USES= php:pecl
-IGNORE_WITH_PHP= 73
+IGNORE_WITH_PHP= 73 74
.include <bsd.port.mk>
diff --git a/devel/pecl-event/Makefile b/devel/pecl-event/Makefile
index 1d3575a6b48f..1686e333e127 100644
--- a/devel/pecl-event/Makefile
+++ b/devel/pecl-event/Makefile
@@ -17,5 +17,6 @@ LIB_DEPENDS= libevent.so:devel/libevent
USES= php:pecl ssl
CONFIGURE_ARGS= --with-openssl-dir=${OPENSSLBASE}
USE_PHP= sockets:build
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/devel/pecl-msgpack/Makefile b/devel/pecl-msgpack/Makefile
index 5d1dfc73d777..b12eb5f48901 100644
--- a/devel/pecl-msgpack/Makefile
+++ b/devel/pecl-msgpack/Makefile
@@ -11,5 +11,6 @@ COMMENT= Provides API for communicating with MessagePack serialization
LICENSE= BSD3CLAUSE
USES= php:pecl
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/devel/pecl-mustache/Makefile b/devel/pecl-mustache/Makefile
index 003a0b611cbf..b2bbba18716d 100644
--- a/devel/pecl-mustache/Makefile
+++ b/devel/pecl-mustache/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
LIB_DEPENDS= libmustache.so:devel/libmustache
USES= compiler:c++11-lang php:pecl
+IGNORE_WITH_PHP= 74
USE_CXXSTD= c++11
diff --git a/devel/pecl-protobuf/Makefile b/devel/pecl-protobuf/Makefile
index 7ac80df26d7a..549f8cdec2a3 100644
--- a/devel/pecl-protobuf/Makefile
+++ b/devel/pecl-protobuf/Makefile
@@ -12,5 +12,6 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= localbase php:pecl
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/devel/pecl-raphf2/Makefile b/devel/pecl-raphf2/Makefile
index 1d77017e4871..c5b1fe010d56 100644
--- a/devel/pecl-raphf2/Makefile
+++ b/devel/pecl-raphf2/Makefile
@@ -16,5 +16,6 @@ PORTSCOUT= limit:^2.*
USES= gmake php:pecl
CONFLICTS= pecl-raphf-1*
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/devel/pecl-request/Makefile b/devel/pecl-request/Makefile
index 985156a3e444..5c15928ad2cd 100644
--- a/devel/pecl-request/Makefile
+++ b/devel/pecl-request/Makefile
@@ -12,6 +12,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
USES= php:pecl
-IGNORE_WITH_PHP= 72 73
+IGNORE_WITH_PHP= 72 73 74
.include <bsd.port.mk>
diff --git a/devel/pecl-weakref2/Makefile b/devel/pecl-weakref2/Makefile
index e5af7321467c..e09b980e1308 100644
--- a/devel/pecl-weakref2/Makefile
+++ b/devel/pecl-weakref2/Makefile
@@ -13,7 +13,7 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
-IGNORE_WITH_PHP= 73
+IGNORE_WITH_PHP= 73 74
CONFLICTS= pecl-weakref-1*
diff --git a/devel/pecl-xdebug/Makefile b/devel/pecl-xdebug/Makefile
index 79f0f30267a4..fd5787147aba 100644
--- a/devel/pecl-xdebug/Makefile
+++ b/devel/pecl-xdebug/Makefile
@@ -13,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFIGURE_ARGS= --enable-xdebug
USES= php:pecl,zend tar:tgz
+IGNORE_WITH_PHP= 74
SUB_FILES= pkg-message
diff --git a/devel/pecl-yac/Makefile b/devel/pecl-yac/Makefile
index 29844444186a..67b9ed858b97 100644
--- a/devel/pecl-yac/Makefile
+++ b/devel/pecl-yac/Makefile
@@ -12,7 +12,7 @@ COMMENT= Yac is a shared memory user data cache for PHP
LICENSE= PHP301
USES= php:pecl
-IGNORE_WITH_PHP= 73
+IGNORE_WITH_PHP= 73 74
OPTIONS_DEFINE= MSGPACK
MSGPACK_DESC= Enable MSGPACK module
diff --git a/devel/pecl-yaconf/Makefile b/devel/pecl-yaconf/Makefile
index a2d77046de15..eab8fbffacd7 100644
--- a/devel/pecl-yaconf/Makefile
+++ b/devel/pecl-yaconf/Makefile
@@ -11,7 +11,7 @@ COMMENT= PHP Persistent Configurations Container
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 73
+IGNORE_WITH_PHP= 73 74
USES= php:pecl
.include <bsd.port.mk>
diff --git a/devel/pecl-zookeeper/Makefile b/devel/pecl-zookeeper/Makefile
index 9ba9b1be6f11..054a0b224110 100644
--- a/devel/pecl-zookeeper/Makefile
+++ b/devel/pecl-zookeeper/Makefile
@@ -15,6 +15,7 @@ LIB_DEPENDS= libzookeeper_mt.so:devel/libzookeeper
USES= php:pecl
USE_PHP= session:build
+IGNORE_WITH_PHP= 74
PORTDATA= zookeeper-api.php
diff --git a/devel/phabricator/Makefile b/devel/phabricator/Makefile
index dd89834555fa..cfa56bf69395 100644
--- a/devel/phabricator/Makefile
+++ b/devel/phabricator/Makefile
@@ -16,6 +16,7 @@ RUN_DEPENDS= ${PHP_PKGNAMEPREFIX}libphutil>=20190831:devel/libphutil@${PHP_FLAVO
git:devel/git
USES= php:flavors shebangfix
+IGNORE_WITH_PHP= 74
REINPLACE_ARGS= -i ""
SHEBANG_FILES= scripts/*.php \
diff --git a/graphics/php-geos/Makefile b/graphics/php-geos/Makefile
index 17a1cf606744..fbba974042e9 100644
--- a/graphics/php-geos/Makefile
+++ b/graphics/php-geos/Makefile
@@ -22,6 +22,7 @@ BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libgeos_c.so:graphics/geos
USES= localbase:ldflags php:ext
+IGNORE_WITH_PHP= 74
WRKSRC= ${WRKDIR}/php-${PORTNAME}
diff --git a/mail/nextcloud-mail/Makefile b/mail/nextcloud-mail/Makefile
index 84b4c4c21ae5..9f7ac94b256b 100644
--- a/mail/nextcloud-mail/Makefile
+++ b/mail/nextcloud-mail/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=16:www/nextcloud@${PHP_FLAVOR}
USES= gettext php:flavors
USE_PHP= imap
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/mail/pecl-mailparse/Makefile b/mail/pecl-mailparse/Makefile
index 4f094627ab8d..ddf76d99e3fe 100644
--- a/mail/pecl-mailparse/Makefile
+++ b/mail/pecl-mailparse/Makefile
@@ -13,5 +13,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
USE_PHP= mbstring:build
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/net/pecl-amqp/Makefile b/net/pecl-amqp/Makefile
index 4e7608a863c1..a9f0ff6a3539 100644
--- a/net/pecl-amqp/Makefile
+++ b/net/pecl-amqp/Makefile
@@ -14,5 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= librabbitmq.so:net/rabbitmq-c-devel
USES= php:pecl
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/net/pecl-oauth2/Makefile b/net/pecl-oauth2/Makefile
index 5d2dd264d01b..7ae5911ce0be 100644
--- a/net/pecl-oauth2/Makefile
+++ b/net/pecl-oauth2/Makefile
@@ -14,6 +14,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libpcre.so:devel/pcre
USES= php:pecl
+IGNORE_WITH_PHP= 74
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/pecl-yaz/Makefile b/net/pecl-yaz/Makefile
index cf51a1944520..f90f8a40f7a1 100644
--- a/net/pecl-yaz/Makefile
+++ b/net/pecl-yaz/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libyaz.so:net/yaz
USES= php:pecl
USE_GNOME+= libxslt
-IGNORE_WITH_PHP= 73
+IGNORE_WITH_PHP= 73 74
CONFIGURE_ARGS= --with-yaz=${LOCALBASE}
diff --git a/security/nextcloud-passman/Makefile b/security/nextcloud-passman/Makefile
index 09ded52e3eb1..f34c9fa25108 100644
--- a/security/nextcloud-passman/Makefile
+++ b/security/nextcloud-passman/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=14:www/nextcloud@${PHP_FLAVOR}
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= php:flavors
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-twofactor_totp/Makefile b/security/nextcloud-twofactor_totp/Makefile
index 97662f704bd4..92a2974a1042 100644
--- a/security/nextcloud-twofactor_totp/Makefile
+++ b/security/nextcloud-twofactor_totp/Makefile
@@ -20,6 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=15:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-twofactor_u2f/Makefile b/security/nextcloud-twofactor_u2f/Makefile
index 7595f6f07747..5cecf683a95f 100644
--- a/security/nextcloud-twofactor_u2f/Makefile
+++ b/security/nextcloud-twofactor_u2f/Makefile
@@ -20,6 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=16:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/textproc/php-mecab/Makefile b/textproc/php-mecab/Makefile
index 13553335c387..0b9aed9dacdf 100644
--- a/textproc/php-mecab/Makefile
+++ b/textproc/php-mecab/Makefile
@@ -22,5 +22,6 @@ GH_PROJECT= php-${PORTNAME}
WRKSRC_SUBDIR= mecab
CONFIGURE_ARGS= --with-mecab=${LOCALBASE}/bin/mecab-config
USES= php:ext
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/www/nextcloud-calendar/Makefile b/www/nextcloud-calendar/Makefile
index 2e61db90fd47..66dda7aba9dc 100644
--- a/www/nextcloud-calendar/Makefile
+++ b/www/nextcloud-calendar/Makefile
@@ -19,6 +19,7 @@ LICENSE= AGPLv3
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=15.9:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/nextcloud-contacts/Makefile b/www/nextcloud-contacts/Makefile
index 85e9dbb625b8..c3f08a24c49a 100644
--- a/www/nextcloud-contacts/Makefile
+++ b/www/nextcloud-contacts/Makefile
@@ -20,6 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=15:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/nextcloud-notes/Makefile b/www/nextcloud-notes/Makefile
index 0bb06f8c3a7b..588139a19414 100644
--- a/www/nextcloud-notes/Makefile
+++ b/www/nextcloud-notes/Makefile
@@ -19,6 +19,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=15:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/nextcloud-tasks/Makefile b/www/nextcloud-tasks/Makefile
index 65fdd6d99b87..70faf9a55a1b 100644
--- a/www/nextcloud-tasks/Makefile
+++ b/www/nextcloud-tasks/Makefile
@@ -20,6 +20,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=15:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
+IGNORE_WITH_PHP= 74
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/nextcloud/Makefile b/www/nextcloud/Makefile
index 802a709f0abe..51df4ab6982a 100644
--- a/www/nextcloud/Makefile
+++ b/www/nextcloud/Makefile
@@ -15,6 +15,7 @@ USES= cpe gettext-runtime php:flavors,web tar:bzip2
USE_PHP= bz2 ctype curl dom fileinfo filter gd hash iconv json \
mbstring pdo posix session simplexml xml xmlreader xmlwriter \
xsl wddx zip zlib
+IGNORE_WITH_PHP= 74
NEXTCLOUD_USERNAME?= ${WWWOWN}
NEXTCLOUD_GROUPNAME?= ${WWWGRP}
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
index 58151598d63b..820cddd8e43e 100644
--- a/www/owncloud/Makefile
+++ b/www/owncloud/Makefile
@@ -17,6 +17,7 @@ USES= cpe php:flavors,web tar:bzip2
USE_PHP= bz2 ctype curl dom fileinfo filter gd hash iconv intl json \
mbstring pdo posix session simplexml xml xmlreader xmlwriter \
xsl wddx zip zlib
+IGNORE_WITH_PHP= 74
NO_ARCH= yes
NO_BUILD= yes
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index e87f07b34abb..644f8c0a539c 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -26,6 +26,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= php:pecl
USE_PHP= zlib:build
+IGNORE_WITH_PHP= 74
CONFLICTS= pecl-http[12]*
diff --git a/www/pecl-solr/Makefile b/www/pecl-solr/Makefile
index dff3cb5d6407..806e967c6ef9 100644
--- a/www/pecl-solr/Makefile
+++ b/www/pecl-solr/Makefile
@@ -16,5 +16,6 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= php:pecl
USE_PHP= json:build
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/www/pecl-yaf/Makefile b/www/pecl-yaf/Makefile
index 8ba57d21a774..435da9a2b3a9 100644
--- a/www/pecl-yaf/Makefile
+++ b/www/pecl-yaf/Makefile
@@ -15,5 +15,6 @@ LIB_DEPENDS= libpcre.so:devel/pcre
CONFIGURE_ARGS= --with-php-config=${LOCALBASE}/bin/php-config
USES= localbase php:pecl
+IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/www/pecl-yar/Makefile b/www/pecl-yar/Makefile
index fadbe31c39bf..52a5b9fb1f0f 100644
--- a/www/pecl-yar/Makefile
+++ b/www/pecl-yar/Makefile
@@ -13,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= localbase php:pecl
USE_PHP= json:build curl:build
+IGNORE_WITH_PHP= 74
OPTIONS_DEFINE= MSGPACK
MSGPACK_DESC= Enable MSGPACK module
diff --git a/www/phalcon/Makefile b/www/phalcon/Makefile
index 2b330577c90c..976f7ea7e675 100644
--- a/www/phalcon/Makefile
+++ b/www/phalcon/Makefile
@@ -16,6 +16,7 @@ ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
USES= php:ext
USE_PHP= hash:build json:build pdo:build
+IGNORE_WITH_PHP= 74
USE_GITHUB= yes
GH_ACCOUNT= phalcon