aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-04-02 23:43:40 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-04-02 23:43:40 +0000
commit2f04cd375f4d5f7c8d3f52821600579fa98de438 (patch)
tree9dfddb99c79b0319b20573e9ecdc0bfda07f1335
parent09cf723a01d7b2674d7b11484559df7e94b866ed (diff)
downloadports-2f04cd375f4d5f7c8d3f52821600579fa98de438.tar.gz
ports-2f04cd375f4d5f7c8d3f52821600579fa98de438.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pynmsg/Makefile25
-rw-r--r--net/py-pynmsg/distinfo2
-rw-r--r--net/py-pynmsg/pkg-descr5
4 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 01fb9f8e0bdc..d22ae534bfec 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -929,6 +929,7 @@
SUBDIR += py-port-for
SUBDIR += py-pybeanstalk
SUBDIR += py-pygeoip
+ SUBDIR += py-pynmsg
SUBDIR += py-pynsq
SUBDIR += py-pypcap
SUBDIR += py-pysendfile
diff --git a/net/py-pynmsg/Makefile b/net/py-pynmsg/Makefile
new file mode 100644
index 000000000000..111c54865bfb
--- /dev/null
+++ b/net/py-pynmsg/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= pynmsg
+PORTVERSION= 0.3.1
+CATEGORIES= net python
+MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= Python wrapper for net/nmsg
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libnmsg.so:${PORTSDIR}/net/nmsg
+
+USE_PYTHON= distutils autoplist
+
+CPPFLAGS+= -I${LOCALBASE}/include
+
+USES= python
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/python2.7/site-packages/_nmsg.so
+
+.include <bsd.port.mk>
diff --git a/net/py-pynmsg/distinfo b/net/py-pynmsg/distinfo
new file mode 100644
index 000000000000..df1b14be6cd0
--- /dev/null
+++ b/net/py-pynmsg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pynmsg-0.3.1.tar.gz) = ee913ff099ef43543a70103a0642c2aa9e298402d73fa74def9fce50fc95c14a
+SIZE (pynmsg-0.3.1.tar.gz) = 103168
diff --git a/net/py-pynmsg/pkg-descr b/net/py-pynmsg/pkg-descr
new file mode 100644
index 000000000000..94b7ce2d5f9e
--- /dev/null
+++ b/net/py-pynmsg/pkg-descr
@@ -0,0 +1,5 @@
+This is pynmsg, a Python extension module implemented in Cython for
+the nmsg C library.
+
+
+WWW: https://github.com/farsightsec/pynmsg