aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-12-05 12:02:24 +0000
committerDima Panov <fluffy@FreeBSD.org>2020-12-05 12:02:24 +0000
commit373b40e4870c76510a1a7a6469e515f8ece5e379 (patch)
tree6ca05ae888e0159f25d3507f5a7f90270eb4aeed
parent8d7f96864aa529dbe8130aebef852eed76ae690c (diff)
downloadports-373b40e4870c76510a1a7a6469e515f8ece5e379.tar.gz
ports-373b40e4870c76510a1a7a6469e515f8ece5e379.zip
MFH: r557051
editors/libreoffice: simplify QT5 on FreeBSD < 12 logic - Enables QT5 by default on DragonFly - Enables QT5 when DEFAULT_VERSIONS += ssl=openssl - Doesn't need to be adjusted when 14.0-CURRENT appears PR: 251450 Submitted by: jbeich Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q4/; revision=557052
-rw-r--r--editors/libreoffice/Makefile10
-rw-r--r--editors/libreoffice6/Makefile10
2 files changed, 12 insertions, 8 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index b28c6358fcc1..359d5dec8091 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -121,10 +121,12 @@ USES= autoreconf:build bison compiler:c++17-lang cpe desktop-file-utils \
pkgconfig python:3.5+ shebangfix shared-mime-info ssl tar:xz xorg
OPTIONS_DEFINE= COINMP CUPS DOCS GNOME GTK3 JAVA KF5 MMEDIA PGSQL QT5 SDK TEST WEBDAV
-OPTIONS_DEFAULT= CUPS MMEDIA
-OPTIONS_DEFAULT_FreeBSD_12= QT5
-OPTIONS_DEFAULT_FreeBSD_13= QT5
-OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${OPSYS}_${OSREL:R}}
+OPTIONS_DEFAULT= CUPS MMEDIA QT5
+
+.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mssl=*}
+# Blocked by net/qt5-network: cannot use QT5 with default OpenSSL
+OPTIONS_EXCLUDE_FreeBSD_11+= QT5
+.endif
COINMP_DESC= Enable CoinMP (deprecated) math solver
GTK3_DESC= GTK+ 3 GUI toolkit support (incomplete visual style)
diff --git a/editors/libreoffice6/Makefile b/editors/libreoffice6/Makefile
index 5bdef7e22e60..e3439973de12 100644
--- a/editors/libreoffice6/Makefile
+++ b/editors/libreoffice6/Makefile
@@ -120,10 +120,12 @@ USES= autoreconf:build bison compiler:c++14-lang cpe desktop-file-utils \
pkgconfig python shebangfix shared-mime-info ssl tar:xz xorg
OPTIONS_DEFINE= CUPS DOCS GNOME GTK3 I18N JAVA KF5 MMEDIA PGSQL QT5 SDK TEST WEBDAV
-OPTIONS_DEFAULT= CUPS MMEDIA
-OPTIONS_DEFAULT_FreeBSD_12= QT5
-OPTIONS_DEFAULT_FreeBSD_13= QT5
-OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${OPSYS}_${OSREL:R}}
+OPTIONS_DEFAULT= CUPS MMEDIA QT5
+
+.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mssl=*}
+# Blocked by net/qt5-network: cannot use QT5 with default OpenSSL
+OPTIONS_EXCLUDE_FreeBSD_11+= QT5
+.endif
GTK3_DESC= GTK+ 3 GUI toolkit support (incomplete visual style)
I18N_DESC= Build i18n resources