aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-01 19:24:00 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-01 19:24:00 +0000
commit3980169c5f07bd29aca9d4622d79e2992d3adb6a (patch)
treee590a1fe25ef8fd6c3924c68296537c795f3af31
parent25b71d968896ec6828ca461daccf177519d7cd7f (diff)
downloadports-3980169c5f07bd29aca9d4622d79e2992d3adb6a.tar.gz
ports-3980169c5f07bd29aca9d4622d79e2992d3adb6a.zip
Notes
-rw-r--r--audio/gnomoradio/Makefile2
-rw-r--r--audio/musicpd/Makefile1
-rw-r--r--audio/umurmur/Makefile3
-rw-r--r--biology/crux/Makefile3
-rw-r--r--biology/seqan-apps/Makefile2
-rw-r--r--cad/alliance/Makefile2
-rw-r--r--editors/texstudio/Makefile3
-rw-r--r--emulators/catapult/Makefile3
-rw-r--r--emulators/dtcyber/Makefile1
-rw-r--r--emulators/pearpc/Makefile2
-rw-r--r--emulators/x49gp/Makefile2
11 files changed, 22 insertions, 2 deletions
diff --git a/audio/gnomoradio/Makefile b/audio/gnomoradio/Makefile
index 9cd7eceb9bee..9d16d1a7b4b3 100644
--- a/audio/gnomoradio/Makefile
+++ b/audio/gnomoradio/Makefile
@@ -13,6 +13,8 @@ COMMENT= Program for finding and playing free music from the Internet
LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libao.so:audio/libao
+BROKEN_aarch64= fails to compile: error: expected ';' at end of declaration list
+
USES= pathfix pkgconfig libtool
GNU_CONFIGURE= yes
USE_GNOME= gconfmm26 gnomeprefix gtkmm24
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 2ade163c8e8c..df90d25360ce 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -28,6 +28,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/sidplay/builders
#Workaround (transient?) link error with libwrap
CONFIGURE_ARGS+=--disable-libwrap
+BROKEN_aarch64= Does not build: fatal error: 'endian.h' file not found
BROKEN_powerpc64= Does not build on powerpc64
PORTDOCS= AUTHORS README.md COPYING NEWS
diff --git a/audio/umurmur/Makefile b/audio/umurmur/Makefile
index eaca9c4741e3..7d289e57fb20 100644
--- a/audio/umurmur/Makefile
+++ b/audio/umurmur/Makefile
@@ -14,6 +14,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libconfig.so:devel/libconfig \
libprotobuf-c.so:devel/protobuf-c
+BROKEN_aarch64= fails to compile: fatal error: byteswap.h file not found
+BROKEN_armv6= fails to compile: fatal error: byteswap.h file not found
+
USE_GITHUB= yes
USES= autoreconf gmake libtool ssl
diff --git a/biology/crux/Makefile b/biology/crux/Makefile
index 50dc846b8459..0e33f688b500 100644
--- a/biology/crux/Makefile
+++ b/biology/crux/Makefile
@@ -13,6 +13,9 @@ COMMENT= Software toolkit for phylogenetic inference
LICENSE= BSD2CLAUSE BSD3CLAUSE
LICENSE_COMB= multi
+BROKEN_aarch64= Fails to link: ImportError: /lib/libgcc_s.so.1: version GCC_4.5.0 required by /usr/local/lib/gcc5/libgfortran.so.3 not found
+BROKEN_armv64= Fails to link: ImportError: /usr/local/lib/gcc49/libgfortran.so.3: Undefined symbol "__aeabi_ldivmod"
+
USES= fortran gmake python tar:bzip2
USE_CSTD= gnu99
GNU_CONFIGURE= yes
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
index 0191a80d8a5a..5b20f03f759e 100644
--- a/biology/seqan-apps/Makefile
+++ b/biology/seqan-apps/Makefile
@@ -26,7 +26,9 @@ CMAKE_ARGS= -DSEQAN_BUILD_SYSTEM="SEQAN_RELEASE_APPS"
USE_GCC= yes
+BROKEN_aarch64= fails to compile: Error: unknown mnemonic rep -- rep
BROKEN_armv6= fails to link: undefined reference to _Unwind_GetIP@GCC_3.0
+BROKEN_powerpc64= fails to compile: Error: unrecognized opcode: rep
.include <bsd.port.pre.mk>
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index deab3e824c8b..28e04d902d3a 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -17,6 +17,8 @@ LICENSE_NAME= Alliance VLSI Cad System License
LICENSE_FILE= ${WRKSRC}/LICENCE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_aarch64= fails to link: collect2: error: ld returned 1 exit status
+
WRKSRC= ${WRKDIR}/alliance-5.0
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index 2c3863d8c2c2..036eea9c3991 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -12,6 +12,9 @@ COMMENT= Integrated writing environment for LaTeX documents
LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
libpoppler.so:graphics/poppler
+BROKEN_aarch64= fails to compile: error: no member named mc_eip in __mcontext
+BROKEN_armv6= fails to compile: error: no member named mc_eip in __mcontext
+
USES= desktop-file-utils dos2unix execinfo ghostscript:run \
pkgconfig qmake
DOS2UNIX_FILES= ${PORTNAME}.pro
diff --git a/emulators/catapult/Makefile b/emulators/catapult/Makefile
index 8d1c4dead7fe..7ee2a0064bc6 100644
--- a/emulators/catapult/Makefile
+++ b/emulators/catapult/Makefile
@@ -36,6 +36,9 @@ MAKE_ARGS= INSTALL_BASE="${PREFIX}" \
MAKE_JOBS_UNSAFE= yes
+BROKEN_aarch64= fails to link: fails to detect libxml2 even though it is installed
+BROKEN_armv6= fails to link: fails to detect libxml2 even though it is installed
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
diff --git a/emulators/dtcyber/Makefile b/emulators/dtcyber/Makefile
index 33a90cb98f79..1c6c0ea8a675 100644
--- a/emulators/dtcyber/Makefile
+++ b/emulators/dtcyber/Makefile
@@ -24,6 +24,7 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/dtcyber %%EXAMPLESDIR%%/cyber.ini %%EXAMPLESDIR%%/cos.tap
BROKEN_aarch64= Fails to compile: error: Unable to determine size of basic data types
+BROKEN_armv6= Fails to compile: error: Unable to determine size of basic data types
BROKEN_mips64= Fails to compile: error: Unable to determine size of basic data types
do-install:
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 58435a01e975..041cb3396381 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -16,8 +16,6 @@ USES= tar:bzip2
USE_XORG= x11
GNU_CONFIGURE= yes
-BROKEN_ia64= internal compiler error on ia64
-
PORTEXAMPLES= ppccfg.example
PLIST_FILES= bin/ppc man/man1/ppc.1.gz %%DATADIR%%/video.x
diff --git a/emulators/x49gp/Makefile b/emulators/x49gp/Makefile
index f2268a376ba2..7153c50faa24 100644
--- a/emulators/x49gp/Makefile
+++ b/emulators/x49gp/Makefile
@@ -14,6 +14,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= shaun@FreeBSD.org
COMMENT= HP 49g+/50g graphics calculator emulator
+BROKEN_aarch64= does not build on arm: unsupported CPU = unknown
+BROKEN_armv6= does not build on arm: unsupported CPU = unknown
BROKEN_i386= does not build on i386 (error: frame pointer required, but reserved)
WRKSRC= ${WRKDIR}/x49gp/x49gp-code