aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-01-24 23:37:03 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-01-24 23:37:03 +0000
commit3d818d82d3b74a6a6ff33f62e5ac801b11a4e54c (patch)
treed2dc2e68c2d200be42fa08f1bb4c1becfddda547
parent95c0e17d9106e7117e7b80d343ca210a89d1f40a (diff)
downloadports-3d818d82d3b74a6a6ff33f62e5ac801b11a4e54c.tar.gz
ports-3d818d82d3b74a6a6ff33f62e5ac801b11a4e54c.zip
Notes
-rw-r--r--security/nss/Makefile12
-rw-r--r--security/nss/distinfo6
-rw-r--r--security/nss/files/patch-..::coreconf::FreeBSD.mk29
-rw-r--r--security/nss/files/patch-..::coreconf::command.mk9
-rw-r--r--security/nss/files/patch-certutil.c72
-rw-r--r--security/nss/files/patch-cmd::platlibs.mk34
-rw-r--r--security/nss/files/patch-crlgen.c24
-rw-r--r--security/nss/files/patch-lib::ckfw::builtins::Makefile16
-rw-r--r--security/nss/files/patch-lib::fortcrypt::swfort::pkcs11::Makefile16
-rw-r--r--security/nss/files/patch-sysdb43
-rw-r--r--security/nss/files/patch-warnings119
-rw-r--r--security/nss/pkg-plist22
12 files changed, 137 insertions, 265 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 69470f1f6250..dc49513b5c3c 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nss
-PORTVERSION= 3.10
+PORTVERSION= 3.11
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= security/nss/releases/NSS_${PORTVERSION:S/./_/g}_RTM/src
@@ -30,16 +30,13 @@ CFLAGS+= -I${LOCALBASE}/include/nspr
DIST= ${WRKSRC:H:H}/dist
-CONFLICTS= btoa-5.* digest-[0-9]* emboss-2.* oases-2.* p5-PAR-0.* \
- qmail-ldap2-[0-9]*
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
IGNORE= core dumps on alpha during build
.endif
-EXTERNALS= CVS dbm security/nss/cmd/zlib
+EXTERNALS= CVS dbm security/nss/cmd/zlib nsprpub security/dbm
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
${EXTERNALS:C,^,--exclude ${DISTNAME}/mozilla/,}
@@ -78,8 +75,9 @@ do-install:
${TAR} -C ${PREFIX}/include/nss -xf -
${INSTALL_PROGRAM} ${DIST}/FreeBSD${OSREL:C/.$/*/}_OPT.OBJ/lib/*.so.1 \
${PREFIX}/lib
- ${INSTALL_PROGRAM} ${DIST}/FreeBSD${OSREL:C/.$/*/}_OPT.OBJ/bin/* \
- ${PREFIX}/bin
+ ${INSTALL_PROGRAM} `${SED} \
+ -e 's|^bin/|${DIST}/FreeBSD${OSREL:C/.$/*/}_OPT.OBJ/bin/|' \
+ -e t -e d ${PLIST}` ${PREFIX}/bin/
cd ${DIST}/FreeBSD${OSREL:C/.$/*/}_OPT.OBJ/lib && \
${TAR} -cf - *.so | ${TAR} --unlink -C ${PREFIX}/lib -xf -
diff --git a/security/nss/distinfo b/security/nss/distinfo
index 10f422988bb4..257832aca93b 100644
--- a/security/nss/distinfo
+++ b/security/nss/distinfo
@@ -1,3 +1,3 @@
-MD5 (nss-3.10.tar.gz) = f0d75d52aff21f88d9c055bdb78f54f8
-SHA256 (nss-3.10.tar.gz) = 47448f60cdfb7447e8337d91a472c821c2b74c785a3033e16034bd17b8df8812
-SIZE (nss-3.10.tar.gz) = 3622858
+MD5 (nss-3.11.tar.gz) = 9be73bd73e361e5e36edf77f456fa20a
+SHA256 (nss-3.11.tar.gz) = 35b65a672c699f1e5fc082fccc29bcc65102ef8d31cff106f2ec68beace96809
+SIZE (nss-3.11.tar.gz) = 5002908
diff --git a/security/nss/files/patch-..::coreconf::FreeBSD.mk b/security/nss/files/patch-..::coreconf::FreeBSD.mk
index 39398a72567b..0dda9f75b060 100644
--- a/security/nss/files/patch-..::coreconf::FreeBSD.mk
+++ b/security/nss/files/patch-..::coreconf::FreeBSD.mk
@@ -1,7 +1,6 @@
---- ../coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
-+++ ../coreconf/FreeBSD.mk Sat Apr 17 21:25:24 2004
-@@ -35,9 +35,9 @@
-
+--- ../coreconf/FreeBSD.mk Fri Sep 16 13:09:23 2005
++++ ../coreconf/FreeBSD.mk Wed Jan 18 18:30:48 2006
+@@ -38,7 +38,7 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
-DEFAULT_COMPILER = gcc
@@ -12,27 +11,27 @@
+CCC = $(CXX)
RANLIB = ranlib
- ifeq ($(OS_TEST),alpha)
-@@ -47,6 +47,8 @@
- endif
+@@ -50,6 +50,12 @@
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
+OS_LIBS = $(BSD_LDOPTS)
+OPTIMIZER =
++ifeq ($(OS_TEST),sparc64)
DSO_CFLAGS = -fPIC
++else
++DSO_CFLAGS = -fpic
++endif
DSO_LDOPTS = -shared -Wl,-soname -Wl,$(notdir $@)
-@@ -58,7 +60,7 @@
- USE_PTHREADS = 1
+
+@@ -61,5 +67,5 @@
DEFINES += -D_THREAD_SAFE -D_REENTRANT
OS_LIBS += -pthread
-DSO_LDOPTS += -pthread
+DSO_LDOPTS += $(BSD_LDOPTS)
endif
- ARCH = freebsd
-@@ -66,12 +68,16 @@
- MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
+@@ -69,10 +75,14 @@
ifeq ($(MOZ_OBJFORMAT),elf)
-DLL_SUFFIX = so
@@ -49,4 +48,8 @@
+endif
ifdef MAPFILE
# Add LD options to restrict exported symbols to those in the map file
- endif
+@@ -84,2 +94,4 @@
+
+ INCLUDES += -I/usr/X11R6/include
++USE_SYSTEM_ZLIB = 1
++ZLIB_LIBS = -lz
diff --git a/security/nss/files/patch-..::coreconf::command.mk b/security/nss/files/patch-..::coreconf::command.mk
index e39f9b8c7ea7..1a5bae069f27 100644
--- a/security/nss/files/patch-..::coreconf::command.mk
+++ b/security/nss/files/patch-..::coreconf::command.mk
@@ -1,14 +1,11 @@
-
$FreeBSD$
---- ../coreconf/command.mk 2002/08/08 17:20:41 1.1
-+++ ../coreconf/command.mk 2002/08/08 17:20:54
-@@ -42,7 +42,7 @@
+--- ../coreconf/command.mk Mon Oct 10 19:46:12 2005
++++ ../coreconf/command.mk Wed Jan 18 17:23:28 2006
+@@ -46,5 +46,5 @@
LINK_DLL = $(LINK) $(OS_DLLFLAGS) $(DLLFLAGS)
LINK_EXE = $(LINK) $(OS_LFLAGS) $(LFLAGS)
- NFSPWD = $(NSINSTALL_DIR)/nfspwd
-CFLAGS = $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
+CFLAGS += $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
$(XCFLAGS)
RANLIB = echo
- TAR = /bin/tar
diff --git a/security/nss/files/patch-certutil.c b/security/nss/files/patch-certutil.c
deleted file mode 100644
index 357ddaf78e79..000000000000
--- a/security/nss/files/patch-certutil.c
+++ /dev/null
@@ -1,72 +0,0 @@
---- cmd/certutil/certutil.c Fri Apr 22 22:12:00 2005
-+++ cmd/certutil/certutil.c Fri Jul 22 02:02:20 2005
-@@ -131,3 +131,3 @@
- fflush (stdout);
-- if (gets (buffer) == NULL) {
-+ if (fgets(buffer, sizeof buffer, stdin) == NULL) {
- PORT_SetError(SEC_ERROR_INPUT_LEN);
-@@ -206,3 +206,3 @@
- puts (prompt);
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
- if (strlen (buffer) > 0) {
-@@ -1424,3 +1424,3 @@
- fprintf(stdout, "%-25s Other to finish\n", "");
-- if (gets (buffer)) {
-+ if (fgets(buffer, sizeof buffer, stdin)) {
- value = atoi (buffer);
-@@ -1439,3 +1439,3 @@
- puts ("Is this a critical extension [y/n]? ");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
-
-@@ -1580,3 +1580,3 @@
-
-- if (gets(buffer) == NULL) {
-+ if (fgets(buffer, sizeof buffer, stdin) == NULL) {
- PORT_SetError(SEC_ERROR_INPUT_LEN);
-@@ -1621,3 +1621,3 @@
- puts ("Is this a critical extension [y/n]? ");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
-
-@@ -1650,3 +1650,3 @@
- fprintf(stdout, "%-25s Other to finish\n", "");
-- if (gets (buffer) == NULL) {
-+ if (fgets(buffer, sizeof buffer, stdin) == NULL) {
- PORT_SetError(SEC_ERROR_INPUT_LEN);
-@@ -1664,3 +1664,3 @@
- puts ("Is this a critical extension [y/n]? ");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
-
-@@ -1769,3 +1769,3 @@
- puts ("Is this a CA certificate [y/n]?");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
- basicConstraint.isCA = (buffer[0] == 'Y' || buffer[0] == 'y') ?
-@@ -1774,3 +1774,3 @@
- puts ("Enter the path length constraint, enter to skip [<0 for unlimited path]:");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
- if (PORT_Strlen (buffer) > 0)
-@@ -1784,3 +1784,3 @@
- puts ("Is this a critical extension [y/n]? ");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
- rv = CERT_AddExtension
-@@ -1908,3 +1908,3 @@
- puts ("Is this a critical extension [y/n]? ");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
-
-@@ -1963,3 +1963,3 @@
- fflush (stdout);
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
- /* For simplicity, use CERT_AsciiToName to converse from a string
-@@ -2031,3 +2031,3 @@
- puts ("Is this a critical extension [y/n]? ");
-- gets (buffer);
-+ fgets(buffer, sizeof buffer, stdin);
-
diff --git a/security/nss/files/patch-cmd::platlibs.mk b/security/nss/files/patch-cmd::platlibs.mk
index 73d609023faa..635107cd0648 100644
--- a/security/nss/files/patch-cmd::platlibs.mk
+++ b/security/nss/files/patch-cmd::platlibs.mk
@@ -9,43 +9,9 @@ $FreeBSD$
- $(DIST)/lib/$(LIB_PREFIX)dbm.$(LIB_SUFFIX) \
$(DIST)/lib/$(NSPR31_LIB_PREFIX)plc4.$(LIB_SUFFIX) \
$(DIST)/lib/$(NSPR31_LIB_PREFIX)plds4.$(LIB_SUFFIX) \
-@@ -85,5 +84,4 @@
-
- JAR_LIBS = $(DIST)/lib/$(LIB_PREFIX)jar.$(LIB_SUFFIX) \
-- $(DIST)/lib/$(LIB_PREFIX)zlib.$(LIB_SUFFIX) \
- $(NULL)
- else
@@ -120,5 +118,4 @@
$(CRYPTOLIB) \
$(DIST)/lib/$(LIB_PREFIX)secutil.$(LIB_SUFFIX) \
- $(DIST)/lib/$(LIB_PREFIX)dbm.$(LIB_SUFFIX) \
$(NULL)
-@@ -141,4 +138,5 @@
- -lplds4 \
- -lnspr4 \
-+ -lz \
- $(NULL)
- endif
-@@ -146,5 +144,4 @@
-
- JAR_LIBS = $(DIST)/lib/$(LIB_PREFIX)jar.$(LIB_SUFFIX) \
-- $(DIST)/lib/$(LIB_PREFIX)zlib.$(LIB_SUFFIX) \
- $(NULL)
-
-@@ -171,5 +168,4 @@
-
- JAR_LIBS = $(DIST)/lib/$(LIB_PREFIX)jar.$(LIB_SUFFIX) \
-- $(DIST)/lib/$(LIB_PREFIX)zlib.$(LIB_SUFFIX) \
- $(NULL)
- else
-@@ -226,8 +222,8 @@
- -lplds4 \
- -lnspr4 \
-+ -lz \
- $(NULL)
-
- JAR_LIBS = $(DIST)/lib/$(LIB_PREFIX)jar.$(LIB_SUFFIX) \
-- $(DIST)/lib/$(LIB_PREFIX)zlib.$(LIB_SUFFIX) \
- $(NULL)
- endif
diff --git a/security/nss/files/patch-crlgen.c b/security/nss/files/patch-crlgen.c
index 119ea98e8465..c7a655c0b8f5 100644
--- a/security/nss/files/patch-crlgen.c
+++ b/security/nss/files/patch-crlgen.c
@@ -103,27 +103,3 @@
+ "AddCert(%s, %s) insufficient number of arguments.\n", certId, revocationDate);
return SECFailure;
}
-@@ -1362,12 +1362,12 @@
- }
-
- if (extStr->extData == NULL) {
-- extStr->extData = PORT_ZAlloc(MAX_EXT_DATA_LENGTH);
-+ extStr->extData = PORT_ZNewArray(char *, MAX_EXT_DATA_LENGTH);
- if (!extStr->extData) {
- return SECFailure;
- }
- }
-- if (extStr->nextUpdatedData > MAX_EXT_DATA_LENGTH) {
-+ if (extStr->nextUpdatedData >= MAX_EXT_DATA_LENGTH) {
- PORT_SetError(SEC_ERROR_INVALID_ARGS);
- crlgen_PrintError(crlGenData->parsedLineNum,
- "number of fields in extension "
-@@ -1415,7 +1415,7 @@
- PORT_Free(crlGenData->certEntry);
- break;
- case CRLGEN_ADD_EXTENSION_CONTEXT:
-- if (crlGenData->extensionEntry->nextUpdatedData) {
-+ if (crlGenData->extensionEntry->extData) {
- int i = 0;
- for (;i < crlGenData->extensionEntry->nextUpdatedData;i++)
- PORT_Free(*(crlGenData->extensionEntry->extData + i));
diff --git a/security/nss/files/patch-lib::ckfw::builtins::Makefile b/security/nss/files/patch-lib::ckfw::builtins::Makefile
deleted file mode 100644
index a8e77802956d..000000000000
--- a/security/nss/files/patch-lib::ckfw::builtins::Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- lib/ckfw/builtins/Makefile.orig Sat Feb 16 00:53:42 2002
-+++ lib/ckfw/builtins/Makefile Thu Aug 8 21:29:48 2002
-@@ -54,8 +54,8 @@
- else
-
- EXTRA_LIBS += \
-- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
-- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
-+ -lplc4 \
-+ -lplds4 \
- $(NULL)
-
- endif
diff --git a/security/nss/files/patch-lib::fortcrypt::swfort::pkcs11::Makefile b/security/nss/files/patch-lib::fortcrypt::swfort::pkcs11::Makefile
deleted file mode 100644
index 07cb5b91c2d9..000000000000
--- a/security/nss/files/patch-lib::fortcrypt::swfort::pkcs11::Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- lib/fortcrypt/swfort/pkcs11/Makefile.orig Sat Feb 16 00:53:46 2002
-+++ lib/fortcrypt/swfort/pkcs11/Makefile Thu Aug 8 21:27:33 2002
-@@ -76,8 +76,8 @@
- $(DIST)/lib/$(LIB_PREFIX)softokn.$(LIB_SUFFIX) \
- $(CRYPTO_LIB) \
- $(DIST)/lib/$(LIB_PREFIX)secutil.$(LIB_SUFFIX) \
-- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
-- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
-+ -lplc4 \
-+ -lplds4 \
- $(NULL)
-
- endif
diff --git a/security/nss/files/patch-sysdb b/security/nss/files/patch-sysdb
index ec8d9acc7d7a..f8101b93d445 100644
--- a/security/nss/files/patch-sysdb
+++ b/security/nss/files/patch-sysdb
@@ -160,15 +160,6 @@ and the db-implementation from -lc. Seems to work on FreeBSD.
+#include <db.h>
NSS_EXTERN_DATA NSSCKMDInstance nss_dbm_mdInstance;
---- lib/fortcrypt/swfort/swfortti.h Sun Apr 25 11:03:07 2004
-+++ lib/fortcrypt/swfort/swfortti.h Fri Jul 22 01:07:34 2005
-@@ -45,5 +45,5 @@
- #include "maci.h"
- #include "seccomon.h"
--#include "mcom_db.h" /* really should be included by certt.h */
-+#include <db.h> /* really should be included by certt.h */
- #include "certt.h"
- /*#include "keyt.h"*/
--- lib/freebl/mac_rand.c Sun Apr 25 11:03:08 2004
+++ lib/freebl/mac_rand.c Fri Jul 22 01:08:19 2005
@@ -40,5 +40,4 @@
@@ -186,37 +177,3 @@ and the db-implementation from -lc. Seems to work on FreeBSD.
+#include <db.h>
#include "secoidt.h"
#include "secdert.h"
---- lib/fortcrypt/swfort/swflib.c Sun Apr 25 11:03:07 2004
-+++ lib/fortcrypt/swfort/swflib.c Fri Jul 22 01:11:20 2005
-@@ -43,6 +43,7 @@
- */
-
--#include "prtypes.h"
--#include "prio.h"
-+#include <fcntl.h>
-+#include <prtypes.h>
-+#include <prio.h>
-
- #include "swforti.h"
---- lib/fortcrypt/swfort/swfutl.c Sun Apr 25 11:03:07 2004
-+++ lib/fortcrypt/swfort/swfutl.c Fri Jul 22 01:14:05 2005
-@@ -38,7 +38,7 @@
- */
-
--#include "prtypes.h"
--#include "prsystem.h"
--#include "prio.h"
-+#include <prtypes.h>
-+#include <prsystem.h>
-+#include <prio.h>
-
- #include "swforti.h"
-@@ -48,7 +48,6 @@
- #include "secport.h"
- #include "secrng.h"
--#ifdef XP_OS2
-+#include <sys/types.h>
- #include <sys/stat.h>
--#endif
-
- #ifdef XP_WIN
diff --git a/security/nss/files/patch-warnings b/security/nss/files/patch-warnings
index 269fecdfb230..ed10a25868b0 100644
--- a/security/nss/files/patch-warnings
+++ b/security/nss/files/patch-warnings
@@ -10,8 +10,29 @@
+ extern const char * const *environ;
#endif
#ifdef BEOS
---- lib/pk11wrap/pk11obj.c Sun Feb 27 10:25:46 2005
-+++ lib/pk11wrap/pk11obj.c Wed Jul 27 22:03:16 2005
+--- lib/pk11wrap/pk11obj.c Thu Sep 8 22:03:57 2005
++++ lib/pk11wrap/pk11obj.c Wed Jan 18 18:40:19 2006
+@@ -553,5 +553,4 @@
+ CK_ATTRIBUTE theTemplate = { CKA_EC_PARAMS, NULL, 0 };
+ SECItem params = {siBuffer, NULL, 0};
+- int length;
+
+ switch (key->keyType) {
+@@ -570,11 +569,12 @@
+ &theTemplate, 1) == CKR_OK) {
+ if (theTemplate.pValue != NULL) {
++ int length;
+ params.len = theTemplate.ulValueLen;
+ params.data = (unsigned char *) theTemplate.pValue;
+ length = SECKEY_ECParamsToKeySize(&params);
+ PORT_Free(theTemplate.pValue);
++ return ((length + 7)/8) * 2;
+ }
+- length = ((length + 7)/8) * 2;
+- return length;
++ return 0;
+ }
+ break;
@@ -1075,6 +1075,6 @@
* for (thisObj=firstObj; thisObj;
* thisObj=PK11_GetNextGenericObject(thisObj)) {
@@ -61,15 +82,6 @@
- if (slot == NULL) {
PORT_SetError(SEC_ERROR_UNKNOWN_OBJECT_TYPE);
return SECFailure;
---- lib/pk11wrap/pk11util.c Sat Apr 2 01:02:53 2005
-+++ lib/pk11wrap/pk11util.c Wed Jul 27 22:07:54 2005
-@@ -862,5 +862,5 @@
- int i, oldCount;
- PRBool freeRef = PR_FALSE;
-- void *mark;
-+ void *mark = NULL;
- CK_ULONG *slotIDs = NULL;
- PK11SlotInfo **newSlots = NULL;
--- cmd/certcgi/certcgi.c Sat Apr 2 00:24:07 2005
+++ cmd/certcgi/certcgi.c Wed Jul 27 22:01:50 2005
@@ -112,5 +112,5 @@
@@ -350,3 +362,88 @@
-
while (*string == ' ') {
+--- cmd/crmftest/testcrmf.c Fri Oct 7 20:57:31 2005
++++ cmd/crmftest/testcrmf.c Wed Jan 18 18:52:23 2006
+@@ -965,16 +965,4 @@
+ }
+
+-static CK_MECHANISM_TYPE
+-mapWrapKeyType(KeyType keyType)
+-{
+- switch (keyType) {
+- case rsaKey:
+- return CKM_RSA_PKCS;
+- default:
+- break;
+- }
+- return CKM_INVALID_MECHANISM;
+-}
+-
+ #define KNOWN_MESSAGE_LENGTH 20 /*160 bits*/
+
+@@ -1329,5 +1317,5 @@
+ }
+ if (retrieved != randomNums[i]) {
+- printf ("Retrieved the number (%d), expected (%d)\n", retrieved,
++ printf ("Retrieved the number (%ld), expected (%ld)\n", retrieved,
+ randomNums[i]);
+ return 913;
+@@ -1435,5 +1423,4 @@
+ DestroyPair(TESTKeyPair *pair)
+ {
+- SECStatus rv = SECSuccess;
+ int irv = 0;
+
+--- cmd/fipstest/fipstest.c Fri Oct 14 16:04:39 2005
++++ cmd/fipstest/fipstest.c Wed Jan 18 18:59:34 2006
+@@ -426,5 +426,5 @@
+ } else {
+ to_hex_str(keystr, key, 8);
+- printf("%ld\tKEY=%s\t", i, keystr);
++ printf("%d\tKEY=%s\t", i, keystr);
+ }
+ if (iv) {
+@@ -497,5 +497,5 @@
+ } else {
+ to_hex_str(keystr, key, 8);
+- printf("%ld\tKEY=%s\t", i, keystr);
++ printf("%d\tKEY=%s\t", i, keystr);
+ }
+ if (iv) {
+@@ -569,5 +569,5 @@
+ } else {
+ to_hex_str(keystr, keyin, 8);
+- printf("%ld\tKEY=%s\t", i, keystr);
++ printf("%d\tKEY=%s\t", i, keystr);
+ }
+ if (iv) {
+@@ -643,5 +643,5 @@
+ } else {
+ to_hex_str(keystr, keyin, 8);
+- printf("%ld\tKEY=%s\t", i, keystr);
++ printf("%d\tKEY=%s\t", i, keystr);
+ }
+ if (iv) {
+@@ -705,5 +705,5 @@
+ } else {
+ to_hex_str(keystr, keyin, 8);
+- printf("%ld\tKEY=%s\t", i, keystr);
++ printf("%d\tKEY=%s\t", i, keystr);
+ }
+ if (iv) {
+@@ -806,5 +806,5 @@
+ } else {
+ to_hex_str(keystr, keyin, 8);
+- printf("%ld\tKEY=%s\t", i, keystr);
++ printf("%d\tKEY=%s\t", i, keystr);
+ }
+ if (iv) {
+@@ -1981,6 +1981,6 @@
+ unsigned int mod;
+ SECItem digest = { 0 }, sig = { 0 };
+- DSAPublicKey pubkey = { 0 };
+- DSAPrivateKey privkey = { 0 };
++ DSAPublicKey pubkey = {{ 0 }};
++ DSAPrivateKey privkey = {{ 0 }};
+ PQGParams params;
+ PQGVerify verify;
diff --git a/security/nss/pkg-plist b/security/nss/pkg-plist
index 82d820690ed9..3f6c3c2f4d66 100644
--- a/security/nss/pkg-plist
+++ b/security/nss/pkg-plist
@@ -1,21 +1,12 @@
-bin/atob
-bin/addbuiltin
-bin/bltest
-bin/btoa
bin/certcgi
bin/certutil
bin/checkcert
-bin/client
bin/cmsutil
bin/crlutil
-bin/dbtest
bin/derdump
-bin/digest
-bin/instinit
bin/makepqg
bin/mangle
bin/modutil
-bin/newuser
bin/ocspclnt
bin/oidcalc
bin/p7content
@@ -23,18 +14,13 @@ bin/p7env
bin/p7sign
bin/p7verify
bin/pk12util
-bin/pp
bin/rsaperf
-bin/sdrtest
-bin/selfserv
-bin/server
bin/shlibsign
bin/signtool
bin/signver
bin/ssltap
bin/strsclnt
bin/symkeyutil
-bin/tstclnt
bin/vfychain
bin/vfyserv
include/nss/nss/base64.h
@@ -126,11 +112,9 @@ include/nss/nss/ssl.h
include/nss/nss/sslerr.h
include/nss/nss/sslproto.h
include/nss/nss/sslt.h
-include/nss/nss/swfort.h
-include/nss/nss/swfortt.h
include/nss/nss/watcomfx.h
-lib/libfort.so
-lib/libfort.so.1
+lib/libfreebl3.so
+lib/libfreebl3.so.1
lib/libnss3.so
lib/libnss3.so.1
lib/libnssckbi.so
@@ -141,7 +125,5 @@ lib/libsoftokn3.so
lib/libsoftokn3.so.1
lib/libssl3.so
lib/libssl3.so.1
-lib/libswft.so
-lib/libswft.so.1
@dirrm include/nss/nss
@dirrm include/nss