aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2001-04-05 16:57:18 +0000
committerAlexander Langer <alex@FreeBSD.org>2001-04-05 16:57:18 +0000
commit48e913db94ae70b5ae4a4f9febef595464b0be6c (patch)
tree51e766b387256f074e3743a03b15aaf632a699a6
parent703ea01d010a1e754b4d7646875a5f39c3c42a65 (diff)
downloadports-48e913db94ae70b5ae4a4f9febef595464b0be6c.tar.gz
ports-48e913db94ae70b5ae4a4f9febef595464b0be6c.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/varconf/Makefile25
-rw-r--r--games/varconf/distinfo1
-rw-r--r--games/varconf/pkg-comment1
-rw-r--r--games/varconf/pkg-descr5
-rw-r--r--games/varconf/pkg-plist9
6 files changed, 42 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b382835b16b6..b8c848a58064 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -197,6 +197,7 @@
SUBDIR += omega
SUBDIR += twitch
SUBDIR += uox3
+ SUBDIR += varconf
SUBDIR += wmeyes
SUBDIR += wmminichess
SUBDIR += wmtictactoe
diff --git a/games/varconf/Makefile b/games/varconf/Makefile
new file mode 100644
index 000000000000..a5f92dbc4720
--- /dev/null
+++ b/games/varconf/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: varconf
+# Date created: 29 March 2001
+# Whom: Oliver Lehmann <lehmann@ans-netz.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= varconf
+PORTVERSION= 0.3.0
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.ecs.soton.ac.uk/pub/worldforge/libs/varconf/ \
+ ftp://two.woovis.com/pub/worldforge/libs/varconf/ \
+ http://dreadnought.res.cmu.edu/worldforge/libs/varconf/ \
+ http://kafka.i-site.com/~novalis/mirrors/acorn/0.3/src/ \
+ http://65.100.132.89/wf/downloads/libs/varconf/
+
+MAINTAINER= lehmann@ans-netz.de
+
+LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++ \
+ Atlas.0:${PORTSDIR}/devel/Atlas
+
+USE_LIBTOOL= YES
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/games/varconf/distinfo b/games/varconf/distinfo
new file mode 100644
index 000000000000..e424278de7e4
--- /dev/null
+++ b/games/varconf/distinfo
@@ -0,0 +1 @@
+MD5 (varconf-0.3.0.tar.gz) = 962d6ec1ea7b50b6eeafb6a4a41292d7
diff --git a/games/varconf/pkg-comment b/games/varconf/pkg-comment
new file mode 100644
index 000000000000..10abd9a8a4fb
--- /dev/null
+++ b/games/varconf/pkg-comment
@@ -0,0 +1 @@
+A Configuration System for the STAGE Server
diff --git a/games/varconf/pkg-descr b/games/varconf/pkg-descr
new file mode 100644
index 000000000000..d3ea526083db
--- /dev/null
+++ b/games/varconf/pkg-descr
@@ -0,0 +1,5 @@
+Varconf is a configuration system designed for the STAGE server.
+Varconf can parse configuration files, command-line arguments and
+environment variables. It supports callbacks and can store its
+configuration information in separate Config objects or in one
+global configuration instance.
diff --git a/games/varconf/pkg-plist b/games/varconf/pkg-plist
new file mode 100644
index 000000000000..67dd83bab307
--- /dev/null
+++ b/games/varconf/pkg-plist
@@ -0,0 +1,9 @@
+lib/libvarconf.so.0
+lib/libvarconf.la
+lib/libvarconf.a
+include/varconf/Config.h
+include/varconf/parse_error.h
+include/varconf/variable.h
+include/varconf/varconf.h
+bin/conftest
+@dirrm include/varconf