aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-30 13:26:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-30 13:26:46 +0000
commit49d214ae0d0ee6264bfc7b18537fe86720dcdf48 (patch)
tree7533278b8352c4898b8d5810f15e414790a2c7d7
parent37977470c54254727fcfeb73cbdf30567dd23030 (diff)
downloadports-49d214ae0d0ee6264bfc7b18537fe86720dcdf48.tar.gz
ports-49d214ae0d0ee6264bfc7b18537fe86720dcdf48.zip
MFH: r554406
graphics/kmscube: add new port kmscube is a little demonstration program for how to drive bare metal graphics without a compositor like X11, Wayland or similar, using DRM/KMS (kernel mode setting), GBM (graphics buffer manager) and EGL for rendering content using OpenGL or OpenGL ES. https://gitlab.freedesktop.org/mesa/kmscube
Notes
Notes: svn path=/branches/2020Q4/; revision=556640
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/kmscube/Makefile37
-rw-r--r--graphics/kmscube/distinfo3
-rw-r--r--graphics/kmscube/pkg-descr6
4 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7cb5a3aae508..1418c2dd7b25 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -398,6 +398,7 @@
SUBDIR += kipi-plugins
SUBDIR += klatexformula
SUBDIR += kludge3d
+ SUBDIR += kmscube
SUBDIR += kolourpaint
SUBDIR += kooka
SUBDIR += kphotoalbum
diff --git a/graphics/kmscube/Makefile b/graphics/kmscube/Makefile
new file mode 100644
index 000000000000..c5d035e9074a
--- /dev/null
+++ b/graphics/kmscube/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= kmscube
+PORTVERSION= s20201028
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Example KMS/GBM/EGL application
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libdrm.so:graphics/libdrm
+
+USES= gl meson pkgconfig
+USE_GITLAB= yes
+USE_GL= egl gbm glesv2
+GL_SITE= https://gitlab.freedesktop.org
+GL_ACCOUNT= mesa
+GL_COMMIT= e6386d1b99366ea7559438c0d3abd2ae2d6d61ac
+PLIST_FILES= bin/${PORTNAME} \
+ bin/texturator \
+ ${NULL}
+
+OPTIONS_DEFINE= GSTREAMER PNG
+OPTIONS_DEFAULT=PNG
+
+GSTREAMER_USES= gnome
+GSTREAMER_USE= GNOME=glib20 GSTREAMER1=yes
+GSTREAMER_MESON_ENABLED=gstreamer
+
+PNG_LIB_DEPENDS= libpng.so:graphics/png
+
+post-patch-PNG-off:
+ @${REINPLACE_CMD} 's/dep_libpng.found()/false/' ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/graphics/kmscube/distinfo b/graphics/kmscube/distinfo
new file mode 100644
index 000000000000..c388fde29559
--- /dev/null
+++ b/graphics/kmscube/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1603878081
+SHA256 (mesa-kmscube-e6386d1b99366ea7559438c0d3abd2ae2d6d61ac_GL0.tar.gz) = f73c20472ce77599e26dffaece5620809648edc0933d457d4d6cfb04df643067
+SIZE (mesa-kmscube-e6386d1b99366ea7559438c0d3abd2ae2d6d61ac_GL0.tar.gz) = 160482
diff --git a/graphics/kmscube/pkg-descr b/graphics/kmscube/pkg-descr
new file mode 100644
index 000000000000..b6869c1dcab7
--- /dev/null
+++ b/graphics/kmscube/pkg-descr
@@ -0,0 +1,6 @@
+kmscube is a little demonstration program for how to drive bare metal
+graphics without a compositor like X11, Wayland or similar, using
+DRM/KMS (kernel mode setting), GBM (graphics buffer manager) and EGL
+for rendering content using OpenGL or OpenGL ES.
+
+WWW: https://gitlab.freedesktop.org/mesa/kmscube