aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:08:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:08:39 +0000
commit4d5623ea35be1700ed738b3434c31b6e40943604 (patch)
tree9811a15ac44a1c22adc82f032496ba3c52a709f6
parent0d263e77cb9c8fc0d78cb27161bb31c39bbd3910 (diff)
downloadports-4d5623ea35be1700ed738b3434c31b6e40943604.tar.gz
ports-4d5623ea35be1700ed738b3434c31b6e40943604.zip
Notes
-rw-r--r--sysutils/bacula-server-devel/Makefile2
-rw-r--r--sysutils/bacula-server/Makefile2
-rw-r--r--sysutils/daemontools/Makefile2
-rw-r--r--sysutils/freebsd-sha1/Makefile2
-rw-r--r--sysutils/healthd/Makefile7
-rw-r--r--sysutils/linux-acu/Makefile10
-rw-r--r--sysutils/pcfclock/Makefile4
-rw-r--r--www/linuxpluginwrapper/Makefile14
-rw-r--r--www/lynx-current/Makefile6
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid25/Makefile2
-rw-r--r--www/squid30/Makefile2
-rw-r--r--www/squid31/Makefile2
-rw-r--r--www/ssserver/Makefile10
-rw-r--r--x11-wm/ctwm/Makefile3
-rw-r--r--x11/XFree86-4-libraries/Makefile5
16 files changed, 19 insertions, 56 deletions
diff --git a/sysutils/bacula-server-devel/Makefile b/sysutils/bacula-server-devel/Makefile
index f475abea7589..3b68fbdd3fe2 100644
--- a/sysutils/bacula-server-devel/Makefile
+++ b/sysutils/bacula-server-devel/Makefile
@@ -170,7 +170,7 @@ MAKE_ENV+= MAN8="${MAN8}" MAN1="${MAN1}"
pre-everything::
.if !defined(WITH_CLIENT_ONLY)
-.if ${OSVERSION} < 490101 || (${OSVERSION} >= 500000 && ${OSVERSION} < 502101)
+.if ${OSVERSION} < 502101
@${ECHO_MSG} "=======> ATTENTION <======="
@${ECHO_MSG} "===> Note that there is a pthreads problem, which leads to the loss of 500kB"
@${ECHO_MSG} "===> of data at the end of an tape. This is corrected in newer versions of FreeBSD"
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 5c2a54ec61a5..5b7291b8565d 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -192,7 +192,7 @@ MAKE_ENV+= MAN8="${MAN8}" MAN1="${MAN1}"
pre-everything::
.if !defined(WITH_CLIENT_ONLY)
-.if ${OSVERSION} < 490101 || (${OSVERSION} >= 500000 && ${OSVERSION} < 502101)
+.if ${OSVERSION} < 502101
@${ECHO_MSG} "=======> ATTENTION <======="
@${ECHO_MSG} "===> Note that there is a pthreads problem, which leads to the loss of 500kB"
@${ECHO_MSG} "===> of data at the end of an tape. This is corrected in newer versions of FreeBSD"
diff --git a/sysutils/daemontools/Makefile b/sysutils/daemontools/Makefile
index f429215080c6..cdedc2ee4214 100644
--- a/sysutils/daemontools/Makefile
+++ b/sysutils/daemontools/Makefile
@@ -53,7 +53,7 @@ SERVICEDIR?= /var/service
STARTUP_SCRIPT?= ${SAMPLERC:S/.sample//}
PLIST_SUB+= STARTUP_SCRIPT="${STARTUP_SCRIPT}"
-.if ${OSVERSION} >= 500023 || ${OSVERSION} < 500000 && ${OSVERSION} >= 460102
+.if ${OSVERSION} >= 500023
RC_SCRIPTS_SUB+= DAEMON="/usr/sbin/daemon -f"
.else
RC_SCRIPTS_SUB+= DAEMON=""
diff --git a/sysutils/freebsd-sha1/Makefile b/sysutils/freebsd-sha1/Makefile
index 59135e730644..4e3491a91142 100644
--- a/sysutils/freebsd-sha1/Makefile
+++ b/sysutils/freebsd-sha1/Makefile
@@ -23,7 +23,7 @@ PLIST_FILES= sbin/sha1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 502113 || ( ${OSVERSION} > 491100 && ${OSVERSION} < 500000 )
+.if ${OSVERSION} > 502113
IGNORE= "is now contained in the base system"
.endif
diff --git a/sysutils/healthd/Makefile b/sysutils/healthd/Makefile
index dce9fdfe7f99..5f37b20fbcfc 100644
--- a/sysutils/healthd/Makefile
+++ b/sysutils/healthd/Makefile
@@ -30,9 +30,7 @@ INSTALL_TARGET= install-all
HDDOCDIR= ${PREFIX}/share/doc/healthd
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400014 || defined(WITHOUT_IPV6)
+.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
.endif
@@ -57,4 +55,5 @@ pre-everything::
.ifndef (WITHOUT_IPV6)
@${ECHO_MSG} "WITHOUT_IPV6=yes builds without IPv6 support"
.endif
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>
diff --git a/sysutils/linux-acu/Makefile b/sysutils/linux-acu/Makefile
index c8aeaa4af483..145114bf796e 100644
--- a/sysutils/linux-acu/Makefile
+++ b/sysutils/linux-acu/Makefile
@@ -37,16 +37,6 @@ RESTRICTED= "Redistribution not allowed"
LINPROCFS!= /sbin/mount | ${GREP} linprocfs | ${AWK} '{print $1}'
-pre-fetch:
-.if ${OSVERSION} < 460000
- @${ECHO}
- @${ECHO} "OS-VERSION ${OSVERSION} too low"
- @${ECHO}
- @${ECHO} "acu needs some important sys/dev/an changes"
- @${ECHO} "Please upgrade to 4.6-STABLE or greater"
- @${FALSE}
-.endif
-
post-extract:
.if ${LINPROCFS}
@${ECHO}
diff --git a/sysutils/pcfclock/Makefile b/sysutils/pcfclock/Makefile
index dd40d37dbd3d..1862a3c2cc5e 100644
--- a/sysutils/pcfclock/Makefile
+++ b/sysutils/pcfclock/Makefile
@@ -28,10 +28,6 @@ PLIST_FILES= sbin/pcfdate
IGNORE= not supported for architecture ${ARCH}
.endif
-.if ${OSVERSION} < 400000
-IGNORE= not supported for versions prior to FreeBSD 4.0
-.endif
-
post-install:
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/www/linuxpluginwrapper/Makefile b/www/linuxpluginwrapper/Makefile
index 9b941465971d..3ac1f56b2bd9 100644
--- a/www/linuxpluginwrapper/Makefile
+++ b/www/linuxpluginwrapper/Makefile
@@ -38,12 +38,6 @@ RUN_DEPENDS+= ${X11BASE}/Adobe/Acrobat7.0/ENU/Browser/intellinux/nppdf.so:${PORT
WITH_PLUGINS= 1
.endif
-.if defined(WITH_PLUGINS)
-.if ${OSVERSION} < 500000
-USE_MOTIF= yes
-.endif
-.endif
-
ONLY_FOR_ARCHS= i386
MAKE_ENV= EXAMPLESDIR=${EXAMPLESDIR} INSTALL_DATA="${INSTALL_DATA}" INSTALL_PROGRAM="${INSTALL_PROGRAM}"
@@ -51,7 +45,7 @@ CONFLICTS= flashpluginwrapper-*
USE_XLIB= yes
PLIST_SUB= LINUXBASE=${LINUXBASE}
PKGMESSAGE= ${WRKDIR}/pkg-message
-.if !defined(WITH_PLUGINS) || ${OSVERSION} < 500000
+.if !defined(WITH_PLUGINS)
PLIST= ${WRKDIR}/pkg-plist
.endif
@@ -61,10 +55,8 @@ LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD6
LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD6
.elif ${OSVERSION} >= 503001
LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-stable
-.elif ${OSVERSION} >= 500000
-LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-current
.else
-LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD4.x
+LIBMAPCONF= ${EXAMPLESDIR}/libmap.conf-FreeBSD5-current
.endif
.if ${OSVERSION} < 501105
@@ -78,7 +70,7 @@ CFLAGS+= -DDEBUG=1
.endif
.if !defined(PACKAGE_BUILDING)
-.if ${OSVERSION} < 490102 || ${OSVERSION} >= 500000 && ${OSVERSION} < 501107
+.if ${OSVERSION} < 501107
pre-everything::
@if ! strings ${RTLD} | ${GREP} libmap.conf > /dev/null 2>&1; then \
${ECHO_MSG} 'Please enable libmap.conf(5) feature for rtld(1).'; \
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 75d286c2e39c..72398a4f470a 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -48,11 +48,7 @@ CONFIGURE_ARGS+= --with-screen=ncursesw
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
-.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
+CONFIGURE_ARGS+=--enable-ipv6
MAKE_FLAGS= helpdir=${L_HELP} docdir=${L_DOC} -f
MAKEFILE= makefile
INSTALL_TARGET= install-full
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 29e4f322b7b0..5b2299e43284 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -346,7 +346,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= the IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 91f96e13a20a..99a8c20cccac 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -313,7 +313,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 96cfb4ea43cb..73ef1c292acd 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -341,7 +341,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= the IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 96cfb4ea43cb..73ef1c292acd 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -341,7 +341,7 @@ IGNORE= pf available only in FreeBSD 5.3 and newer
# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
# information.
.if defined(WITH_SQUID_IPFILTER)
-.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+.if (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
IGNORE= the IPFilter headers are not part of the base system
.else
CONFIGURE_ARGS+= --enable-ipf-transparent
diff --git a/www/ssserver/Makefile b/www/ssserver/Makefile
index ac7172b132df..58b50b1e6e07 100644
--- a/www/ssserver/Makefile
+++ b/www/ssserver/Makefile
@@ -13,17 +13,13 @@ MASTER_SITES= http://www.kryltech.com/download/FreeBSD.x86.3/
MAINTAINER= support@kryltech.com
COMMENT= Adds the search capability to a Web site
+LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
+
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
INSTALL_RWDATA= ${INSTALL} ${COPY} -o ${SHAREOWN} -g ${SHAREGRP} -m 666
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400000
-LIB_DEPENDS+= c.3:${PORTSDIR}/misc/compat3x
-.endif
-
do-install:
@${MKDIR} ${PREFIX}/www/cgi-bin/ssserverdata
@${INSTALL_PROGRAM} ${WRKSRC}/ssserver ${PREFIX}/www/cgi-bin
@@ -89,4 +85,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/ctwm/Makefile b/x11-wm/ctwm/Makefile
index 1cbedcbce56d..1b40b99abfe9 100644
--- a/x11-wm/ctwm/Makefile
+++ b/x11-wm/ctwm/Makefile
@@ -24,8 +24,7 @@ MAN1= ctwm.1
.include <bsd.port.pre.mk>
# Very old versions need GNU m4
-.if ( ${OSVERSION} < 450005 || \
- ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500034 ) )
+.if ( ${OSVERSION} < 500034 )
EXTRA_PATCHES+= ${FILESDIR}/gm4-patch
BUILD_DEPENDS+= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS+= gm4:${PORTSDIR}/devel/m4
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index 5e98682a8e17..14231722544c 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -115,12 +115,7 @@ IGNORE= is part of XFree86 and you have ${X_WINDOW_SYSTEM} set for X11\
of FAQ for more information
.endif
-# BuildXF86DRI is false for FreeBSD < 4.1
-.if ${OSVERSION} < 410000
-PLIST_SUB+= OSMESA:="@comment "
-.else
PLIST_SUB+= OSMESA:=""
-.endif
# sparc64 doesn't have a working libc_r yet, and -current doesn't need
# libXThrStub.