aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-07-29 04:54:34 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-07-29 04:54:34 +0000
commit608284ba700490ee85274752b2ea2790f4505af2 (patch)
treef958fcba8202218f7159a02ec0336d2e45f53598
parentc953f588fc7564dc1dc7d5b352e03a2d4bfbdf4d (diff)
downloadports-608284ba700490ee85274752b2ea2790f4505af2.tar.gz
ports-608284ba700490ee85274752b2ea2790f4505af2.zip
Notes
-rw-r--r--java/Makefile1
-rw-r--r--java/java-gcj-compat/Makefile38
-rw-r--r--java/java-gcj-compat/distinfo3
-rw-r--r--java/java-gcj-compat/files/patch-Makefile.in22
-rw-r--r--java/java-gcj-compat/files/patch-configure11
-rw-r--r--java/java-gcj-compat/pkg-descr5
-rw-r--r--java/java-gcj-compat/pkg-plist26
7 files changed, 106 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 0925fa2d0e29..8cbf39f7fb75 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -71,6 +71,7 @@
SUBDIR += jasmin
SUBDIR += java-checkstyle
SUBDIR += java-cup
+ SUBDIR += java-gcj-compat
SUBDIR += java-getopt
SUBDIR += java-tutorial
SUBDIR += java3d
diff --git a/java/java-gcj-compat/Makefile b/java/java-gcj-compat/Makefile
new file mode 100644
index 000000000000..0ea58b2d02a6
--- /dev/null
+++ b/java/java-gcj-compat/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: java-gcj-compat
+# Date created: 29 July 2006
+# Whom: <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= java-gcj-compat
+PORTVERSION= 1.0.56 # intentionally not upgrading
+CATEGORIES= java devel
+MASTER_SITES= ftp://sources.redhat.com/pub/rhug/
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= A collection of wrapper scripts, symlinks and jar files for GCJ
+
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/ldconfig/gcc41-withgcjawt:${PORTSDIR}/lang/gcc41-withgcjawt
+BUILD_DEPENDS+= gjdoc:${PORTSDIR}/java/gjdoc
+
+RUN_DEPENDS+= ${LOCALBASE}/libdata/ldconfig/gcc41-withgcjawt:${PORTSDIR}/lang/gcc41-withgcjawt
+RUN_DEPENDS+= gjdoc:${PORTSDIR}/java/gjdoc
+
+GCJVER=41
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+PLIST_SUB= ARCH=${ARCH}
+CONFIGURE_ARGS+="-with-origin-name=gcj41" "--with-gcc-suffix=41" \
+ "--with-arch-directory=${ARCH}" "--disable-symlinks" \
+ "--with-classpath-security=${LOCALBASE}/lib/security/classpath.security" \
+ "--with-security-directory=${LOCALBASE}/etc/java/security/security.d"
+
+pre-configure:
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/Makefile.in
+
+post-install:
+ @${LN} -sf ${PREFIX}/lib/jvm/java-1.4.2-gcj41-1.4.2.0 ${PREFIX}/lib/jvm/java-gcj
+
+.include <bsd.port.mk>
diff --git a/java/java-gcj-compat/distinfo b/java/java-gcj-compat/distinfo
new file mode 100644
index 000000000000..4b17d87e0e8e
--- /dev/null
+++ b/java/java-gcj-compat/distinfo
@@ -0,0 +1,3 @@
+MD5 (java-gcj-compat-1.0.56.tar.gz) = 016b4ed55cc61f19e8c3caf0b21a4b7b
+SHA256 (java-gcj-compat-1.0.56.tar.gz) = 6841a88e8f6f5ae21613a2f98a637adf882b1b5ffc333f5f94f81df0da73fd1c
+SIZE (java-gcj-compat-1.0.56.tar.gz) = 90314
diff --git a/java/java-gcj-compat/files/patch-Makefile.in b/java/java-gcj-compat/files/patch-Makefile.in
new file mode 100644
index 000000000000..465df2dfb8ae
--- /dev/null
+++ b/java/java-gcj-compat/files/patch-Makefile.in
@@ -0,0 +1,22 @@
+--- Makefile.in~ Mon Jul 24 18:03:23 2006
++++ Makefile.in Sat Jul 29 12:14:06 2006
+@@ -171,8 +171,8 @@
+
+ jardir = $(SDK_LIB_DIR)
+ jar_DATA = tools.jar
+-javadoc_jarfile = /usr/share/java/com-sun-javadoc-0.7.7.jar
+-taglet_jarfile = /usr/share/java/com-sun-tools-doclets-Taglet-0.7.7.jar
++javadoc_jarfile = %%LOCALBASE%%/share/java/com-sun-javadoc-0.7.7.jar
++taglet_jarfile = %%LOCALBASE%%/share/java/com-sun-tools-doclets-Taglet-0.7.7.jar
+ tools_jar_source_files = \
+ $(top_builddir)/com/sun/tools/javac/Config.java \
+ com/sun/tools/javac/Main.java \
+@@ -553,7 +553,7 @@
+ ln -sf $(GJDOC) $(DESTDIR)$(SDK_BIN_DIR)/javadoc
+ ln -sf $(GCJ_BIN_DIR)/grmic$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/rmic
+ ln -sf $(GCJ_BIN_DIR)/gjnih$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/javah
+- ln -sf $(GCJ_BIN_DIR)/ecj $(DESTDIR)$(SDK_BIN_DIR)/javac
++ ln -sf $(GCJ_BIN_DIR)/gcj$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/javac
+ ln -sf $(GCJ_BIN_DIR)/grmiregistry$(gcc_suffix) $(DESTDIR)$(SDK_BIN_DIR)/rmiregistry
+ ln -sf $(GCJ_BIN_DIR)/grmiregistry$(gcc_suffix) $(DESTDIR)$(JRE_BIN_DIR)/rmiregistry
+ @INSTALL_SYMLINKS_TRUE@ $(mkinstalldirs) $(DESTDIR)$(prefix)/bin
diff --git a/java/java-gcj-compat/files/patch-configure b/java/java-gcj-compat/files/patch-configure
new file mode 100644
index 000000000000..dfb900fcc27a
--- /dev/null
+++ b/java/java-gcj-compat/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure~ Mon Jul 24 18:03:23 2006
++++ configure Sat Jul 29 12:32:48 2006
+@@ -1996,7 +1996,7 @@
+ # special-case gjdoc and make which are not in the GCC tree
+ GJDOC=`which gjdoc`
+
+-MAKE=`which make`
++MAKE=`which gmake`
+
+
+ # Find gcj prefix using gcj found in PATH.
diff --git a/java/java-gcj-compat/pkg-descr b/java/java-gcj-compat/pkg-descr
new file mode 100644
index 000000000000..b7c6478df369
--- /dev/null
+++ b/java/java-gcj-compat/pkg-descr
@@ -0,0 +1,5 @@
+java-gcj-compat is a collection of wrapper scripts, symlinks and jar
+files. It is meant to provide an SDK-like interface to the GCJ tool
+set.
+
+WWW: ftp://sources.redhat.com/pub/rhug/
diff --git a/java/java-gcj-compat/pkg-plist b/java/java-gcj-compat/pkg-plist
new file mode 100644
index 000000000000..967ac4300546
--- /dev/null
+++ b/java/java-gcj-compat/pkg-plist
@@ -0,0 +1,26 @@
+bin/rebuild-gcj-db
+bin/aot-compile
+bin/aot-compile-rpm
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/lib/tools.jar
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/lib/i386/libjawt.so
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/bin/java
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/bin/rmiregistry
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/java
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/jar
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/javadoc
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/rmic
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/javah
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/javac
+lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin/rmiregistry
+lib/jvm/java-gcj
+%%PYTHON_SITELIBDIR%%/aotcompile.py
+%%PYTHON_SITELIBDIR%%/aotcompile.pyc
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/bin
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/lib/%%ARCH%%
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre/lib
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/jre
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/include
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/lib
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0/bin
+@dirrm lib/jvm/java-1.4.2-gcj41-1.4.2.0
+@dirrm lib/jvm