aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-07 19:09:19 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-07 19:09:19 +0000
commit646999a27c0c1620389481a0de39fa865ba2d99e (patch)
tree49c7d13fc277b580590c819742af3110103fd5b3
parent2949cb5d8b67bfc8581e73732033579d0c913a7f (diff)
downloadports-646999a27c0c1620389481a0de39fa865ba2d99e.tar.gz
ports-646999a27c0c1620389481a0de39fa865ba2d99e.zip
Notes
-rw-r--r--comms/hylafax/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index fcefae554424..f9e231fce46e 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -27,12 +27,13 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
DIST_SUBDIR= hylafax
-USE_GMAKE= yes
CONFIGURE_ARGS= --with-INSTALL="" \
- --with-MAKE=gmake --with-CC=/usr/bin/cc \
--with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
- --with-TIFFINC="${LOCALBASE}/include"
+ --with-ZLIB=no --with-LIBZ=-lz --with-ZLIBINC=none \
+ --with-TIFFINC="${LOCALBASE}/include" \
+ --with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none
HAS_CONFIGURE= yes
+CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
MAN1= hylafax.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 sendfax.1 \
sendpage.1 sgi2fax.1 textfmt.1
@@ -50,6 +51,9 @@ MAN8= cqtest.8c choptest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
+post-extract:
+ ${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
+
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}