aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2009-06-13 20:11:34 +0000
committerMikhail Teterin <mi@FreeBSD.org>2009-06-13 20:11:34 +0000
commit664752938243e99c1f59c1477a94c9d1b9311ea7 (patch)
tree9dad29479f6f3262fb040f7417da2ea7c0c41c62
parent9331cee55e38f93ca929924022bb276341664565 (diff)
downloadports-664752938243e99c1f59c1477a94c9d1b9311ea7.tar.gz
ports-664752938243e99c1f59c1477a94c9d1b9311ea7.zip
Notes
-rw-r--r--www/mod_dtcl/Makefile2
-rw-r--r--www/mod_dtcl/files/patch-warning8
2 files changed, 8 insertions, 2 deletions
diff --git a/www/mod_dtcl/Makefile b/www/mod_dtcl/Makefile
index 512195809abc..3b34e39e1dc4 100644
--- a/www/mod_dtcl/Makefile
+++ b/www/mod_dtcl/Makefile
@@ -18,8 +18,6 @@ BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
USE_TCL= yes
USE_TCL_BUILD= yes
-BROKEN= does not build
-
WRKSRC= ${WRKDIR}/mod_dtcl
MAKEFILE= ${FILESDIR}/Makefile.bsd
USE_APACHE= 1.3
diff --git a/www/mod_dtcl/files/patch-warning b/www/mod_dtcl/files/patch-warning
index 0b0341eaa3f1..9850ab02baa3 100644
--- a/www/mod_dtcl/files/patch-warning
+++ b/www/mod_dtcl/files/patch-warning
@@ -31,6 +31,14 @@
+ print_error(r, 0, Tcl_GetVar(interp, "errorInfo", 0));
print_error(r, 1, "<p><b>OUTPUT BUFFER:</b></p>");
print_error(r, 0, Tcl_GetStringFromObj(outbuf, (int *)NULL));
+@@ -382,5 +381,6 @@
+ {
+ hashKey = ap_psprintf(r->pool, "%s%lx%lx%d", filename,
+- mtime, ctime, toplevel);
++ (unsigned long)mtime, (unsigned long)ctime,
++ toplevel);
+ entry = Tcl_CreateHashEntry(dsc->objCache, hashKey, &isNew);
+ }
--- channel.c 2001-09-05 08:01:22.000000000 -0400
+++ channel.c 2009-04-11 23:03:43.000000000 -0400
@@ -19,5 +19,6 @@