aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2020-11-15 13:05:42 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2020-11-15 13:05:42 +0000
commit73668afd9ccafbd91c29b2865e69913c8e5a7c72 (patch)
tree7c31d8d0e5575a6e93bb2d00526e24acd3d9990a
parentdbbdf8e3dfedc47b990bdf7324aa7d2738aae52e (diff)
downloadports-73668afd9ccafbd91c29b2865e69913c8e5a7c72.tar.gz
ports-73668afd9ccafbd91c29b2865e69913c8e5a7c72.zip
MFH: r555206
devel/tinygo: Unbreak with go1.15.5 - unbreak with go 1.15.5 - drop maintainership Approved by: portmgr (build fix blanket)
Notes
Notes: svn path=/branches/2020Q4/; revision=555207
-rw-r--r--devel/tinygo/Makefile3
-rw-r--r--devel/tinygo/files/patch-Makefile22
2 files changed, 19 insertions, 6 deletions
diff --git a/devel/tinygo/Makefile b/devel/tinygo/Makefile
index 467dca64cfbc..8d141f03ff9d 100644
--- a/devel/tinygo/Makefile
+++ b/devel/tinygo/Makefile
@@ -3,9 +3,10 @@
PORTNAME= tinygo
DISTVERSIONPREFIX= v
DISTVERSION= 0.14.1
+PORTREVISION= 1
CATEGORIES= devel
-MAINTAINER= dmgk@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Go compiler for small places
LICENSE= BSD3CLAUSE
diff --git a/devel/tinygo/files/patch-Makefile b/devel/tinygo/files/patch-Makefile
index 46df6d7c3245..4b6c06e445d6 100644
--- a/devel/tinygo/files/patch-Makefile
+++ b/devel/tinygo/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2020-04-13 15:48:30 UTC
+--- Makefile.orig 2020-08-19 06:37:16 UTC
+++ Makefile
@@ -40,7 +40,7 @@ MD5SUM = md5sum
TINYGO ?= tinygo
@@ -9,8 +9,17 @@
LLVM_OPTION += '-DLLVM_CCACHE_BUILD=ON'
endif
+@@ -104,7 +104,7 @@ LLD_LIBS = $(START_GROUP) -llldCOFF -llldCommon -llldC
+ ifneq ("$(wildcard $(LLVM_BUILDDIR)/bin/llvm-config*)","")
+ CGO_CPPFLAGS=$(shell $(LLVM_BUILDDIR)/bin/llvm-config --cppflags) -I$(abspath $(LLVM_BUILDDIR))/tools/clang/include -I$(abspath $(CLANG_SRC))/include -I$(abspath $(LLD_SRC))/include
+ CGO_CXXFLAGS=-std=c++14
+- CGO_LDFLAGS+=$(LIBCLANG_PATH) -std=c++14 -L$(abspath $(LLVM_BUILDDIR)/lib) $(CLANG_LIBS) $(LLD_LIBS) $(shell $(LLVM_BUILDDIR)/bin/llvm-config --ldflags --libs --system-libs $(LLVM_COMPONENTS)) -lstdc++ $(CGO_LDFLAGS_EXTRA)
++ CGO_LDFLAGS+=$(LIBCLANG_PATH) -L$(abspath $(LLVM_BUILDDIR)/lib) $(CLANG_LIBS) $(LLD_LIBS) $(shell $(LLVM_BUILDDIR)/bin/llvm-config --ldflags --libs --system-libs $(LLVM_COMPONENTS)) -lstdc++ $(CGO_LDFLAGS_EXTRA)
+ endif
+
+
@@ -121,13 +121,13 @@ fmt-check:
- gen-device: gen-device-avr gen-device-nrf gen-device-sam gen-device-sifive gen-device-stm32
+ gen-device: gen-device-avr gen-device-nrf gen-device-sam gen-device-sifive gen-device-stm32 gen-device-kendryte gen-device-nxp
gen-device-avr:
- $(GO) build -o ./build/gen-device-avr ./tools/gen-device-avr/
@@ -25,7 +34,7 @@
gen-device-nrf: build/gen-device-svd
./build/gen-device-svd -source=https://github.com/NordicSemiconductor/nrfx/tree/master/mdk lib/nrfx/mdk/ src/device/nrf/
-@@ -165,16 +165,16 @@ $(LLVM_BUILDDIR): $(LLVM_BUILDDIR)/build.ninja
+@@ -173,16 +173,16 @@ $(LLVM_BUILDDIR): $(LLVM_BUILDDIR)/build.ninja
.PHONY: wasi-libc
wasi-libc: lib/wasi-libc/sysroot/lib/wasm32-wasi/libc.a
lib/wasi-libc/sysroot/lib/wasm32-wasi/libc.a:
@@ -45,8 +54,11 @@
tinygo-test:
cd tests/tinygotest && tinygo test
-@@ -345,4 +345,3 @@ release: tinygo gen-device wasi-libc
+@@ -383,7 +383,6 @@ build/release: tinygo gen-device wasi-libc
./build/tinygo build-library -target=armv6m-none-eabi -o build/release/tinygo/pkg/armv6m-none-eabi/picolibc.a picolibc
./build/tinygo build-library -target=armv7m-none-eabi -o build/release/tinygo/pkg/armv7m-none-eabi/picolibc.a picolibc
./build/tinygo build-library -target=armv7em-none-eabi -o build/release/tinygo/pkg/armv7em-none-eabi/picolibc.a picolibc
-- tar -czf build/release.tar.gz -C build/release tinygo
+-
+ release: build/release
+ tar -czf build/release.tar.gz -C build/release tinygo
+