aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2008-03-24 22:48:35 +0000
committerBrooks Davis <brooks@FreeBSD.org>2008-03-24 22:48:35 +0000
commit74afc71c04a50797560e13b9718ee538eba6b691 (patch)
treedd1f7c273ac9172aa447bf3d904c5f45ec44b7f0
parent8d6c8c964e23b4f21e69ff7e621ee6bdd3f41c87 (diff)
downloadports-74afc71c04a50797560e13b9718ee538eba6b691.tar.gz
ports-74afc71c04a50797560e13b9718ee538eba6b691.zip
Notes
-rw-r--r--devel/llvm/Makefile2
-rw-r--r--devel/llvm/distinfo6
-rw-r--r--devel/llvm/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp61
-rw-r--r--devel/llvm/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp21
-rw-r--r--devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp16
-rw-r--r--devel/llvm/pkg-plist36
-rw-r--r--devel/llvm29/Makefile2
-rw-r--r--devel/llvm29/distinfo6
-rw-r--r--devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp61
-rw-r--r--devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp21
-rw-r--r--devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp16
-rw-r--r--devel/llvm29/pkg-plist36
-rw-r--r--lang/llvm-gcc4/Makefile15
-rw-r--r--lang/llvm-gcc4/distinfo6
-rw-r--r--lang/llvm-gcc4/files/patch-gcc_config.gcc11
15 files changed, 115 insertions, 201 deletions
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index e3b825effd6a..9f6da8631064 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= llvm
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
diff --git a/devel/llvm/distinfo b/devel/llvm/distinfo
index 17809141f9f0..40dd8315677e 100644
--- a/devel/llvm/distinfo
+++ b/devel/llvm/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.1.tar.gz) = b930e7213b37acc934d0d163cf13af18
-SHA256 (llvm-2.1.tar.gz) = 8cabd422f249ada736d864fc8a1f4d14aabefacb6f860c9beefbc53f93e0f96c
-SIZE (llvm-2.1.tar.gz) = 5062241
+MD5 (llvm-2.2.tar.gz) = c16f89f0f28b66db0b776dfb2997cc40
+SHA256 (llvm-2.2.tar.gz) = 788d871aec139e0c61d49533d0252b21c4cd030e91405491ee8cb9b2d0311072
+SIZE (llvm-2.2.tar.gz) = 5702420
diff --git a/devel/llvm/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp b/devel/llvm/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp
deleted file mode 100644
index 5246aae1207d..000000000000
--- a/devel/llvm/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp
+++ /dev/null
@@ -1,61 +0,0 @@
-Author: lattner
-Date: Fri Sep 21 13:30:39 2007
-New Revision: 42205
-
-Log:
-#ifdef out unsafe tracing code, which fixes PR1689
-
-==============================================================================
---- lib/ExecutionEngine/Interpreter/Execution.cpp (original)
-+++ lib/ExecutionEngine/Interpreter/Execution.cpp Fri Sep 21 13:30:39 2007
-@@ -1338,20 +1338,6 @@
- StackFrame.VarArgs.assign(ArgVals.begin()+i, ArgVals.end());
- }
-
--static void PrintGenericValue(const GenericValue &Val, const Type* Ty) {
-- switch (Ty->getTypeID()) {
-- default: assert(0 && "Invalid GenericValue Type");
-- case Type::VoidTyID: DOUT << "void"; break;
-- case Type::FloatTyID: DOUT << "float " << Val.FloatVal; break;
-- case Type::DoubleTyID: DOUT << "double " << Val.DoubleVal; break;
-- case Type::PointerTyID: DOUT << "void* " << intptr_t(Val.PointerVal); break;
-- case Type::IntegerTyID:
-- DOUT << "i" << Val.IntVal.getBitWidth() << " "
-- << Val.IntVal.toStringUnsigned(10)
-- << " (0x" << Val.IntVal.toStringUnsigned(16) << ")\n";
-- break;
-- }
--}
-
- void Interpreter::run() {
- while (!ECStack.empty()) {
-@@ -1364,12 +1350,28 @@
-
- DOUT << "About to interpret: " << I;
- visit(I); // Dispatch to one of the visit* methods...
-+#if 0
-+ // This is not safe, as visiting the instruction could lower it and free I.
- #ifndef NDEBUG
- if (!isa<CallInst>(I) && !isa<InvokeInst>(I) &&
- I.getType() != Type::VoidTy) {
- DOUT << " --> ";
-- PrintGenericValue(SF.Values[&I], I.getType());
-+ const GenericValue &Val = SF.Values[&I];
-+ switch (I.getType()->getTypeID()) {
-+ default: assert(0 && "Invalid GenericValue Type");
-+ case Type::VoidTyID: DOUT << "void"; break;
-+ case Type::FloatTyID: DOUT << "float " << Val.FloatVal; break;
-+ case Type::DoubleTyID: DOUT << "double " << Val.DoubleVal; break;
-+ case Type::PointerTyID: DOUT << "void* " << intptr_t(Val.PointerVal);
-+ break;
-+ case Type::IntegerTyID:
-+ DOUT << "i" << Val.IntVal.getBitWidth() << " "
-+ << Val.IntVal.toStringUnsigned(10)
-+ << " (0x" << Val.IntVal.toStringUnsigned(16) << ")\n";
-+ break;
-+ }
- }
- #endif
-+#endif
- }
- }
diff --git a/devel/llvm/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp b/devel/llvm/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp
deleted file mode 100644
index e3a82d5972aa..000000000000
--- a/devel/llvm/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
-Author: dpatel
-Date: Thu Sep 20 18:01:50 2007
-New Revision: 42178
-
-Log:
-Don't increment invalid iterator.
-
-==============================================================================
---- lib/Transforms/Scalar/LoopIndexSplit.cpp (original)
-+++ lib/Transforms/Scalar/LoopIndexSplit.cpp Thu Sep 20 18:01:50 2007
-@@ -928,8 +928,9 @@
- while (!WorkList.empty()) {
- BasicBlock *BB = WorkList.back(); WorkList.pop_back();
- for(BasicBlock::iterator BBI = BB->begin(), BBE = BB->end();
-- BBI != BBE; ++BBI) {
-+ BBI != BBE; ) {
- Instruction *I = BBI;
-+ ++BBI;
- I->replaceAllUsesWith(UndefValue::get(I->getType()));
- I->eraseFromParent();
- }
diff --git a/devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp b/devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
new file mode 100644
index 000000000000..a2ea96188a30
--- /dev/null
+++ b/devel/llvm/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- lib/Transforms/Scalar/LoopUnroll.cpp.orig
++++ lib/Transforms/Scalar/LoopUnroll.cpp
+@@ -365,8 +365,9 @@
+ // be updated specially after unrolling all the way.
+ if (*BB != LatchBlock)
+ for (Value::use_iterator UI = (*BB)->use_begin(), UE = (*BB)->use_end();
+- UI != UE; ++UI) {
++ UI != UE;) {
+ Instruction *UseInst = cast<Instruction>(*UI);
++ ++UI;
+ if (isa<PHINode>(UseInst) && !L->contains(UseInst->getParent())) {
+ PHINode *phi = cast<PHINode>(UseInst);
+ Value *Incoming = phi->getIncomingValueForBlock(*BB);
diff --git a/devel/llvm/pkg-plist b/devel/llvm/pkg-plist
index 24f8485f0b03..e8c75d87abb0 100644
--- a/devel/llvm/pkg-plist
+++ b/devel/llvm/pkg-plist
@@ -26,18 +26,27 @@ etc/llvm/cpp
etc/llvm/cxx
etc/llvm/ll
etc/llvm/st
+include/llvm-c/Analysis.h
+include/llvm-c/BitReader.h
+include/llvm-c/BitWriter.h
+include/llvm-c/Core.h
+include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DenseMap.h
+include/llvm/ADT/DenseSet.h
include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
include/llvm/ADT/HashExtras.h
+include/llvm/ADT/ImmutableMap.h
+include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/SCCIterator.h
include/llvm/ADT/STLExtras.h
@@ -52,6 +61,7 @@ include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
include/llvm/ADT/Tree.h
+include/llvm/ADT/Trie.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
include/llvm/ADT/hash_map
@@ -65,6 +75,7 @@ include/llvm/Analysis/CFGPrinter.h
include/llvm/Analysis/CallGraph.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DominatorInternals.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/Interval.h
@@ -96,12 +107,20 @@ include/llvm/Bitcode/Archive.h
include/llvm/Bitcode/BitCodes.h
include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
+include/llvm/Bitcode/Deserialize.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
+include/llvm/Bitcode/Serialization.h
+include/llvm/Bitcode/SerializationFwd.h
+include/llvm/Bitcode/Serialize.h
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
+include/llvm/CodeGen/BreakCriticalMachineEdge.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/Collector.h
+include/llvm/CodeGen/CollectorMetadata.h
+include/llvm/CodeGen/Collectors.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FileWriters.h
@@ -114,6 +133,7 @@ include/llvm/CodeGen/MachORelocation.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
include/llvm/CodeGen/MachineConstantPool.h
+include/llvm/CodeGen/MachineDominators.h
include/llvm/CodeGen/MachineFrameInfo.h
include/llvm/CodeGen/MachineFunction.h
include/llvm/CodeGen/MachineFunctionPass.h
@@ -121,22 +141,23 @@ include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
+include/llvm/CodeGen/MachineLoopInfo.h
include/llvm/CodeGen/MachineModuleInfo.h
+include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
+include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/RuntimeLibcalls.h
-include/llvm/CodeGen/SSARegMap.h
include/llvm/CodeGen/SchedGraphCommon.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
-include/llvm/CodeGen/SimpleRegisterCoalescing.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/Config/alloca.h
@@ -154,6 +175,7 @@ include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
+include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/Function.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
@@ -167,6 +189,8 @@ include/llvm/IntrinsicInst.h
include/llvm/Intrinsics.gen
include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
+include/llvm/IntrinsicsARM.td
+include/llvm/IntrinsicsCellSPU.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
include/llvm/LinkAllPasses.h
@@ -182,6 +206,7 @@ include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
+include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
include/llvm/Support/Annotation.h
include/llvm/Support/CFG.h
@@ -212,17 +237,19 @@ include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
+include/llvm/Support/Registry.h
include/llvm/Support/SlowOperationInformer.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/Streams.h
+include/llvm/Support/StringPool.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/Timer.h
-include/llvm/Support/TypeInfo.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
include/llvm/System/Alarm.h
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
+include/llvm/System/Host.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
include/llvm/System/MappedFile.h
@@ -239,6 +266,7 @@ include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
include/llvm/Target/TargetFrameInfo.h
+include/llvm/Target/TargetInstrDesc.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
include/llvm/Target/TargetJITInfo.h
@@ -261,6 +289,7 @@ include/llvm/Transforms/Utils/InlineCost.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
+include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Type.h
include/llvm/TypeSymbolTable.h
include/llvm/Use.h
@@ -270,6 +299,7 @@ include/llvm/ValueSymbolTable.h
lib/LLVMARM.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
+lib/LLVMCellSPU.o
lib/LLVMExecutionEngine.o
lib/LLVMHello.a
lib/LLVMHello.la
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
index e3b825effd6a..9f6da8631064 100644
--- a/devel/llvm29/Makefile
+++ b/devel/llvm29/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= llvm
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
index 17809141f9f0..40dd8315677e 100644
--- a/devel/llvm29/distinfo
+++ b/devel/llvm29/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.1.tar.gz) = b930e7213b37acc934d0d163cf13af18
-SHA256 (llvm-2.1.tar.gz) = 8cabd422f249ada736d864fc8a1f4d14aabefacb6f860c9beefbc53f93e0f96c
-SIZE (llvm-2.1.tar.gz) = 5062241
+MD5 (llvm-2.2.tar.gz) = c16f89f0f28b66db0b776dfb2997cc40
+SHA256 (llvm-2.2.tar.gz) = 788d871aec139e0c61d49533d0252b21c4cd030e91405491ee8cb9b2d0311072
+SIZE (llvm-2.2.tar.gz) = 5702420
diff --git a/devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp b/devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp
deleted file mode 100644
index 5246aae1207d..000000000000
--- a/devel/llvm29/files/patch-lib_ExecutionEngine_Interpreter_Execution.cpp
+++ /dev/null
@@ -1,61 +0,0 @@
-Author: lattner
-Date: Fri Sep 21 13:30:39 2007
-New Revision: 42205
-
-Log:
-#ifdef out unsafe tracing code, which fixes PR1689
-
-==============================================================================
---- lib/ExecutionEngine/Interpreter/Execution.cpp (original)
-+++ lib/ExecutionEngine/Interpreter/Execution.cpp Fri Sep 21 13:30:39 2007
-@@ -1338,20 +1338,6 @@
- StackFrame.VarArgs.assign(ArgVals.begin()+i, ArgVals.end());
- }
-
--static void PrintGenericValue(const GenericValue &Val, const Type* Ty) {
-- switch (Ty->getTypeID()) {
-- default: assert(0 && "Invalid GenericValue Type");
-- case Type::VoidTyID: DOUT << "void"; break;
-- case Type::FloatTyID: DOUT << "float " << Val.FloatVal; break;
-- case Type::DoubleTyID: DOUT << "double " << Val.DoubleVal; break;
-- case Type::PointerTyID: DOUT << "void* " << intptr_t(Val.PointerVal); break;
-- case Type::IntegerTyID:
-- DOUT << "i" << Val.IntVal.getBitWidth() << " "
-- << Val.IntVal.toStringUnsigned(10)
-- << " (0x" << Val.IntVal.toStringUnsigned(16) << ")\n";
-- break;
-- }
--}
-
- void Interpreter::run() {
- while (!ECStack.empty()) {
-@@ -1364,12 +1350,28 @@
-
- DOUT << "About to interpret: " << I;
- visit(I); // Dispatch to one of the visit* methods...
-+#if 0
-+ // This is not safe, as visiting the instruction could lower it and free I.
- #ifndef NDEBUG
- if (!isa<CallInst>(I) && !isa<InvokeInst>(I) &&
- I.getType() != Type::VoidTy) {
- DOUT << " --> ";
-- PrintGenericValue(SF.Values[&I], I.getType());
-+ const GenericValue &Val = SF.Values[&I];
-+ switch (I.getType()->getTypeID()) {
-+ default: assert(0 && "Invalid GenericValue Type");
-+ case Type::VoidTyID: DOUT << "void"; break;
-+ case Type::FloatTyID: DOUT << "float " << Val.FloatVal; break;
-+ case Type::DoubleTyID: DOUT << "double " << Val.DoubleVal; break;
-+ case Type::PointerTyID: DOUT << "void* " << intptr_t(Val.PointerVal);
-+ break;
-+ case Type::IntegerTyID:
-+ DOUT << "i" << Val.IntVal.getBitWidth() << " "
-+ << Val.IntVal.toStringUnsigned(10)
-+ << " (0x" << Val.IntVal.toStringUnsigned(16) << ")\n";
-+ break;
-+ }
- }
- #endif
-+#endif
- }
- }
diff --git a/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp b/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp
deleted file mode 100644
index e3a82d5972aa..000000000000
--- a/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopIndexSplit.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
-Author: dpatel
-Date: Thu Sep 20 18:01:50 2007
-New Revision: 42178
-
-Log:
-Don't increment invalid iterator.
-
-==============================================================================
---- lib/Transforms/Scalar/LoopIndexSplit.cpp (original)
-+++ lib/Transforms/Scalar/LoopIndexSplit.cpp Thu Sep 20 18:01:50 2007
-@@ -928,8 +928,9 @@
- while (!WorkList.empty()) {
- BasicBlock *BB = WorkList.back(); WorkList.pop_back();
- for(BasicBlock::iterator BBI = BB->begin(), BBE = BB->end();
-- BBI != BBE; ++BBI) {
-+ BBI != BBE; ) {
- Instruction *I = BBI;
-+ ++BBI;
- I->replaceAllUsesWith(UndefValue::get(I->getType()));
- I->eraseFromParent();
- }
diff --git a/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp b/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
new file mode 100644
index 000000000000..a2ea96188a30
--- /dev/null
+++ b/devel/llvm29/files/patch-lib_Transforms_Scalar_LoopUnroll.cpp
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- lib/Transforms/Scalar/LoopUnroll.cpp.orig
++++ lib/Transforms/Scalar/LoopUnroll.cpp
+@@ -365,8 +365,9 @@
+ // be updated specially after unrolling all the way.
+ if (*BB != LatchBlock)
+ for (Value::use_iterator UI = (*BB)->use_begin(), UE = (*BB)->use_end();
+- UI != UE; ++UI) {
++ UI != UE;) {
+ Instruction *UseInst = cast<Instruction>(*UI);
++ ++UI;
+ if (isa<PHINode>(UseInst) && !L->contains(UseInst->getParent())) {
+ PHINode *phi = cast<PHINode>(UseInst);
+ Value *Incoming = phi->getIncomingValueForBlock(*BB);
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
index 24f8485f0b03..e8c75d87abb0 100644
--- a/devel/llvm29/pkg-plist
+++ b/devel/llvm29/pkg-plist
@@ -26,18 +26,27 @@ etc/llvm/cpp
etc/llvm/cxx
etc/llvm/ll
etc/llvm/st
+include/llvm-c/Analysis.h
+include/llvm-c/BitReader.h
+include/llvm-c/BitWriter.h
+include/llvm-c/Core.h
+include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DenseMap.h
+include/llvm/ADT/DenseSet.h
include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
include/llvm/ADT/HashExtras.h
+include/llvm/ADT/ImmutableMap.h
+include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/SCCIterator.h
include/llvm/ADT/STLExtras.h
@@ -52,6 +61,7 @@ include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
include/llvm/ADT/Tree.h
+include/llvm/ADT/Trie.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
include/llvm/ADT/hash_map
@@ -65,6 +75,7 @@ include/llvm/Analysis/CFGPrinter.h
include/llvm/Analysis/CallGraph.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DominatorInternals.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/Interval.h
@@ -96,12 +107,20 @@ include/llvm/Bitcode/Archive.h
include/llvm/Bitcode/BitCodes.h
include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
+include/llvm/Bitcode/Deserialize.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
+include/llvm/Bitcode/Serialization.h
+include/llvm/Bitcode/SerializationFwd.h
+include/llvm/Bitcode/Serialize.h
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
+include/llvm/CodeGen/BreakCriticalMachineEdge.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/Collector.h
+include/llvm/CodeGen/CollectorMetadata.h
+include/llvm/CodeGen/Collectors.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FileWriters.h
@@ -114,6 +133,7 @@ include/llvm/CodeGen/MachORelocation.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
include/llvm/CodeGen/MachineConstantPool.h
+include/llvm/CodeGen/MachineDominators.h
include/llvm/CodeGen/MachineFrameInfo.h
include/llvm/CodeGen/MachineFunction.h
include/llvm/CodeGen/MachineFunctionPass.h
@@ -121,22 +141,23 @@ include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
+include/llvm/CodeGen/MachineLoopInfo.h
include/llvm/CodeGen/MachineModuleInfo.h
+include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
+include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/RuntimeLibcalls.h
-include/llvm/CodeGen/SSARegMap.h
include/llvm/CodeGen/SchedGraphCommon.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
-include/llvm/CodeGen/SimpleRegisterCoalescing.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/Config/alloca.h
@@ -154,6 +175,7 @@ include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
+include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/Function.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
@@ -167,6 +189,8 @@ include/llvm/IntrinsicInst.h
include/llvm/Intrinsics.gen
include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
+include/llvm/IntrinsicsARM.td
+include/llvm/IntrinsicsCellSPU.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
include/llvm/LinkAllPasses.h
@@ -182,6 +206,7 @@ include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
+include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
include/llvm/Support/Annotation.h
include/llvm/Support/CFG.h
@@ -212,17 +237,19 @@ include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
+include/llvm/Support/Registry.h
include/llvm/Support/SlowOperationInformer.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/Streams.h
+include/llvm/Support/StringPool.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/Timer.h
-include/llvm/Support/TypeInfo.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
include/llvm/System/Alarm.h
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
+include/llvm/System/Host.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
include/llvm/System/MappedFile.h
@@ -239,6 +266,7 @@ include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
include/llvm/Target/TargetFrameInfo.h
+include/llvm/Target/TargetInstrDesc.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
include/llvm/Target/TargetJITInfo.h
@@ -261,6 +289,7 @@ include/llvm/Transforms/Utils/InlineCost.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
+include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Type.h
include/llvm/TypeSymbolTable.h
include/llvm/Use.h
@@ -270,6 +299,7 @@ include/llvm/ValueSymbolTable.h
lib/LLVMARM.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
+lib/LLVMCellSPU.o
lib/LLVMExecutionEngine.o
lib/LLVMHello.a
lib/LLVMHello.la
diff --git a/lang/llvm-gcc4/Makefile b/lang/llvm-gcc4/Makefile
index ea5fb648f69c..dbabc30fe338 100644
--- a/lang/llvm-gcc4/Makefile
+++ b/lang/llvm-gcc4/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= gcc4
-PORTVERSION= 2.1
-PORTREVISION= 1
+PORTVERSION= 2.2
CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
PKGNAMEPREFIX= llvm-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}.0-${PORTVERSION}.source
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}.2-${PORTVERSION}.source
MAINTAINER= emil@cs.rmit.edu.au
-COMMENT= gcc4 frontend for LLVM
+COMMENT= A gcc4 frontend for LLVM
+
+BUILD_DEPENDS= llc:${PORTSDIR}/devel/llvm
GNU_CONFIGURE= yes
USE_BISON= build
@@ -23,9 +24,7 @@ USE_ICONV= yes
USE_PERL5_BUILD=yes
ONLY_FOR_ARCHS= i386 amd64
-BUILD_DEPENDS= ${LOCALBASE}/bin/llc:${PORTSDIR}/devel/llvm
-
-GCC_VER= 4.0.1
+GCC_VER= 4.2.1
WRKSRC= ${WRKDIR}/${DISTNAME}/build
TARGLIB= ${PREFIX}/lib/gcc-llvm-${PORTVERSION}
CONFIGURE_SCRIPT= ../configure
@@ -63,8 +62,6 @@ post-patch:
post-install:
${RM} -f ${PREFIX}/man/man7/fsf-funding.7 \
${PREFIX}/man/man7/gfdl.7 ${PREFIX}/man/man7/gpl.7
- ${MV} -f ${PREFIX}/include/mf-runtime.h \
- ${TARGLIB}/gcc/${CONFIGURE_TARGET}/4.0.1/include
# Add target libraries and include files to packaging list.
${RM} -f ${WRKDIR}/PLIST.lib
.for d in ${TARGLIB:S/^${PREFIX}\///}
diff --git a/lang/llvm-gcc4/distinfo b/lang/llvm-gcc4/distinfo
index 2020025f5760..21723a208059 100644
--- a/lang/llvm-gcc4/distinfo
+++ b/lang/llvm-gcc4/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-gcc4.0-2.1.source.tar.gz) = b2592f6d4010f7128ff29eb8bffa3896
-SHA256 (llvm-gcc4.0-2.1.source.tar.gz) = 9bfe4ffb5d4db6564944381b58c65dfb1c38f1866d5a0cb1565721b3eb9de56f
-SIZE (llvm-gcc4.0-2.1.source.tar.gz) = 36597285
+MD5 (llvm-gcc4.2-2.2.source.tar.gz) = 7591c949eed3efc7a8b802b8f97effcc
+SHA256 (llvm-gcc4.2-2.2.source.tar.gz) = 77e24456d620f16fb515c2ddd898c922ac80a9cac59faae43098996339b27287
+SIZE (llvm-gcc4.2-2.2.source.tar.gz) = 49160222
diff --git a/lang/llvm-gcc4/files/patch-gcc_config.gcc b/lang/llvm-gcc4/files/patch-gcc_config.gcc
deleted file mode 100644
index acdd3593365b..000000000000
--- a/lang/llvm-gcc4/files/patch-gcc_config.gcc
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../gcc/config.gcc.orig 2007-12-20 19:57:41.000000000 -0500
-+++ ../gcc/config.gcc 2007-12-20 19:58:08.000000000 -0500
-@@ -431,6 +431,8 @@
- *-*-freebsd7 | *-*-freebsd[7].*)
- tm_defines="${tm_defines} FBSD_MAJOR=7" ;;
- # APPLE LOCAL end LLVM
-+ *-*-freebsd8 | *-*-freebsd[8].*)
-+ tm_defines="${tm_defines} FBSD_MAJOR=8" ;;
- *)
- echo 'Please update *-*-freebsd* in gcc/config.gcc'
- exit 1