aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-04-02 09:53:02 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-04-02 09:53:02 +0000
commit7c54d6e79af98e98da2dd181b6f95e9ea403d67d (patch)
tree2b71af6b2fa0621d12731c8bed70695fb195e1e9
parente888c2e3a04a9c0e364de20abb02604f0f3b5a8c (diff)
downloadports-7c54d6e79af98e98da2dd181b6f95e9ea403d67d.tar.gz
ports-7c54d6e79af98e98da2dd181b6f95e9ea403d67d.zip
Notes
-rw-r--r--graphics/p5-GraphViz-Data-Structure/Makefile12
-rw-r--r--graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL18
2 files changed, 20 insertions, 10 deletions
diff --git a/graphics/p5-GraphViz-Data-Structure/Makefile b/graphics/p5-GraphViz-Data-Structure/Makefile
index 174540585f2f..8a6c9b463c00 100644
--- a/graphics/p5-GraphViz-Data-Structure/Makefile
+++ b/graphics/p5-GraphViz-Data-Structure/Makefile
@@ -17,19 +17,11 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= Visualise data structures
BUILD_DEPENDS= ${SITE_PERL}/GraphViz.pm:${PORTSDIR}/graphics/p5-GraphViz \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+ ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Does not build
-
PERL_CONFIGURE= yes
MAN3= GraphViz::Data::Structure.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL b/graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL
new file mode 100644
index 000000000000..f911f05a1d64
--- /dev/null
+++ b/graphics/p5-GraphViz-Data-Structure/files/patch-Makefile.PL
@@ -0,0 +1,18 @@
+--- Makefile.PL.orig Tue Sep 27 05:20:28 2005
++++ Makefile.PL Mon Apr 2 17:27:28 2007
+@@ -2,15 +2,6 @@
+ use 5.008;
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+-my $dot_version = `dot -V 2>&1`;
+-
+-if (!$dot_version) {
+- die "You must install the graphviz package (http://www.graphviz.org) before using this module.\n";
+-}
+-else {
+- my ($v) = ($dot_version =~ /dot version (.*?) /);
+- die "You must have at least version 2.2 of dot to use this module" if ($v+0 < 2.2);
+-}
+
+ WriteMakefile(
+ NAME => 'GraphViz::Data::Structure',