aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-13 23:05:02 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-13 23:05:02 +0000
commit84f83b71aa4e9ae279bc4495f12fabf66461c2c8 (patch)
tree469f0d0cd71a9c7fa0eb2185738bfa6433cf79f4
parentba74761a29d4deccf8c013baaba10333f77f7952 (diff)
downloadports-84f83b71aa4e9ae279bc4495f12fabf66461c2c8.tar.gz
ports-84f83b71aa4e9ae279bc4495f12fabf66461c2c8.zip
Notes
-rw-r--r--textproc/aspell/Makefile13
-rw-r--r--textproc/aspell/distinfo2
-rw-r--r--textproc/aspell/files/patch-ah25
-rw-r--r--textproc/aspell/files/patch-aj11
-rw-r--r--textproc/aspell/pkg-plist13
5 files changed, 47 insertions, 17 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 5f05ace4cd5c..507d541e7092 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -1,21 +1,24 @@
# New ports collection makefile for: aspell
-# Date created: 7 December 1998
-# Whom: Josh Gilliam <josh@quick.net>
+# Date created: 7 December 1998
+# Whom: Josh Gilliam <josh@quick.net>
#
# $FreeBSD$
#
PORTNAME= aspell
-PORTVERSION= 0.29.1
+PORTVERSION= 0.31
CATEGORIES= textproc
MASTER_SITES= http://download.sourceforge.net/aspell/
-DISTNAME= ${PORTNAME}-.29.1
+DISTNAME= ${PORTNAME}-.31
MAINTAINER= ade@FreeBSD.org
+LIB_DEPENDS= pspell.2:${PORTSDIR}/textproc/pspell
+
USE_NEWGCC= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${WRKSRC}"
+CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
MAKE_ARGS+= NOPORTDOCS=${NOPORTDOCS}
diff --git a/textproc/aspell/distinfo b/textproc/aspell/distinfo
index b3a1dc651de6..79d90e61d1af 100644
--- a/textproc/aspell/distinfo
+++ b/textproc/aspell/distinfo
@@ -1 +1 @@
-MD5 (aspell-.29.1.tar.gz) = 87ea8a91fcf741fa9dc432445162b7ad
+MD5 (aspell-.31.tar.gz) = d9d6c9ad87abbcb8a452c75c1dc40eff
diff --git a/textproc/aspell/files/patch-ah b/textproc/aspell/files/patch-ah
index 749ecceac3c0..02aafea0d73d 100644
--- a/textproc/aspell/files/patch-ah
+++ b/textproc/aspell/files/patch-ah
@@ -1,20 +1,29 @@
---- configure.orig Mon Jul 26 12:31:53 1999
-+++ configure Thu Aug 19 11:42:57 1999
-@@ -2581,7 +2581,7 @@
- \
- dictdir=$enable_dict_dir
+--- configure.orig Sat Jun 10 16:20:16 2000
++++ configure Tue Jun 13 13:57:08 2000
+@@ -862,7 +862,7 @@
+ enableval="$enable_dict_dir"
+ dictdir=$enable_dict_dir
else
- dictdir=${libdir}/aspell
+ dictdir=${datadir}/aspell
fi
-@@ -2592,7 +2592,7 @@
- \
- pkgdocdir=$enable_doc_dir
+@@ -872,7 +872,7 @@
+ enableval="$enable_doc_dir"
+ pkgdocdir=$enable_doc_dir
else
- pkgdocdir=\${prefix}/doc/aspell
+ pkgdocdir=\${prefix}/share/doc/aspell
fi
+@@ -2197,7 +2197,7 @@
+ objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
+ deplibs_check_method="$deplibs_check_method" file_magic_cmd="$file_magic_cmd" \
+ ${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+-$libtool_flags --no-verify --build="$build" $ac_aux_dir/ltmain.sh $lt_target \
++$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
+ || { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
+
+ # Reload cache, that may have been modified by ltconfig
diff --git a/textproc/aspell/files/patch-aj b/textproc/aspell/files/patch-aj
new file mode 100644
index 000000000000..a53d6777aef5
--- /dev/null
+++ b/textproc/aspell/files/patch-aj
@@ -0,0 +1,11 @@
+--- data/Makefile.in.orig Sat Jun 10 23:53:37 2000
++++ data/Makefile.in Tue Jun 13 14:13:47 2000
+@@ -82,7 +82,7 @@
+ pkgdata_DATA = *.dat *.map
+
+
+-pspelldatadir = `${bindir}/pspell-config pkgdatadir`
++pspelldatadir = ${datadir}/pspell
+
+ pspelldata_DATA = en-american-aspell.pwli en-aspell.pwli
+
diff --git a/textproc/aspell/pkg-plist b/textproc/aspell/pkg-plist
index 9e971ff4771c..8eb9ce0122a8 100644
--- a/textproc/aspell/pkg-plist
+++ b/textproc/aspell/pkg-plist
@@ -1,6 +1,7 @@
bin/aspell
bin/run-with-aspell
include/aspell/amanager.hh
+include/aspell/app_string.hh
include/aspell/asuggest.hh
include/aspell/bad_value.hh
include/aspell/block_vector.hh
@@ -12,7 +13,6 @@ include/aspell/clone_ptr.hh
include/aspell/config.hh
include/aspell/config_data.hh
include/aspell/const_string.hh
-include/aspell/container.hh
include/aspell/copy_ptr-t.hh
include/aspell/copy_ptr.hh
include/aspell/data.hh
@@ -25,6 +25,8 @@ include/aspell/exception.hh
include/aspell/file_exceps.hh
include/aspell/file_util.hh
include/aspell/filter.hh
+include/aspell/generic_copy_ptr-t.hh
+include/aspell/generic_copy_ptr.hh
include/aspell/hash_const_string.hh
include/aspell/hash_repl-p.hh
include/aspell/hash_repl-t.hh
@@ -32,7 +34,7 @@ include/aspell/hash_repl.hh
include/aspell/hash_simple_string.hh
include/aspell/hash_string.hh
include/aspell/hash_string_s.hh
-include/aspell/itemize.hh
+include/aspell/invalid_word.hh
include/aspell/itr_equal.hh
include/aspell/language.hh
include/aspell/language_exceps.hh
@@ -76,7 +78,10 @@ include/aspell/vector_hash.hh
include/aspell/weights.hh
lib/libaspell.a
lib/libaspell.so
-lib/libaspell.so.4
+lib/libaspell.so.6
+lib/libpspell_aspell.a
+lib/libpspell_aspell.so
+lib/libpspell_aspell.so.1
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
share/aspell/ASCII.dat
@@ -156,6 +161,8 @@ share/doc/aspell/manual.aux
share/doc/aspell/manual.dvi
share/doc/aspell/manual.tex
share/doc/aspell/manual2.lyx
+share/pspell/en-american-aspell.pwli
+share/pspell/en-aspell.pwli
@dirrm include/aspell
@dirrm share/aspell
@dirrm share/doc/aspell/man-html