aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-03 02:44:50 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-03 02:44:50 +0000
commit86b14432c1f91880be2b64f6f0f1a975f3b0f3ea (patch)
tree6f077e5dd2a873e2b7ba819d4113f19125801682
parentbc64952c8125c93a17af548cf0fab3e245593b13 (diff)
downloadports-86b14432c1f91880be2b64f6f0f1a975f3b0f3ea.tar.gz
ports-86b14432c1f91880be2b64f6f0f1a975f3b0f3ea.zip
Notes
-rw-r--r--editors/scite/Makefile7
-rw-r--r--editors/scite/distinfo6
-rw-r--r--editors/scite/files/patch-gtk_makefile39
-rw-r--r--editors/scite/pkg-descr2
-rw-r--r--editors/scite/pkg-plist1
5 files changed, 30 insertions, 25 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index 957db7c10ec8..3ecde97ad4b8 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scite
-DISTVERSION= 4.3.2
+DISTVERSION= 4.4.5
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -28,6 +28,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
USE_GNOME= cairo gdkpixbuf2 gtk30
MAKEFILE= makefile
MAKE_ARGS= GTK3=1
+.if defined(WITH_DEBUG)
+MAKE_ARGS+= DEBUG=1
+.endif
PORTDATA= *.properties
PORTDOCS= *.html *.jpg *.png
@@ -39,12 +42,12 @@ MAKE_ARGS+= CLANG=1
.endif
post-patch:
- @${REINPLACE_CMD} -e 's| -Os||g' ${WRKSRC}/makefile
@${REINPLACE_CMD} -e 's|$$(SciteDefaultHome)|${DOCSDIR}|' \
${WRKSRC}/../src/SciTEGlobal.properties
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/SciTE ${STAGEDIR}${PREFIX}/bin
+ ${LN} -sf SciTE ${STAGEDIR}${PREFIX}/bin/scite
${INSTALL_MAN} ${WRKSRC}/../doc/scite.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/SciTE.desktop ${STAGEDIR}${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/Sci48M.png ${STAGEDIR}${PREFIX}/share/pixmaps
diff --git a/editors/scite/distinfo b/editors/scite/distinfo
index 6d07855b2a4a..d9ae763baa70 100644
--- a/editors/scite/distinfo
+++ b/editors/scite/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1584222159
-SHA256 (scite432.tgz) = fb7d9d2899b9559b31beca6a695d5b271cc7a6461b218e4a961b4fcd320a798f
-SIZE (scite432.tgz) = 2710026
+TIMESTAMP = 1601836826
+SHA256 (scite445.tgz) = 9d74bde5e4ee18d767b6add5a6b95d7ffcedbcfd017c3df59e16b0785e3521a1
+SIZE (scite445.tgz) = 2777899
diff --git a/editors/scite/files/patch-gtk_makefile b/editors/scite/files/patch-gtk_makefile
index 9ecd20ccfa4e..7396cbe55e23 100644
--- a/editors/scite/files/patch-gtk_makefile
+++ b/editors/scite/files/patch-gtk_makefile
@@ -1,32 +1,33 @@
---- gtk/makefile.orig 2020-01-02 00:45:08 UTC
+--- gtk/makefile.orig 2020-09-11 10:44:44 UTC
+++ gtk/makefile
-@@ -18,8 +18,6 @@ ifdef CLANG
+@@ -18,9 +18,7 @@ ifdef CLANG
# thread also need to create Position Independent Executable -> search online documentation
SANITIZE = address
#SANITIZE = undefined
-CXX = clang++
-CC = clang
- BASE_FLAGS += -fsanitize=$(SANITIZE)
+-BASE_FLAGS += -fsanitize=$(SANITIZE)
++#BASE_FLAGS += -fsanitize=$(SANITIZE)
WARNINGS += -Wno-deprecated-register
WARNINGS += -Wno-empty-body
-@@ -33,7 +31,7 @@ GTK_VERSION = $(if $(GTK3),gtk+-3.0,gtk+-2.0)
- # For the Gnome desktop stuff to work, prefix must point to where Gnome thinks it is.
- CONFIGFLAGS:=$(shell pkg-config --cflags $(GTK_VERSION))
- CONFIGLIB:=$(shell pkg-config --libs $(GTK_VERSION) gthread-2.0 gmodule-no-export-2.0)
--gnomeprefix:=$(shell pkg-config --variable=prefix $(GTK_VERSION) 2>/dev/null)
-+gnomeprefix:=$(PREFIX)
- ifndef prefix
- ifdef gnomeprefix
- prefix=$(gnomeprefix)
-@@ -141,8 +139,9 @@ SRC_OBJS = \
- StyleWriter.o \
+ else
+@@ -59,7 +57,7 @@ COMPLIB=$(SCINTILLA_DIR)/bin/scintilla.a
+ COMPONENT=$(srcdir)/../bin/libscintilla.$(SHAREDEXTENSION)
+ LEXILLA=$(srcdir)/../bin/liblexilla.$(SHAREDEXTENSION)
+
+-all: $(PROG) $(COMPONENT) $(LEXILLA)
++all: $(PROG)
+
+ vpath %.h $(srcdir) $(srcdir)/../src $(SCINTILLA_DIR)/include
+ vpath %.cxx $(srcdir) $(srcdir)/../src
+@@ -151,7 +149,9 @@ SRC_OBJS = \
Utf8_16.o
--$(PROG): SciTEGTK.o GUIGTK.o Widget.o GTKMutex.o DirectorExtension.o $(SRC_OBJS) $(COMPLIB) $(LUA_OBJS)
-- $(CXX) $(BASE_FLAGS) -rdynamic -Wl,--as-needed -Wl,--version-script $(srcdir)/lua.vers $^ -o $@ $(CONFIGLIB) $(LIBS) $(LDLIBS)
-+$(PROG): SciTEGTK.o GUIGTK.o Widget.o GTKMutex.o DirectorExtension.o $(SRC_OBJS) $(LUA_OBJS)
-+ $(CXX) $(BASE_FLAGS) -rdynamic -Wl,--version-script $(srcdir)/lua.vers $(CXXFLAGS) $^ -o $@ \
-+ $(LDFLAGS) -lscintilla -lscintilla_lexers -Wl,--as-needed $(CONFIGLIB)
+ $(PROG): SciTEGTK.o GUIGTK.o Widget.o DirectorExtension.o $(SRC_OBJS) $(LUA_OBJS)
+- $(CXX) $(BASE_FLAGS) $(LDFLAGS) -rdynamic -Wl,--as-needed -Wl,-rpath,'$${ORIGIN}' -Wl,--version-script $(srcdir)/lua.vers -Wl,-rpath,$(libdir) $^ -o $@ $(CONFIGLIB) $(LIBS) -L ../../scintilla/bin -lscintilla $(LDLIBS)
++ $(CXX) $(BASE_FLAGS) $(LDFLAGS) -rdynamic \
++ -Wl,--version-script $(srcdir)/lua.vers $^ -o $@ -lscintilla \
++ -Wl,--as-needed $(CONFIGLIB)
# Automatically generate header dependencies with "make deps"
include deps.mak
diff --git a/editors/scite/pkg-descr b/editors/scite/pkg-descr
index b2f561bc178e..d14a4d2a0f34 100644
--- a/editors/scite/pkg-descr
+++ b/editors/scite/pkg-descr
@@ -4,4 +4,4 @@ building and running programs. It is best used for jobs with simple
configurations - I use it for building test and demonstration programs as well
as SciTE and Scintilla, themselves.
-WWW: http://www.scintilla.org/SciTE.html
+WWW: https://www.scintilla.org/SciTE.html
diff --git a/editors/scite/pkg-plist b/editors/scite/pkg-plist
index b142548e06af..fd8b0f08ae89 100644
--- a/editors/scite/pkg-plist
+++ b/editors/scite/pkg-plist
@@ -1,4 +1,5 @@
bin/SciTE
+bin/scite
man/man1/scite.1.gz
share/applications/SciTE.desktop
share/pixmaps/Sci48M.png