aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-15 00:31:37 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-15 00:31:37 +0000
commit8d1fdbcb271c22887d2c01566e7751d19dad412f (patch)
treef655a00aeafba35fc2d71c56b0488c2d51cbef66
parent83b2ebc743bc89b69da075e35c78b9262390965b (diff)
downloadports-8d1fdbcb271c22887d2c01566e7751d19dad412f.tar.gz
ports-8d1fdbcb271c22887d2c01566e7751d19dad412f.zip
Notes
-rw-r--r--textproc/jtc/Makefile26
-rw-r--r--textproc/jtc/distinfo6
-rw-r--r--textproc/jtc/files/patch-lib_Json.hpp24
-rw-r--r--textproc/jtc/files/patch-lib_dbg.hpp12
4 files changed, 54 insertions, 14 deletions
diff --git a/textproc/jtc/Makefile b/textproc/jtc/Makefile
index e1ef20bf617d..f3ff6ea28b64 100644
--- a/textproc/jtc/Makefile
+++ b/textproc/jtc/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= jtc
-PORTVERSION= 1.75d
+DISTVERSION= 1.76
CATEGORIES= textproc
MAINTAINER= vulcan@wired.sh
@@ -15,13 +15,27 @@ USE_CXXSTD= c++14
USE_GITHUB= yes
GH_ACCOUNT= ldn-softdev
-LDFLAGS+= -lexecinfo
+LDFLAGS+= -lexecinfo -lpthread
PLIST_FILES= bin/${PORTNAME}
-PORTDOCS= README.md Release\ Notes.md User\ Guide.md \
- Walk-path\ tutorial.md
-
-OPTIONS_DEFINE= DOCS
+PORTDOCS= "Release Notes.md" "User Guide.md" "Walk-path tutorial.md" \
+ README.md
+
+OPTIONS_DEFINE= BG_CC BG_DTS BG_FLOW BG_MTS DOCS NO_DBG NO_DBG_PARSER
+
+BG_CC_DESC= Every call to a copy-constructor of Jnode class will reveal itself
+BG_DTS_DESC= Makes time-stamp display delta (since last debug message) instead of absolute stamp
+BG_FLOW_DESC= All debuggable function/method calls will display an entry and exit point
+BG_MTS_DESC= Display absolute time-stamps in the debug message
+NO_DBG_DESC= Disable all debug messages
+NO_DBG_PARSER_DESC= Disable debug messages coming from parsing JSON
+
+BG_CC_CXXFLAGS= -DBG_CC
+BG_DTS_CXXFLAGS= -DBG_dTS
+BG_FLOW_CXXFLAGS= -BG_FLOW
+BG_MTS_CXXFLAGS= -DBG_mTS -DBG_uTS
+NO_DBG_CXXFLAGS= -DNDEBUG
+NO_DBG_PARSER_CXXFLAGS= -DNDBG_PARSER
do-build:
${CXX} ${CXXFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.cpp -o ${WRKSRC}/${PORTNAME}
diff --git a/textproc/jtc/distinfo b/textproc/jtc/distinfo
index 1587aade17e1..e6eeea3f5b7b 100644
--- a/textproc/jtc/distinfo
+++ b/textproc/jtc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583518848
-SHA256 (ldn-softdev-jtc-1.75d_GH0.tar.gz) = e490a754be493660ef4f2e764ea121b5c39b280adf9b4c55d73e4876e8618f04
-SIZE (ldn-softdev-jtc-1.75d_GH0.tar.gz) = 206457
+TIMESTAMP = 1589016243
+SHA256 (ldn-softdev-jtc-1.76_GH0.tar.gz) = 8524ba3c67364719196ffc8c81078ea9c1ccfa629fff5e57441edd09f1950052
+SIZE (ldn-softdev-jtc-1.76_GH0.tar.gz) = 228445
diff --git a/textproc/jtc/files/patch-lib_Json.hpp b/textproc/jtc/files/patch-lib_Json.hpp
index 596787673807..c8d8a1fda947 100644
--- a/textproc/jtc/files/patch-lib_Json.hpp
+++ b/textproc/jtc/files/patch-lib_Json.hpp
@@ -1,11 +1,25 @@
---- lib/Json.hpp.orig 2020-03-13 20:36:36 UTC
+--- lib/Json.hpp.orig 2020-05-07 19:34:09 UTC
+++ lib/Json.hpp
-@@ -1189,8 +1189,6 @@ class Jnode::Iterator: public std::iterator<std::bidir
+@@ -688,11 +688,11 @@ class Jnode {
+ Jnode(const Jnode &jn): Jnode() { // CC
+
+ #ifdef BG_CC // -DBG_CC to compile this debug
+- if(DBG()(__Dbg_flow__::ind)) { // dodge DBG's mutex dead-lock
++ if(DBG()(__Dbg_flow__::ind())) { // dodge DBG's mutex dead-lock
+ GUARD(DBG().alt_prefix, DBG().alt_prefix)
+ DBG().alt_prefix(">");
+ DOUT() << DBG().prompt(__func__,
+- __Dbg_flow__::ind + 1, DBG().stamped(),
++ __Dbg_flow__::ind() + 1, DBG().stamped(),
+ Debug::Indention::Alternative)
+ << "CC copying: "
+ << jn.to_string(Jnode::PrettyType::Raw, 0) << std::endl;
+@@ -1221,8 +1221,6 @@ class Jnode::Iterator: public std::iterator<std::bidir
+ SuperJnode(Jtype t): Jnode{t} {} // Init Construct
SuperJnode & operator()(const std::string &s, Jnode &jn)
- { lbp_ = &s; jnp_ = &jn; return *this; }
-- const SuperJnode & operator()(const std::string &s, const Jnode &jn) const
- { lbp_ = &s; jnp_ = &jn; return *this; }
+- const SuperJnode & operator()(const std::string &s, const Jnode &jn) const
+ { lbp_ = &s; jnp_ = &jn; return *this; }
const std::string * lbp_{nullptr}; // pointer to a label string
- Jnode * jnp_{nullptr}; // resolved Jnode pointer
diff --git a/textproc/jtc/files/patch-lib_dbg.hpp b/textproc/jtc/files/patch-lib_dbg.hpp
new file mode 100644
index 000000000000..6ad575ad19c7
--- /dev/null
+++ b/textproc/jtc/files/patch-lib_dbg.hpp
@@ -0,0 +1,12 @@
+--- lib/dbg.hpp.orig 2020-05-07 19:34:09 UTC
++++ lib/dbg.hpp
+@@ -879,6 +879,9 @@ class __Dbg_flow__ {
+ }
+ }
+
++ static size_t ind(void) { return __Dbg_flow__::ind_; }
++
++
+ protected:
+ const Debug & dbg_; // debug reference
+ const char * dfnc_; // debug function