aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-15 02:01:13 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-15 02:01:13 +0000
commita80dac7496e12611fed65ae77726f184dfd8ecdd (patch)
treebe4e8b6c659b5fbd2a12b81ca3c15b85ca735448
parent8563e2c8e0f2baddd5b97d08bbbdbbf1413a7a30 (diff)
downloadports-a80dac7496e12611fed65ae77726f184dfd8ecdd.tar.gz
ports-a80dac7496e12611fed65ae77726f184dfd8ecdd.zip
MFH: r555161
games/ioquake3: fix build on powerpc64 Approved by: portmgr (fix build blanket)
Notes
Notes: svn path=/branches/2020Q4/; revision=555162
-rw-r--r--games/ioquake3/Makefile4
-rw-r--r--games/ioquake3/files/patch-Makefile11
-rw-r--r--games/ioquake3/files/patch-code-qcommon-q_platform.h8
3 files changed, 20 insertions, 3 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index f57c25abe015..6402ecd1b7d3 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -20,7 +20,7 @@ USES= pkgconfig gmake
# Port configuration flags:
# CLIENT SERVER TOOLS DLRENDERER GAMELIBS OPUS OPENGL2
IOQ3?= CLIENT TOOLS GAMELIBS
-IOQ3ARCH?= ${ARCH}
+IOQ3ARCH?= ${ARCH:S/powerpc/ppc/}
IOQ3SDL?= sdl
.if ! ${IOQ3:MCLIENT} && ! ${IOQ3:MSERVER}
@@ -87,7 +87,7 @@ Q3INSTALL?=
Q3ENGINEVER?= ${DISTVERSION}
IOQUAKE3VER= 1.36
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= amd64 i386 powerpc64
DEBUG_VARS= ALL_TARGET=debug
SERVER_RUN_DEPENDS= ${Q3SERVER}${BINSUFFIX}:games/${PORTNAME}-server
diff --git a/games/ioquake3/files/patch-Makefile b/games/ioquake3/files/patch-Makefile
index 3c77c16c2fb9..c4d5e74ad3c1 100644
--- a/games/ioquake3/files/patch-Makefile
+++ b/games/ioquake3/files/patch-Makefile
@@ -1,5 +1,16 @@
--- Makefile.orig 2009-04-22 18:54:48 UTC
+++ Makefile
+@@ -16,6 +16,10 @@ ifeq ($(COMPILE_PLATFORM),darwin)
+ # Apple does some things a little differently...
+ COMPILE_ARCH=$(shell uname -p | sed -e s/i.86/i386/)
+ endif
++ifeq ($(COMPILE_PLATFORM),freebsd)
++ # FreeBSD does some things a little differently...
++ COMPILE_ARCH=$(shell uname -p)
++endif
+
+ ifeq ($(COMPILE_PLATFORM),mingw32)
+ ifeq ($(COMPILE_ARCH),i386)
@@ -187,6 +187,8 @@ ifeq ($(shell which pkg-config > /dev/nu
# FIXME: introduce CLIENT_CFLAGS
SDL_CFLAGS=$(shell pkg-config --cflags sdl|sed 's/-Dmain=SDL_main//')
diff --git a/games/ioquake3/files/patch-code-qcommon-q_platform.h b/games/ioquake3/files/patch-code-qcommon-q_platform.h
index 55b1d5d2ec17..956a61cad464 100644
--- a/games/ioquake3/files/patch-code-qcommon-q_platform.h
+++ b/games/ioquake3/files/patch-code-qcommon-q_platform.h
@@ -1,6 +1,6 @@
--- code/qcommon/q_platform.h.orig 2009-03-02 17:29:30 UTC
+++ code/qcommon/q_platform.h
-@@ -199,6 +199,8 @@ Foundation, Inc., 51 Franklin St, Fifth
+@@ -199,8 +199,14 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
#ifdef __i386__
#define ARCH_STRING "i386"
@@ -8,4 +8,10 @@
+#define ARCH_STRING "amd64"
#elif defined __axp__
#define ARCH_STRING "alpha"
++#elif defined __powerpc64__
++#define ARCH_STRING "ppc64"
++#elif defined __powerpc__
++#define ARCH_STRING "ppc"
#endif
+
+ #if BYTE_ORDER == BIG_ENDIAN