aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-02-16 06:24:38 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-02-16 06:24:38 +0000
commita942716cc61f4bb8552186df880e8a80a4bfe638 (patch)
treed783f72c47b82d4a889cab1423d5f541437d8f45
parent8b22127138fce0239b54390e686529065b4b9271 (diff)
downloadports-a942716cc61f4bb8552186df880e8a80a4bfe638.tar.gz
ports-a942716cc61f4bb8552186df880e8a80a4bfe638.zip
Notes
-rw-r--r--math/superlu_mt/Makefile15
-rw-r--r--math/superlu_mt/files/patch-make.inc2
2 files changed, 9 insertions, 8 deletions
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index 31cea1607b18..f7236bafd22b 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -27,7 +27,7 @@ USE_FORTRAN= yes
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -35,13 +35,14 @@ USE_BLAS= atlas
.if ${USE_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-BLAS_LIBS= -lblas
+BLAS= -lblas
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
-BLAS_LIBS= -lgotop
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+BLAS= -lgoto2p
+BROKEN= Build stops while testing
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS_LIBS= -lptf77blas -lptcblas -latlas_r
+BLAS= -lptf77blas -lptcblas -latlas_r
.endif
.if ${ARCH} == "sparc64" || ${ARCH} == "amd64"
@@ -66,7 +67,7 @@ post-patch:
s|\$$(ARCH)|$$(ARCMD)|' ${WRKSRC}/${fmk}
.endfor
${CP} -r ${WRKSRC} ${WRKSRC_SHARED}
- @${REINPLACE_CMD} -e 's+%%BLAS_LIBS%%+-L${LOCALBASE}/lib ${BLAS_LIBS}+ ; \
+ @${REINPLACE_CMD} -e 's+%%BLAS%%+-L${LOCALBASE}/lib ${BLAS}+ ; \
s+%%CC%%+${CC}+; s+%%FC%%+${FC}+; \
s+%%CFLAGS%%+${CFLAGS}+; \
s+%%FFLAGS%%+${FFLAGS}+; \
@@ -75,7 +76,7 @@ post-patch:
s+%%PTHREAD_LIBS%%+${PTHREAD_LIBS}+ ' \
${WRKSRC}/make.inc
- @${REINPLACE_CMD} -e 's+%%BLAS_LIBS%%+-L${LOCALBASE}/lib ${BLAS_LIBS}+ ; \
+ @${REINPLACE_CMD} -e 's+%%BLAS%%+-L${LOCALBASE}/lib ${BLAS}+ ; \
s+%%CC%%+${CC}+; s+%%FC%%+${FC}+; \
s+%%CFLAGS%%+${CFLAGS} ${FPIC}+; \
s+%%FFLAGS%%+${FFLAGS} ${FPIC}+; \
diff --git a/math/superlu_mt/files/patch-make.inc b/math/superlu_mt/files/patch-make.inc
index 83adafa4f9d1..4ef5f716d687 100644
--- a/math/superlu_mt/files/patch-make.inc
+++ b/math/superlu_mt/files/patch-make.inc
@@ -22,7 +22,7 @@
#
BLASDEF = -DUSE_VENDOR_BLAS
-BLASLIB = -lessl
-+BLASLIB = %%BLAS_LIBS%%
++BLASLIB = %%BLAS%%
#BLASLIB = ../lib/libblas$(PLAT).a
MATHLIB = -lm
-MPLIB = -lpthread