aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-12-04 00:36:59 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-12-04 00:36:59 +0000
commitaf42edc943684953b769abb41856f1d628775ceb (patch)
tree4dd9c5e25f573146ab717133c7143fb4fc47048a
parentf48e644ad3b771faf12ece2b616a00eafa4642fa (diff)
downloadports-af42edc943684953b769abb41856f1d628775ceb.tar.gz
ports-af42edc943684953b769abb41856f1d628775ceb.zip
Update to 3.1.0.
19 months have passed since the release of 3.0.0 and there have been 1259 commits from over 24 contributors. Though many of the bugfixes did make it into the 3.0 branch, not all of them did. 3.1 brings many speedups, new features and commands, a new web interface, and build hooks. The new web interface works at a top-level, jail-level and the build-level still by using a static site with AJAX. There is a queue system that is not quite ready yet but should make it into 3.2. The release notes documenting the major changes is at https://github.com/freebsd/poudriere/wiki/release_notes_31 Thank you to everyone involved. Support can be found in #poudriere on Freenode.
Notes
Notes: svn path=/head/; revision=373856
-rw-r--r--UPDATING8
-rw-r--r--ports-mgmt/poudriere/Makefile32
-rw-r--r--ports-mgmt/poudriere/distinfo4
-rw-r--r--ports-mgmt/poudriere/files/patch-Makefile26
-rw-r--r--ports-mgmt/poudriere/files/patch-src__libexec__poudriere__Makefile20
-rw-r--r--ports-mgmt/poudriere/pkg-descr2
-rw-r--r--ports-mgmt/poudriere/pkg-plist65
7 files changed, 93 insertions, 64 deletions
diff --git a/UPDATING b/UPDATING
index 8006fee895b2..d033dba534cd 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20141203:
+ AFFECTS: users of ports-mgmt/poudriere
+ AUTHOR: bdrewery@FreeBSD.org
+
+ Poudriere has been updated to 3.1.0. See the release notes at
+ https://github.com/freebsd/poudriere/wiki/release_notes_31 for
+ information on changed features and required setup.
+
20141130:
AFFECTS: users of devel/gettext (close to everyone)
AUTHOR: tijl@FreeBSD.org
diff --git a/ports-mgmt/poudriere/Makefile b/ports-mgmt/poudriere/Makefile
index dd28de84c443..2e0ce12be1e4 100644
--- a/ports-mgmt/poudriere/Makefile
+++ b/ports-mgmt/poudriere/Makefile
@@ -1,26 +1,40 @@
# $FreeBSD$
PORTNAME= poudriere
-PORTVERSION= 3.0.19
+DISTVERSION= 3.1.0
+PORTREVISION= 0
CATEGORIES= ports-mgmt
-MASTER_SITES= http://fossil.etoilebsd.net/poudriere/tarball/ \
- LOCAL/bdrewery/${PORTNAME}/
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}?uuid=${PORTVERSION}
+MASTER_SITES= LOCAL/bdrewery/${PORTNAME}/ \
+ http://mirror.shatow.net/freebsd/${PORTNAME}/ \
+ GH
+DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-0-g${GH_COMMIT}
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Port build and test system
LICENSE= BSD2CLAUSE
-OPTIONS_DEFINE= ZSH
+CONFLICTS_INSTALL= poudriere-devel-[0-9]*
+
+USE_GITHUB= yes
+GH_ACCOUNT= freebsd
+GH_COMMIT= 17f761b
+GH_TAGNAME= ${GH_COMMIT}
+
+GNU_CONFIGURE= yes
+ETCDIR= ${PREFIX}/etc/poudriere.d
+
+OPTIONS_DEFINE= ZSH QEMU
OPTIONS_SUB= yes
-CONFLICTS_INSTALL= poudriere-devel
+QEMU_DESC= Add qemu-user-static to compile ports for non-x86 architectures
+QEMU_RUN_DEPENDS= qemu-user-static>0:${PORTSDIR}/emulators/qemu-user-static
+
+.include <bsd.port.options.mk>
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/poudriere/*
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
- @${INSTALL_DATA} ${WRKSRC}/zsh-completions \
- ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_poudriere
+ ${INSTALL_DATA} ${WRKSRC}/completions/zsh/_poudriere \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
.include <bsd.port.mk>
diff --git a/ports-mgmt/poudriere/distinfo b/ports-mgmt/poudriere/distinfo
index 14923a7fc4d6..568513c6bb64 100644
--- a/ports-mgmt/poudriere/distinfo
+++ b/ports-mgmt/poudriere/distinfo
@@ -1,2 +1,2 @@
-SHA256 (poudriere-3.0.19.tar.gz?uuid=3.0.19) = ab2f79c3ffb5ed6946c7a36df87bced1cbff083870188d2150dcf71c4a9db9c0
-SIZE (poudriere-3.0.19.tar.gz?uuid=3.0.19) = 156255
+SHA256 (freebsd-poudriere-3.1.0-0-g17f761b.tar.gz) = 24815c2d7781af617a19a5fd3b00cda6977c2b3325ca5b589601c32f948f958e
+SIZE (freebsd-poudriere-3.1.0-0-g17f761b.tar.gz) = 2713346
diff --git a/ports-mgmt/poudriere/files/patch-Makefile b/ports-mgmt/poudriere/files/patch-Makefile
deleted file mode 100644
index 0cd47c8acfaa..000000000000
--- a/ports-mgmt/poudriere/files/patch-Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./Makefile.orig 2014-03-17 16:01:47.000000000 +0100
-+++ ./Makefile 2014-04-05 00:10:41.888129490 +0200
-@@ -5,18 +5,18 @@
- ${MAKE} -C src/libexec/poudriere
-
- install:
-- install -m 755 -o root -g wheel src/bin/poudriere.sh \
-+ install -m 755 src/bin/poudriere.sh \
- ${DESTDIR}${PREFIX}/bin/poudriere
- mkdir -p ${DESTDIR}${PREFIX}/share/poudriere
- mkdir -p ${DESTDIR}${PREFIX}/share/poudriere/awk
- mkdir -p ${DESTDIR}${PREFIX}/share/poudriere/html
-- install -m 755 -o root -g wheel src/share/poudriere/*.sh \
-+ install -m 755 src/share/poudriere/*.sh \
- ${DESTDIR}${PREFIX}/share/poudriere/
-- install -m 644 -o root -g wheel src/share/poudriere/awk/* \
-+ install -m 644 src/share/poudriere/awk/* \
- ${DESTDIR}${PREFIX}/share/poudriere/awk/
-- install -m 644 -o root -g wheel src/share/poudriere/html/* \
-+ install -m 644 src/share/poudriere/html/* \
- ${DESTDIR}${PREFIX}/share/poudriere/html/
-- install -m 644 -o root -g wheel conf/poudriere.conf.sample \
-+ install -m 644 conf/poudriere.conf.sample \
- ${DESTDIR}${PREFIX}/etc/
- if [ -f poudriere.8.gz ]; then rm -f poudriere.8.gz; fi
- gzip -k -9 poudriere.8
diff --git a/ports-mgmt/poudriere/files/patch-src__libexec__poudriere__Makefile b/ports-mgmt/poudriere/files/patch-src__libexec__poudriere__Makefile
deleted file mode 100644
index 74b1f3e803f3..000000000000
--- a/ports-mgmt/poudriere/files/patch-src__libexec__poudriere__Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./src/libexec/poudriere/Makefile.orig 2014-03-17 16:01:47.000000000 +0100
-+++ ./src/libexec/poudriere/Makefile 2014-04-05 00:11:53.061289147 +0200
-@@ -16,13 +16,13 @@
-
- install: dirwatch make_index dirempty cpdup/cpdup
- mkdir -p ${DESTDIR}${PREFIX}/libexec/poudriere
-- install -m 755 -o root -g wheel dirwatch \
-+ install -m 755 dirwatch \
- ${DESTDIR}${PREFIX}/libexec/poudriere
-- install -m 755 -o root -g wheel make_index \
-+ install -m 755 make_index \
- ${DESTDIR}${PREFIX}/libexec/poudriere
-- install -m 755 -o root -g wheel dirempty \
-+ install -m 755 dirempty \
- ${DESTDIR}${PREFIX}/libexec/poudriere
-- install -m 755 -o root -g wheel cpdup/cpdup \
-+ install -m 755 cpdup/cpdup \
- ${DESTDIR}${PREFIX}/libexec/poudriere
-
- clean:
diff --git a/ports-mgmt/poudriere/pkg-descr b/ports-mgmt/poudriere/pkg-descr
index 9ede64ef9477..3e950072cf23 100644
--- a/ports-mgmt/poudriere/pkg-descr
+++ b/ports-mgmt/poudriere/pkg-descr
@@ -2,4 +2,4 @@ poudriere is a tool primarily designed to test package production on
FreeBSD. However, most people will find it useful to bulk build ports
for FreeBSD.
-WWW: https://fossil.etoilebsd.net/poudriere/doc/3.0.x/doc/index.wiki
+WWW: https://github.com/freebsd/poudriere/wiki
diff --git a/ports-mgmt/poudriere/pkg-plist b/ports-mgmt/poudriere/pkg-plist
index 9caea1f265ba..cd5fd955fe37 100644
--- a/ports-mgmt/poudriere/pkg-plist
+++ b/ports-mgmt/poudriere/pkg-plist
@@ -1,28 +1,81 @@
bin/poudriere
@sample etc/poudriere.conf.sample
+%%ETCDIR%%/hooks/bulk.sh.sample
+%%ETCDIR%%/hooks/pkgbuild.sh.sample
+@sample etc/poudriered.conf.sample
+etc/rc.d/poudriered
libexec/poudriere/cpdup
libexec/poudriere/dirempty
libexec/poudriere/dirwatch
-libexec/poudriere/make_index
+libexec/poudriere/jexecd
+libexec/poudriere/nc
+libexec/poudriere/poudriered
+libexec/poudriere/rename
+libexec/poudriere/rexec
+libexec/poudriere/timeout
+libexec/poudriere/timestamp
+libexec/poudriere/tsort
man/man8/poudriere.8.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/httpd.conf.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nginx.conf.sample
%%DATADIR%%/awk/dependency_loop.awk
%%DATADIR%%/awk/humanize.awk
%%DATADIR%%/awk/json.awk
-%%DATADIR%%/awk/make_index.awk
+%%DATADIR%%/awk/json_jail.awk
+%%DATADIR%%/awk/json_top.awk
+%%DATADIR%%/awk/processonelog2.awk
%%DATADIR%%/awk/siginfo_buildtime.awk
%%DATADIR%%/bulk.sh
%%DATADIR%%/clean.sh
%%DATADIR%%/common.sh
%%DATADIR%%/daemon.sh
%%DATADIR%%/distclean.sh
+%%DATADIR%%/html/assets/DataTables-1.10.0/css/jquery.dataTables.min.css
+%%DATADIR%%/html/assets/DataTables-1.10.0/css/jquery.dataTables_themeroller.min.css
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/back_disabled.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/back_enabled.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/back_enabled_hover.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/forward_disabled.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/forward_enabled.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/forward_enabled_hover.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/sort_asc.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/sort_asc_disabled.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/sort_both.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/sort_desc.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/images/sort_desc_disabled.png
+%%DATADIR%%/html/assets/DataTables-1.10.0/js/jquery.dataTables.min.js
+%%DATADIR%%/html/assets/bootstrap-3.1.1/css/bootstrap-theme.min.css
+%%DATADIR%%/html/assets/bootstrap-3.1.1/css/bootstrap.min.css
+%%DATADIR%%/html/assets/bootstrap-3.1.1/fonts/glyphicons-halflings-regular.eot
+%%DATADIR%%/html/assets/bootstrap-3.1.1/fonts/glyphicons-halflings-regular.svg
+%%DATADIR%%/html/assets/bootstrap-3.1.1/fonts/glyphicons-halflings-regular.ttf
+%%DATADIR%%/html/assets/bootstrap-3.1.1/fonts/glyphicons-halflings-regular.woff
+%%DATADIR%%/html/assets/bootstrap-3.1.1/js/bootstrap.min.js
+%%DATADIR%%/html/assets/favicon.ico
+%%DATADIR%%/html/assets/jquery-1.11.1.js
+%%DATADIR%%/html/assets/jquery-1.11.1.min.js
+%%DATADIR%%/html/assets/jquery-1.11.1.min.map
+%%DATADIR%%/html/assets/jquery.dataTables.rowGrouping-1.2.9.js
+%%DATADIR%%/html/assets/logo.svg
+%%DATADIR%%/html/assets/poudriere.css
+%%DATADIR%%/html/assets/poudriere.js
+%%DATADIR%%/html/build.html
%%DATADIR%%/html/index.html
-%%DATADIR%%/html/jquery-1.9.1.min.js
-%%DATADIR%%/html/logo.jpg
-%%DATADIR%%/html/poudriere.css
-%%DATADIR%%/html/poudriere.js
+%%DATADIR%%/html/jail.html
+%%DATADIR%%/html/robots.txt
+%%DATADIR%%/include/common.sh.dragonfly
+%%DATADIR%%/include/common.sh.freebsd
+%%DATADIR%%/include/colors.sh
+%%DATADIR%%/include/display.sh
+%%DATADIR%%/include/fs.sh
+%%DATADIR%%/include/hash.sh
+%%DATADIR%%/include/html.sh
+%%DATADIR%%/include/parallel.sh
%%DATADIR%%/jail.sh
%%DATADIR%%/options.sh
+%%DATADIR%%/pkgclean.sh
%%DATADIR%%/ports.sh
+%%DATADIR%%/processonelog.sh
%%DATADIR%%/queue.sh
%%DATADIR%%/status.sh
%%DATADIR%%/testport.sh