aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-10 23:04:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-10 23:04:01 +0000
commitb06e081819884e536627a66b3b1e7f757ffc85f5 (patch)
treeb9ec551fe16d7eb9746c2b3ac489c429992747c5
parent9297c97c51e8e1d7b88c2b5b7e349d90e39ac1fd (diff)
downloadports-b06e081819884e536627a66b3b1e7f757ffc85f5.tar.gz
ports-b06e081819884e536627a66b3b1e7f757ffc85f5.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile32
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Delegate/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-plist12
5 files changed, 51 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b0b4b9ed4294..c57afad82784 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -581,6 +581,7 @@
SUBDIR += p5-Catalyst-Plugin-Session-State-Cookie
SUBDIR += p5-Catalyst-Plugin-Session-State-URI
SUBDIR += p5-Catalyst-Plugin-Session-Store-DBI
+ SUBDIR += p5-Catalyst-Plugin-Session-Store-Delegate
SUBDIR += p5-Catalyst-Plugin-Session-Store-FastMmap
SUBDIR += p5-Catalyst-Plugin-Session-Store-File
SUBDIR += p5-Catalyst-Plugin-Session-Store-Memcached
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
new file mode 100644
index 000000000000..8404a044f6d7
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Delegate/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-Delegate
+# Date created: 28 Dec 2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-Delegate
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Delegate session storage to an application model object
+
+BUILD_DEPENDS= p5-Catalyst-Plugin-Session>=0.12:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Session::Store::Delegate.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Delegate/distinfo b/www/p5-Catalyst-Plugin-Session-Store-Delegate/distinfo
new file mode 100644
index 000000000000..e21d80c970b9
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Delegate/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-Store-Delegate-0.02.tar.gz) = f838dce5352222acbe240a1072e7c60f
+SHA256 (Catalyst-Plugin-Session-Store-Delegate-0.02.tar.gz) = ae28da3f2462202dd682b45e62d9dfe64174c5e5f03407a3dcf70025dc699eeb
+SIZE (Catalyst-Plugin-Session-Store-Delegate-0.02.tar.gz) = 5087
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-descr b/www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-descr
new file mode 100644
index 000000000000..e83c36725445
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-descr
@@ -0,0 +1,3 @@
+This storage module will store session data in a database using DBIx::Class.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-DBIC/
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-plist b/www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-plist
new file mode 100644
index 000000000000..5bfbee3ec7b2
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Delegate/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store/Delegate/.packlist
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/Delegate.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store/Delegate
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Session/Store
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Session
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+