aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-07-26 07:13:52 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-07-26 07:13:52 +0000
commitbd510d4f155659ce81bb1af63e52c3e16ef0745b (patch)
tree23e35fd75fcf265dfcebc1e51241cd793cdd1cf8
parentb5b991f3f01fdfc3c241957227112fd9d4846fea (diff)
downloadports-bd510d4f155659ce81bb1af63e52c3e16ef0745b.tar.gz
ports-bd510d4f155659ce81bb1af63e52c3e16ef0745b.zip
Notes
-rw-r--r--net-im/mbpurple/Makefile4
-rw-r--r--security/libotr/Makefile2
-rw-r--r--security/pidgin-otr/Makefile3
3 files changed, 5 insertions, 4 deletions
diff --git a/net-im/mbpurple/Makefile b/net-im/mbpurple/Makefile
index 8ef4cc9953da..666a4db683f5 100644
--- a/net-im/mbpurple/Makefile
+++ b/net-im/mbpurple/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= dougb@FreeBSD.org
COMMENT= Integrate twitter with pidgin (AKA microblog-purple)
-BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
+BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin \
+ pkgconf>0:${PORTSDIR}/devel/pkgconf
RUN_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
PROJECTHOST= microblog-purple
USE_GMAKE= yes
-USE_PKGCONFIG= yes
post-patch:
@${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.Dist
diff --git a/security/libotr/Makefile b/security/libotr/Makefile
index 8383609285e2..ce9d58e4c4e2 100644
--- a/security/libotr/Makefile
+++ b/security/libotr/Makefile
@@ -20,6 +20,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dougb@FreeBSD.org
COMMENT= The portable OTR Messaging Library and toolkit
+BUILD_DEPENDS= pkgconf>0:${PORTSDIR}/devel/pkgconf
LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error \
gcrypt:${PORTSDIR}/security/libgcrypt
@@ -27,7 +28,6 @@ MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= autoconf libtool
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
MAN1= otr_toolkit.1
MLINKS= otr_toolkit.1 otr_parse.1 \
diff --git a/security/pidgin-otr/Makefile b/security/pidgin-otr/Makefile
index a8226d8e439a..0a813b7a1d8b 100644
--- a/security/pidgin-otr/Makefile
+++ b/security/pidgin-otr/Makefile
@@ -21,7 +21,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dougb@FreeBSD.org
COMMENT= Allows deniable private conversations using Pidgin
-BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
+BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin \
+ pkgconf>0:${PORTSDIR}/devel/pkgconf
LIB_DEPENDS= otr:${PORTSDIR}/security/libotr \
gcrypt:${PORTSDIR}/security/libgcrypt \
purple:${PORTSDIR}/net-im/libpurple