aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-15 16:44:34 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-15 16:44:34 +0000
commitc2260104550590303bbcc8309d8d5514a2be022d (patch)
tree53f6ad12767da7ed19859fdec57229b4ab4496b8
parent92370b46b1f19ebc3bde62cb12946818dd298643 (diff)
downloadports-c2260104550590303bbcc8309d8d5514a2be022d.tar.gz
ports-c2260104550590303bbcc8309d8d5514a2be022d.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/klira/Makefile36
-rw-r--r--audio/klira/distinfo2
-rw-r--r--audio/klira/pkg-descr12
-rw-r--r--audio/klira/pkg-plist24
5 files changed, 75 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ff4cf0b91131..20051a724fdd 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -166,6 +166,7 @@
SUBDIR += juk
SUBDIR += juke
SUBDIR += jxm
+ SUBDIR += klira
SUBDIR += kmp
SUBDIR += ksmp3play
SUBDIR += ladspa
diff --git a/audio/klira/Makefile b/audio/klira/Makefile
new file mode 100644
index 000000000000..90a1bb498ede
--- /dev/null
+++ b/audio/klira/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Klira
+# Date created: Wed Dec 15 16:05:43 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= klira
+PORTVERSION= 0.1
+CATEGORIES= audio kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A gstreamer based audio converter for KDE
+
+DEPENDS= ${PORTSDIR}/misc/kdehier
+LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
+
+USE_BZIP2= yes
+USE_GNOME= gstreamerplugins
+USE_KDELIBS_VER=3
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-configure
+#EXTRA_PATCHES= ${PORTSDIR}/x11/kde3/files/extrapatch-old_configure
+
+post-patch:
+# disable GNU auto* tools
+ @${FIND} ${WRKSRC} -type f -name "Makefile.in" | ${XARGS} \
+ -n 10 ${REINPLACE_CMD} -E \
+ -e 's!^(ACLOCAL|AUTOCONF|AUTOMAKE|AUTOHEADER).+$$!\1=${TRUE}!'
+
+.include <bsd.port.mk>
diff --git a/audio/klira/distinfo b/audio/klira/distinfo
new file mode 100644
index 000000000000..5863bf55f820
--- /dev/null
+++ b/audio/klira/distinfo
@@ -0,0 +1,2 @@
+MD5 (klira-0.1.tar.bz2) = c5b38080b7593ea4cc38d32e75698f10
+SIZE (klira-0.1.tar.bz2) = 416878
diff --git a/audio/klira/pkg-descr b/audio/klira/pkg-descr
new file mode 100644
index 000000000000..388acb64b92c
--- /dev/null
+++ b/audio/klira/pkg-descr
@@ -0,0 +1,12 @@
+[ excerpt from developer's web site ]
+
+This app is an audio converter for KDE. It lets you convert to and
+from various audio file formats (at the moment: mp3, Ogg and wav),
+mantaining, when possible, all the informations attached to those
+files (title, author and so on). Its interface is thought as a
+wizard (a serie of pages navigable through back-forward buttons),
+so it should be quite simple to use, or so I hope.
+
+WWW: http://klira.sourceforge.net/
+
+-- lioux@FreeBSD.org
diff --git a/audio/klira/pkg-plist b/audio/klira/pkg-plist
new file mode 100644
index 000000000000..aab2e7593dce
--- /dev/null
+++ b/audio/klira/pkg-plist
@@ -0,0 +1,24 @@
+bin/klira
+share/applnk/Utilities/klira.desktop
+share/apps/klira/kliraui.rc
+share/doc/HTML/en/klira/common
+share/doc/HTML/en/klira/index.cache.bz2
+share/doc/HTML/en/klira/index.docbook
+share/icons/hicolor/16x16/apps/klira.png
+share/icons/hicolor/32x32/apps/klira.png
+share/icons/hicolor/64x64/apps/klira.png
+@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
+@unexec rmdir %D/share/icons 2>/dev/null || true
+@dirrm share/doc/HTML/en/klira
+@unexec rmdir %D/share/doc/HTML/en 2>/dev/null || true
+@unexec rmdir %D/share/doc/HTML 2>/dev/null || true
+@dirrm share/apps/klira
+@unexec rmdir %D/share/apps 2>/dev/null || true
+@unexec rmdir %D/share/applnk/Utilities 2>/dev/null || true
+@unexec rmdir %D/share/applnk 2>/dev/null || true