aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-05 13:45:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-05 13:45:39 +0000
commitc57133fc365bbbda0130bdef7e2be2f6212c7b74 (patch)
tree9fd8f3d259351b0293c2c2251beccb8764555320
parent58fb45f3dd6072a62c8853d31c25cee7e8140684 (diff)
downloadports-c57133fc365bbbda0130bdef7e2be2f6212c7b74.tar.gz
ports-c57133fc365bbbda0130bdef7e2be2f6212c7b74.zip
Notes
-rw-r--r--audio/espeak/Makefile6
-rw-r--r--devel/oniguruma4/Makefile15
-rw-r--r--devel/p5-Class-Accessor-Lvalue/Makefile4
-rw-r--r--devel/p5-Class-Accessor-Lvalue/pkg-plist2
-rw-r--r--devel/p5-Data-TreeDumper/Makefile3
-rw-r--r--devel/p5-Data-TreeDumper/pkg-plist1
-rw-r--r--devel/p5-Log-Dispatchouli/Makefile5
-rw-r--r--devel/p5-Log-Dispatchouli/pkg-plist3
-rw-r--r--devel/p5-MooseX-Types-Perl/Makefile3
-rw-r--r--devel/p5-MooseX-Types-Perl/pkg-plist1
-rw-r--r--devel/p5-Test-YAML-Valid/Makefile2
-rw-r--r--devel/p5-Test-YAML-Valid/pkg-plist1
-rw-r--r--devel/ucommon/pkg-plist1
-rw-r--r--german/pecl-konto_check/Makefile18
-rw-r--r--graphics/geos/Makefile3
-rw-r--r--mail/libesmtp/Makefile15
-rw-r--r--math/pecl-big_int/Makefile13
-rw-r--r--net/pecl-radius/Makefile7
-rw-r--r--print/freetype/Makefile2
-rw-r--r--sysutils/pwgen/Makefile5
20 files changed, 38 insertions, 72 deletions
diff --git a/audio/espeak/Makefile b/audio/espeak/Makefile
index 7679d4fb3406..be951c8a6a4a 100644
--- a/audio/espeak/Makefile
+++ b/audio/espeak/Makefile
@@ -63,10 +63,8 @@ PULSEAUDIOLIB=
post-patch:
cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} ${REINPLACE_FILES}
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/oniguruma4/Makefile b/devel/oniguruma4/Makefile
index bec99321e809..d54b83498077 100644
--- a/devel/oniguruma4/Makefile
+++ b/devel/oniguruma4/Makefile
@@ -19,7 +19,6 @@ DOCS= HISTORY README doc/*
PKGNAMESUFFIX= 4
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
-e 's|freebsd1|freebsd1.|' \
@@ -30,17 +29,13 @@ post-configure:
${FILESDIR}/onig-config > ${WRKSRC}/onig-config
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/*.c ${WRKSRC}/sample/Makefile* \
- ${EXAMPLESDIR}/
-.endif
+ ${STAGEDIR}${EXAMPLESDIR}/
.include <bsd.port.mk>
diff --git a/devel/p5-Class-Accessor-Lvalue/Makefile b/devel/p5-Class-Accessor-Lvalue/Makefile
index 5f74a2788305..81bcf30ba2c7 100644
--- a/devel/p5-Class-Accessor-Lvalue/Makefile
+++ b/devel/p5-Class-Accessor-Lvalue/Makefile
@@ -17,8 +17,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
-MAN3= Class::Accessor::Lvalue.3 \
- Class::Accessor::Lvalue::Fast.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/p5-Class-Accessor-Lvalue/pkg-plist b/devel/p5-Class-Accessor-Lvalue/pkg-plist
index 6212986e0f54..d8e6f0e4c644 100644
--- a/devel/p5-Class-Accessor-Lvalue/pkg-plist
+++ b/devel/p5-Class-Accessor-Lvalue/pkg-plist
@@ -1,5 +1,7 @@
%%SITE_PERL%%/Class/Accessor/Lvalue.pm
%%SITE_PERL%%/Class/Accessor/Lvalue/Fast.pm
+%%PERL5_MAN3%%/Class::Accessor::Lvalue.3.gz
+%%PERL5_MAN3%%/Class::Accessor::Lvalue::Fast.3.gz
@dirrmtry %%SITE_PERL%%/Class/Accessor/Lvalue
@dirrmtry %%SITE_PERL%%/Class/Accessor
@dirrmtry %%SITE_PERL%%/Class
diff --git a/devel/p5-Data-TreeDumper/Makefile b/devel/p5-Data-TreeDumper/Makefile
index 055e4830fec8..ce9cc57f5632 100644
--- a/devel/p5-Data-TreeDumper/Makefile
+++ b/devel/p5-Data-TreeDumper/Makefile
@@ -18,12 +18,9 @@ BUILD_DEPENDS= p5-Term-Size>=0:${PORTSDIR}/devel/p5-Term-Size \
p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
RUN_DEPENDS:= ${BUILD_DEPENDS}
-MAN3= Data::TreeDumper.3
-
USES= perl5
USE_PERL5= configure
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 501400
diff --git a/devel/p5-Data-TreeDumper/pkg-plist b/devel/p5-Data-TreeDumper/pkg-plist
index 7251805842de..0af2f5cd3ee8 100644
--- a/devel/p5-Data-TreeDumper/pkg-plist
+++ b/devel/p5-Data-TreeDumper/pkg-plist
@@ -1,3 +1,4 @@
+%%PERL5_MAN3%%/Data::TreeDumper.3.gz
%%SITE_PERL%%/Data/TreeDumper.pm
%%SITE_PERL%%/Data/colors.pl
%%SITE_PERL%%/Data/filters.pl
diff --git a/devel/p5-Log-Dispatchouli/Makefile b/devel/p5-Log-Dispatchouli/Makefile
index d416fa9dbfef..7f9440c2b8b4 100644
--- a/devel/p5-Log-Dispatchouli/Makefile
+++ b/devel/p5-Log-Dispatchouli/Makefile
@@ -29,11 +29,6 @@ TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
USES= perl5
USE_PERL5= configure
-MAN3= Log::Dispatchouli.3 \
- Log::Dispatchouli::Global.3 \
- Log::Dispatchouli::Proxy.3
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501400
diff --git a/devel/p5-Log-Dispatchouli/pkg-plist b/devel/p5-Log-Dispatchouli/pkg-plist
index 5380411c1db0..a7b31660b0e7 100644
--- a/devel/p5-Log-Dispatchouli/pkg-plist
+++ b/devel/p5-Log-Dispatchouli/pkg-plist
@@ -2,6 +2,9 @@
%%SITE_PERL%%/Log/Dispatchouli/Global.pm
%%SITE_PERL%%/Log/Dispatchouli/Proxy.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatchouli/.packlist
+%%PERL5_MAN3%%/Log::Dispatchouli.3.gz
+%%PERL5_MAN3%%/Log::Dispatchouli::Global.3.gz
+%%PERL5_MAN3%%/Log::Dispatchouli::Proxy.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatchouli
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log
@dirrmtry %%SITE_PERL%%/Log/Dispatchouli
diff --git a/devel/p5-MooseX-Types-Perl/Makefile b/devel/p5-MooseX-Types-Perl/Makefile
index f1e0dc123fbf..26223d679ec8 100644
--- a/devel/p5-MooseX-Types-Perl/Makefile
+++ b/devel/p5-MooseX-Types-Perl/Makefile
@@ -17,9 +17,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= MooseX::Types::Perl.3
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501400
diff --git a/devel/p5-MooseX-Types-Perl/pkg-plist b/devel/p5-MooseX-Types-Perl/pkg-plist
index 10357278994d..ed678f86dca3 100644
--- a/devel/p5-MooseX-Types-Perl/pkg-plist
+++ b/devel/p5-MooseX-Types-Perl/pkg-plist
@@ -1,5 +1,6 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Types/Perl/.packlist
%%SITE_PERL%%/MooseX/Types/Perl.pm
+%%PERL5_MAN3%%/MooseX::Types::Perl.3.gz
@dirrmtry %%SITE_PERL%%/MooseX/Types
@dirrmtry %%SITE_PERL%%/MooseX
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Types/Perl
diff --git a/devel/p5-Test-YAML-Valid/Makefile b/devel/p5-Test-YAML-Valid/Makefile
index 6311e607378a..f57ba862b815 100644
--- a/devel/p5-Test-YAML-Valid/Makefile
+++ b/devel/p5-Test-YAML-Valid/Makefile
@@ -17,8 +17,6 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Test::YAML::Valid.3
-
OPTIONS_DEFINE= YAMLSYCK
YAMLSYCK_DESC= Use YAML::Syck for testing
diff --git a/devel/p5-Test-YAML-Valid/pkg-plist b/devel/p5-Test-YAML-Valid/pkg-plist
index c3ab5d87c45d..91cdedee8ec1 100644
--- a/devel/p5-Test-YAML-Valid/pkg-plist
+++ b/devel/p5-Test-YAML-Valid/pkg-plist
@@ -1,5 +1,6 @@
%%SITE_PERL%%/Test/YAML/Valid.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML/Valid/.packlist
+%%PERL5_MAN3%%/Test::YAML::Valid.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML/Valid
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
diff --git a/devel/ucommon/pkg-plist b/devel/ucommon/pkg-plist
index 6d3b7410c58e..3c4d39afb914 100644
--- a/devel/ucommon/pkg-plist
+++ b/devel/ucommon/pkg-plist
@@ -83,6 +83,7 @@ man/man1/scrub-files.1.gz
man/man1/sockaddr.1.gz
man/man1/ucommon-config.1.gz
man/man1/zerofill.1.gz
+man/man1/keywait.1.gz
@dirrm include/ucommon
@dirrm include/commoncpp
@dirrm bin/ucommon
diff --git a/german/pecl-konto_check/Makefile b/german/pecl-konto_check/Makefile
index 71ef7e5b224f..a1dd57219723 100644
--- a/german/pecl-konto_check/Makefile
+++ b/german/pecl-konto_check/Makefile
@@ -20,9 +20,6 @@ DEFAULT_PHP_VER=53
WRKSRC= ${WRKDIR}/php
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-extract:
@${UNZIP_CMD} -q -d ${WRKDIR} ${WRKDIR}/php.zip
@@ -30,13 +27,10 @@ post-patch:
@${REINPLACE_CMD} -e "s|\"/etc|\"${ETCDIR}|g;" ${WRKSRC}/konto_check.c ${WRKSRC}/konto_check.lxx
post-install:
- @${MKDIR} ${ETCDIR}
- @${INSTALL_DATA} ${WRKDIR}/blz.lut ${ETCDIR}
- @${INSTALL_DATA} ${WRKDIR}/blz.lut2 ${ETCDIR}
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKDIR}/00liesmich.pdf ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ @${INSTALL_DATA} ${WRKDIR}/blz.lut ${STAGEDIR}${ETCDIR}
+ @${INSTALL_DATA} ${WRKDIR}/blz.lut2 ${STAGEDIR}${ETCDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKDIR}/00liesmich.pdf ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index a4ea191d4ff1..f2f25eba36de 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -21,7 +21,6 @@ OPTIONS_DEFINE= PHP PYTHON RUBY
OPTIONS_SUB= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHP} || ${PORT_OPTIONS:MPYTHON} || ${PORT_OPTIONS:MRUBY}
@@ -45,6 +44,6 @@ CONFIGURE_ENV+= RUBY="${RUBY}"
.endif
post-install:
- @${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so ${PREFIX}/lib/libgeos.so.0
+ @${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libgeos.so.0
.include <bsd.port.mk>
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index 316546013339..fa852d4c3679 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= OPENSSL DEBUG DOCS EXAMPLES
OPTIONS_DEFAULT= OPENSSL
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
@@ -29,7 +29,6 @@ USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
@@ -45,15 +44,11 @@ CONFIGURE_ARGS+= --enable-debug
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS ChangeLog NEWS Notes README TODO
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/math/pecl-big_int/Makefile b/math/pecl-big_int/Makefile
index 6398dcd0affc..02ada663f217 100644
--- a/math/pecl-big_int/Makefile
+++ b/math/pecl-big_int/Makefile
@@ -14,7 +14,6 @@ COMMENT= Functions for calculations with arbitrary length integers and bitsets
USE_PHP= yes
USE_PHPEXT= yes
-NO_STAGE= yes
DOCS= CREDITS INSTALL LICENSE README docs/index.html libbig_int/CREDITS \
libbig_int/LICENSE
@@ -22,16 +21,14 @@ EXAMPLES= bitset.php example.php rand.php RSA.php std_header.php
CONFIGURE_ARGS= --enable-big-int=shared
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${DOCSDIR}
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
. for doc in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
. endfor
-. for test in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/tests/${test} ${EXAMPLESDIR}
+. for test in ${STAGEDIR}${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/tests/${test} ${STAGEDIR}${EXAMPLESDIR}
. endfor
-.endif
.include <bsd.port.mk>
diff --git a/net/pecl-radius/Makefile b/net/pecl-radius/Makefile
index d95c28eafe99..5e904ed83f6a 100644
--- a/net/pecl-radius/Makefile
+++ b/net/pecl-radius/Makefile
@@ -14,14 +14,11 @@ COMMENT= Radius client library for PHP
USE_PHP= yes
USE_PHPEXT= yes
-NO_STAGE= yes
CONFIGURE_ARGS= --enable-radius
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/print/freetype/Makefile b/print/freetype/Makefile
index b16f67d0f433..df19e610924b 100644
--- a/print/freetype/Makefile
+++ b/print/freetype/Makefile
@@ -15,13 +15,13 @@ MASTER_SITES= SF \
MAINTAINER= doceng@FreeBSD.org
COMMENT= A free and portable TrueType font rendering engine
+USES= desthack
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
PORTSCOUT= limit:^1\.
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
diff --git a/sysutils/pwgen/Makefile b/sysutils/pwgen/Makefile
index 8fe7ca37510d..3553b8db9ee8 100644
--- a/sysutils/pwgen/Makefile
+++ b/sysutils/pwgen/Makefile
@@ -14,8 +14,7 @@ GNU_CONFIGURE= yes
USES= perl5
USE_PERL5= build
-MAN1= pwgen.1
-PLIST_FILES= bin/pwgen
+PLIST_FILES= bin/pwgen \
+ man/man1/pwgen.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>