aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-04 23:15:05 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-04 23:15:05 +0000
commitc5939966b29483000849f8dd6661eda605999576 (patch)
tree0b291e3c1a183b766c52f015584c38e484e9f94b
parent9bde697a8a4bafb41b9bac3be7527188d46eb671 (diff)
downloadports-c5939966b29483000849f8dd6661eda605999576.tar.gz
ports-c5939966b29483000849f8dd6661eda605999576.zip
Notes
-rw-r--r--databases/evolution-data-server/Makefile4
-rw-r--r--databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c20
2 files changed, 20 insertions, 4 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 9d1612499501..61a5f60b8e81 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -46,10 +46,6 @@ PLIST_SUB= VERSION="1.4" EVO_VERSION="1.2"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not build on 4.X"
-.endif
-
.if ( ( ${OSVERSION} < 504101 ) || ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600012 ) )
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libedataserver_e-msgport.c
.endif
diff --git a/databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c b/databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c
new file mode 100644
index 000000000000..00ea9a3d6b55
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c
@@ -0,0 +1,20 @@
+--- camel/providers/imap/camel-imap-utils.c.orig Tue Nov 29 03:03:43 2005
++++ camel/providers/imap/camel-imap-utils.c Sun Dec 4 23:13:35 2005
+@@ -371,7 +371,7 @@ imap_parse_list_response (CamelImapStore
+ return FALSE;
+
+ if (folder) {
+- char *astring;
++ char *astring, *mailbox;
+
+ /* get the folder name */
+ word = imap_next_word (word);
+@@ -380,8 +380,6 @@ imap_parse_list_response (CamelImapStore
+ return FALSE;
+
+ *folder = astring;
+-
+- char *mailbox;
+
+ mailbox = imap_mailbox_decode (astring, strlen (astring));
+ g_free (astring);