aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 11:14:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 11:14:49 +0000
commitc706f7f3440734871fa53b3918c1e99eb287898c (patch)
tree0460d125ade9bf9b94b7daecf24b65257facfc3b
parent96ec3df0612618019b94f6fd1c41e003d61ffabd (diff)
downloadports-c706f7f3440734871fa53b3918c1e99eb287898c.tar.gz
ports-c706f7f3440734871fa53b3918c1e99eb287898c.zip
Notes
-rw-r--r--cad/salome/Makefile.ext28
-rw-r--r--games/asc/Makefile10
-rw-r--r--games/bastet/Makefile2
-rw-r--r--games/ember/Makefile14
-rw-r--r--games/frogatto/Makefile4
-rw-r--r--games/galaxyhack/Makefile4
-rw-r--r--games/openlierox/Makefile8
-rw-r--r--games/py-fife/Makefile8
-rw-r--r--games/secretmaryochronicles/Makefile6
-rw-r--r--games/spring/Makefile12
-rw-r--r--games/vdrift/Makefile4
-rw-r--r--games/wesnoth/Makefile4
-rw-r--r--graphics/agave/Makefile6
-rw-r--r--graphics/digikam-kde4/Makefile22
-rw-r--r--graphics/gnash/Makefile12
-rw-r--r--graphics/gsculpt/Makefile2
-rw-r--r--graphics/hugin-devel/Makefile20
17 files changed, 83 insertions, 83 deletions
diff --git a/cad/salome/Makefile.ext b/cad/salome/Makefile.ext
index 44af86fe1088..9eaf3d4ce7e3 100644
--- a/cad/salome/Makefile.ext
+++ b/cad/salome/Makefile.ext
@@ -133,14 +133,14 @@ AUTOMAKE_ARGS=--add-missing --copy --gnu
#Dependency from HDF5
.if !${SAL_MODULE} == "randomizer" && !${SAL_MODULE} == "yacs" && !${SAL_MODULE} == "hello" && !${SAL_MODULE} == "pyhello"
-LIB_DEPENDS+= hdf5.7:${PORTSDIR}/science/hdf5-18
+LIB_DEPENDS+= libhdf5.so.7:${PORTSDIR}/science/hdf5-18
CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}
AUTOTOOLS_ENV+= HDF5HOME=${LOCALBASE}
.endif
#Dependency from Opencascade
.if !${SAL_MODULE} == "kernel"
-LIB_DEPENDS+= TKernel.0:${PORTSDIR}/cad/opencascade
+LIB_DEPENDS+= libTKernel.so:${PORTSDIR}/cad/opencascade
CASROOT= ${LOCALBASE}/OpenCAS/ros
CONFIGURE_ENV+= CASROOT=${CASROOT}
AUTOTOOLS_ENV+= CASROOT=${CASROOT}
@@ -154,7 +154,7 @@ BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
#Dependency from libxml2
.if ${SAL_MODULE} == "gui" || ${SAL_MODULE} == "kernel" || ${SAL_MODULE} == "med" || ${SAL_MODULE} == "yacs"
-LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
CPPFLAGS+= -I${LOCALBASE}/include/libxml2
CONFIGURE_ENV+= LIBXML_DIR=${LOCALBASE}
.endif
@@ -162,7 +162,7 @@ CONFIGURE_ENV+= LIBXML_DIR=${LOCALBASE}
#Dependency from boost
.if !${SAL_MODULE} == "light" && !${SAL_MODULE} == "randomizer" && !${SAL_MODULE} == "pycalculator" && !${SAL_MODULE} == "light"
CONFIGURE_ENV+= BOOSTDIR=${LOCALBASE}
-LIB_DEPENDS+= boost_thread:${PORTSDIR}/devel/boost-all
+LIB_DEPENDS+= libboost_thread.so:${PORTSDIR}/devel/boost-all
###python boost support off by default
RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
BUILD_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
@@ -185,14 +185,14 @@ CONFIGURE_ARGS+= --with-qsci4-libraries=${QT_LIBDIR} --with-qsci4-includes=${QT_
#Dependency from vtk
.if !${SAL_MODULE} == "kernel" && !${SAL_MODULE} == "randomizer"
-LIB_DEPENDS+= vtkCommon.5:${PORTSDIR}/math/vtk5
+LIB_DEPENDS+= libvtkCommon.so:${PORTSDIR}/math/vtk5
CONFIGURE_ARGS+= --with-vtk=${LOCALBASE}
CONFIGURE_ENV+= VTKSUFFIX=-5.10
.endif
#Dependency from cad/netgen
.if ${SAL_MODULE} == "netgenplugin"
-LIB_DEPENDS+= nglib.1:${PORTSDIR}/cad/netgen
+LIB_DEPENDS+= libnglib.so:${PORTSDIR}/cad/netgen
CONFIGURE_ENV+= NETGENHOME=${LOCALBASE}
AUTOTOOLS_ENV+= NETGENHOME=${LOCALBASE}
.endif
@@ -200,7 +200,7 @@ AUTOTOOLS_ENV+= NETGENHOME=${LOCALBASE}
#Dependency from qwt5
.if ${SAL_MODULE} == "gui" || ${SAL_MODULE} == "component" || ${SAL_MODULE} == "smesh" || ${SAL_MODULE} == "visu" || ${SAL_MODULE} == "filter"
-LIB_DEPENDS+= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+LIB_DEPENDS+= libqwt.so:${PORTSDIR}/x11-toolkits/qwt5
CONFIGURE_ARGS+= --with-qwt=${LOCALBASE}
CPPFLAGS+= -I/${LOCALBASE}/include/qwt/
AUTOTOOLS_ENV+= QWTHOME=${LOCALBASE}
@@ -208,7 +208,7 @@ AUTOTOOLS_ENV+= QWTHOME=${LOCALBASE}
#Dependency from omniORB & py-omniorb
.if !${SAL_MODULE} == "light"
-LIB_DEPENDS+= omniORB4.1:${PORTSDIR}/devel/omniORB
+LIB_DEPENDS+= libomniORB4.so:${PORTSDIR}/devel/omniORB
RUN_DEPENDS+= ${LOCALBASE}/include/omniORBpy.h:${PORTSDIR}/devel/py-omniorb
RUN_DEPENDS+= notifd:${PORTSDIR}/devel/omniNotify
AUTOTOOLS_ENV+= OMNIORBDIR=${LOCALBASE}
@@ -246,19 +246,19 @@ CPPFLAGS+= -I${LOCALBASE}/include/metis
#Dependency from MED
.if ${SAL_MODULE} == "med"
-LIB_DEPENDS+= med.2:${PORTSDIR}/french/med
+LIB_DEPENDS+= libmed.so:${PORTSDIR}/french/med
CONFIGURE_ENV+= MED2HOME=${LOCALBASE}
.endif
#Dependency from gd
.if ${SAL_MODULE} == "sierpinsky"
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
.endif
.if ${SAL_MODULE} == "yacs"
-LIB_DEPENDS+= argp.0:${PORTSDIR}/devel/argp-standalone
-LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
-LIB_DEPENDS+= gvc:${PORTSDIR}/graphics/graphviz
+LIB_DEPENDS+= libargp.so:${PORTSDIR}/devel/argp-standalone
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= libgvc.so:${PORTSDIR}/graphics/graphviz
LDFLAGS+= -largp
.endif
@@ -282,7 +282,7 @@ PLIST_SUB+= CPPUNIT="@comment "
#optionally dependency from mpich2
.if ${SAL_MODULE} == "kernel" || ${SAL_MODULE} == "med"
.if ${PORT_OPTIONS:MMPI}
-LIB_DEPENDS+= mpich.2:${PORTSDIR}/net/mpich2
+LIB_DEPENDS+= libmpich.so:${PORTSDIR}/net/mpich2
CONFIGURE_ARGS+= --with-mpich=${LOCALBASE}/mpich2 --with-mpi=${LOCALBASE}/mpich2
PLIST_SUB+= MPI=""
. else
diff --git a/games/asc/Makefile b/games/asc/Makefile
index fa88b7ae46d6..9fb66c9a98f5 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -18,10 +18,10 @@ LICENSE= GPLv2
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/lib/libloki.so:${PORTSDIR}/devel/loki
-LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
- boost_regex:${PORTSDIR}/devel/boost-libs \
- sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
- expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libsigc-1.2.so:${PORTSDIR}/devel/libsigc++12 \
+ libexpat.so:${PORTSDIR}/textproc/expat2
RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= MUSIC XVID
@@ -64,7 +64,7 @@ PLIST_FILES+= ${ASC_MUSICDIR}/${file}
.endif
.if ${PORT_OPTIONS:MXVID}
-LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+LIB_DEPENDS+= libxvidcore.so:${PORTSDIR}/multimedia/xvid
.else
CONFIGURE_ENV+= ac_cv_lib_xvidcore_xvid_encore=no
.endif
diff --git a/games/bastet/Makefile b/games/bastet/Makefile
index f282855c60e9..b3009c5209b2 100644
--- a/games/bastet/Makefile
+++ b/games/bastet/Makefile
@@ -13,7 +13,7 @@ COMMENT= An ncurses Tetris clone which is harder than every other Tetris
LICENSE= GPLv3 # (or later)
-LIB_DEPENDS= boost_program_options:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_program_options.so:${PORTSDIR}/devel/boost-libs
USES= ncurses
USE_GMAKE= yes
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 37e5245b5295..8dc0ad2663da 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -15,13 +15,13 @@ COMMENT= Ember is a WorldForge 3D client using the OGRE 3D library
BUILD_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so.1.8.1:${PORTSDIR}/graphics/ogre3d
RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so.1.8.1:${PORTSDIR}/graphics/ogre3d
-LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
- eris-1.3:${PORTSDIR}/devel/eris \
- varconf-1.0.8:${PORTSDIR}/devel/varconf \
- mercator-0.3.3:${PORTSDIR}/devel/mercator \
- wfut-0.2:${PORTSDIR}/devel/libwfut \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- CEGUIBase-0.7.9.0:${PORTSDIR}/graphics/cegui
+LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
+ liberis-1.3.so:${PORTSDIR}/devel/eris \
+ libvarconf-1.0.so:${PORTSDIR}/devel/varconf \
+ libmercator-0.3.so:${PORTSDIR}/devel/mercator \
+ libwfut-0.2.so:${PORTSDIR}/devel/libwfut \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libCEGUIBase-0.7.9.so:${PORTSDIR}/graphics/cegui
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc \
--program-transform-name= --disable-cppunit --disable-debug \
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index aa80333fcbf7..817528a03151 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= GH
MAINTAINER= fiziologus@gmail.com
COMMENT= An old-school 2D classic adventure platformer game
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libpng15.so:${PORTSDIR}/graphics/png
NO_PACKAGE= Package will be 144M, set FORCE_PACKAGE if you really want it
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index 9b28f4911a79..533a5ec3f8f2 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -12,8 +12,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= AI script based strategy game
-LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libfreetype.so:${PORTSDIR}/print/freetype2
USES= dos2unix gmake
USE_BZIP2= yes
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index dd3dffd3607d..34dc0981a9a2 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -11,10 +11,10 @@ DISTNAME= OpenLieroX_${DISTVERSION}.src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Extremely addictive realtime worms shoot-em-up
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- boost_signals:${PORTSDIR}/devel/boost-libs \
- curl:${PORTSDIR}/ftp/curl \
- alut:${PORTSDIR}/audio/freealut
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libboost_signals.so:${PORTSDIR}/devel/boost-libs \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libalut.so:${PORTSDIR}/audio/freealut
USE_BZIP2= yes
USE_SDL= sdl image
diff --git a/games/py-fife/Makefile b/games/py-fife/Makefile
index 930755b429c2..9177752eac52 100644
--- a/games/py-fife/Makefile
+++ b/games/py-fife/Makefile
@@ -17,10 +17,10 @@ COMMENT= Flexible Isometric Free Engine
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
-LIB_DEPENDS= vorbisfile:${PORTSDIR}/audio/libvorbis \
- guichan:${PORTSDIR}/devel/guichan \
- boost_filesystem:${PORTSDIR}/devel/boost-libs \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libguichan.so:${PORTSDIR}/devel/guichan \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libpng15.so:${PORTSDIR}/graphics/png
FETCH_ARGS= -Fpr
diff --git a/games/secretmaryochronicles/Makefile b/games/secretmaryochronicles/Makefile
index 3c140c9132ce..87ad68885369 100644
--- a/games/secretmaryochronicles/Makefile
+++ b/games/secretmaryochronicles/Makefile
@@ -12,9 +12,9 @@ DISTNAME= smc-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Secret Maryo Chronicles two-dimensional platform game
-LIB_DEPENDS= CEGUIBase-0.7.9:${PORTSDIR}/graphics/cegui \
- boost_filesystem:${PORTSDIR}/devel/boost-libs \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libCEGUIBase-0.7.9.so:${PORTSDIR}/graphics/cegui \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libpng15.so:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_AUTOTOOLS= aclocal:env autoheader:env autoconf:env automake:env
diff --git a/games/spring/Makefile b/games/spring/Makefile
index a4d71427142c..e5a6181b7606 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -16,12 +16,12 @@ EXPIRATION_DATE= 2013-12-22
BROKEN= Does not build with recent boost
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- IL:${PORTSDIR}/graphics/devil \
- ogg:${PORTSDIR}/audio/libogg \
- vorbis:${PORTSDIR}/audio/libvorbis \
- execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libIL.so:${PORTSDIR}/graphics/devil \
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
ONLY_FOR_ARCHS= i386 amd64
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index 8f1a3d6a9909..b3fc7baee619 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -15,8 +15,8 @@ COMMENT= Open source driving simulation
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons \
${LOCALBASE}/lib/libBulletCollision.a:${PORTSDIR}/devel/bullet \
${LOCALBASE}/include/asio.hpp:${PORTSDIR}/net/asio
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/settings/VDrift.config:${PORTSDIR}/games/vdrift-data
USE_BZIP2= yes
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 6255fbd001ff..8ced5ae65e9e 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -14,8 +14,8 @@ LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/lib/X11/fonts/junicode/Junicode.ttf:${PORTSDIR}/x11-fonts/junicode
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libpng15.so:${PORTSDIR}/graphics/png
USE_SDL= image mixer net ttf
USE_GNOME= pango desktopfileutils
diff --git a/graphics/agave/Makefile b/graphics/agave/Makefile
index 4ee08a9716d7..b8b53d700a3f 100644
--- a/graphics/agave/Makefile
+++ b/graphics/agave/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= http://download.gna.org/colorscheme/releases/
MAINTAINER= ps.ports@smyrak.com
COMMENT= A color scheme builder for the GNOME desktop
-LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
- boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libglademm-2.4.so:${PORTSDIR}/devel/libglademm24 \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs
# --disable-gnome option is broken in 0.4.2
#OPTIONS= GNOME "Adds GNOME support" on
@@ -33,7 +33,7 @@ NO_STAGE= yes
#CONFIGURE_ARGS+= --disable-gnome --disable-gconf
#.else
USE_GNOME+= libgnomeui
-LIB_DEPENDS+= gconfmm-2.6:${PORTSDIR}/devel/gconfmm26
+LIB_DEPENDS+= libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26
#.endif
.include <bsd.port.post.mk>
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 236ed635fee5..2997fa4a8229 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -14,16 +14,16 @@ NO_STAGE= yes
.include "${.CURDIR}/Makefile.common"
BUILD_DEPENDS= ${LOCALBASE}/include/eigen3/Eigen/Eigen:${PORTSDIR}/math/eigen3
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
- lcms:${PORTSDIR}/graphics/lcms \
- png15:${PORTSDIR}/graphics/png \
- jasper:${PORTSDIR}/graphics/jasper \
- lensfun:${PORTSDIR}/graphics/lensfun \
- lqr-1:${PORTSDIR}/graphics/liblqr-1 \
- kface:${PORTSDIR}/graphics/libkface \
- pgf:${PORTSDIR}/graphics/libpgf \
- kgeomap:${PORTSDIR}/astro/libkgeomap \
- boost_graph:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjasper.so:${PORTSDIR}/graphics/jasper \
+ liblensfun.so:${PORTSDIR}/graphics/lensfun \
+ liblqr-1.so:${PORTSDIR}/graphics/liblqr-1 \
+ libkface.so:${PORTSDIR}/graphics/libkface \
+ libpgf.so:${PORTSDIR}/graphics/libpgf \
+ libkgeomap.so:${PORTSDIR}/astro/libkgeomap \
+ libboost_graph.so:${PORTSDIR}/devel/boost-libs
LATEST_LINK= ${PORTNAME}-kde4
@@ -56,7 +56,7 @@ RUN_DEPENDS+= digikam-doc>=${DIGIKAM_VER}:${PORTSDIR}/graphics/digikam-kde4-doc
.endif
.if ${PORT_OPTIONS:MGPHOTO2}
-LIB_DEPENDS+= gphoto2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS+= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
.else
CMAKE_ARGS+= -DWITH_Gphoto2:BOOL=OFF
.endif
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 34f5d752d84a..e39f5525853e 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -10,12 +10,12 @@ MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNU Flash movie player
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
- jpeg:${PORTSDIR}/graphics/jpeg \
- curl:${PORTSDIR}/ftp/curl \
- gif:${PORTSDIR}/graphics/giflib \
- speex:${PORTSDIR}/audio/speex \
- nspr4:${PORTSDIR}/devel/nspr
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libgif.so:${PORTSDIR}/graphics/giflib \
+ libspeex.so:${PORTSDIR}/audio/speex \
+ libnspr4.so:${PORTSDIR}/devel/nspr
CONFLICTS= gnash-devel-[0-9]*
NO_STAGE= yes
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 0bfe6234755c..0d0d0526bba0 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -13,7 +13,7 @@ COMMENT= An Opensource 3D modelling application
LICENSE= GPLv2
-LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>0:${PORTSDIR}/graphics/py-opengl \
${PYTHON_PKGNAMEPREFIX}gtkglext>0:${PORTSDIR}/x11-toolkits/py-gtkglext
diff --git a/graphics/hugin-devel/Makefile b/graphics/hugin-devel/Makefile
index 64e3045e1b4f..1322c24903c2 100644
--- a/graphics/hugin-devel/Makefile
+++ b/graphics/hugin-devel/Makefile
@@ -12,16 +12,16 @@ DISTNAME= hugin-2013.0.0_beta1
MAINTAINER= grog@FreeBSD.org
COMMENT= A GUI for Panorama Tools, to stitch panoramic images
-LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- Imath:${PORTSDIR}/graphics/ilmbase \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- exiv2:${PORTSDIR}/graphics/exiv2 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- lensfun:${PORTSDIR}/graphics/lensfun \
- pano13:${PORTSDIR}/graphics/libpano13 \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libImath.so:${PORTSDIR}/graphics/ilmbase \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblensfun.so:${PORTSDIR}/graphics/lensfun \
+ libpano13.so:${PORTSDIR}/graphics/libpano13 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20 \
tclap>=1.2.1:${PORTSDIR}/devel/tclap
# gmake is really needed at _runtime_. Do not remove it from this list.