aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-12 21:21:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-12 21:21:14 +0000
commitcf25cf89165b7638378c1223ef231c5bbd16ded6 (patch)
tree0d66ab987b19c4582d44b1b22709a838eb591ec3
parent5250efe2de098fe53d7b3767043c9e640e25e21a (diff)
downloadports-cf25cf89165b7638378c1223ef231c5bbd16ded6.tar.gz
ports-cf25cf89165b7638378c1223ef231c5bbd16ded6.zip
Notes
-rw-r--r--x11/Makefile1
-rw-r--r--x11/fbpanel/Makefile27
-rw-r--r--x11/fbpanel/distinfo2
-rw-r--r--x11/fbpanel/files/patch-Makefile13
-rw-r--r--x11/fbpanel/files/patch-Makefile.common14
-rw-r--r--x11/fbpanel/files/patch-default.cfg15
-rw-r--r--x11/fbpanel/pkg-descr12
-rw-r--r--x11/fbpanel/pkg-plist15
8 files changed, 99 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 8dede66e37bc..7f335ccb462f 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -43,6 +43,7 @@
SUBDIR += erun
SUBDIR += eterm
SUBDIR += eweather
+ SUBDIR += fbpanel
SUBDIR += fbsd-icons
SUBDIR += fixesext
SUBDIR += fluxbg
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
new file mode 100644
index 000000000000..cf25fce449f9
--- /dev/null
+++ b/x11/fbpanel/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: fbpanel
+# Date created: Sat Jun 26 13:43:50 CEST 2004
+# Whom: Tobias Roth <ports@fsck.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fbpanel
+PORTVERSION= 3.8
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@fsck.ch
+COMMENT= A desktop panel that includes a taskbar, pager, launchbar and more
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_GMAKE= yes
+
+MAN1= fbpanel.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/x11/fbpanel/distinfo b/x11/fbpanel/distinfo
new file mode 100644
index 000000000000..634a3f665627
--- /dev/null
+++ b/x11/fbpanel/distinfo
@@ -0,0 +1,2 @@
+MD5 (fbpanel-3.8.tgz) = 95e43a2c201feb5e272bbd9a4f78ad6e
+SIZE (fbpanel-3.8.tgz) = 72121
diff --git a/x11/fbpanel/files/patch-Makefile b/x11/fbpanel/files/patch-Makefile
new file mode 100644
index 000000000000..918b9c9a63bf
--- /dev/null
+++ b/x11/fbpanel/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- man/Makefile.orig Sat Jun 26 12:37:59 2004
++++ man/Makefile Sat Jun 26 12:38:14 2004
+@@ -20,8 +20,8 @@
+
+
+ install: all
+- install -d $(PREFIX)/share/man/man1
+- install -m 644 $(TARGET) $(PREFIX)/share/man/man1
++ install -d $(PREFIX)/man/man1
++ install -m 644 $(TARGET) $(PREFIX)/man/man1
+
+ uninstall:
+ rm -f $(PREFIX)/share/man/man1/$(TARGET)
diff --git a/x11/fbpanel/files/patch-Makefile.common b/x11/fbpanel/files/patch-Makefile.common
new file mode 100644
index 000000000000..94b33a3a4102
--- /dev/null
+++ b/x11/fbpanel/files/patch-Makefile.common
@@ -0,0 +1,14 @@
+--- Makefile.common.orig Sat Jun 26 14:00:42 2004
++++ Makefile.common Sat Jun 26 14:03:02 2004
+@@ -15,10 +15,9 @@
+ endif
+ endif
+
+-CC = gcc
++CC ?= gcc
+ LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
+ INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
+-CFLAGS = -O2 # overwriten by command line or env. variable
+ CFLAGS += -Wall # always nice to have
+ ifneq (,$(DEVEL))
+ CFLAGS := -g -Wall
diff --git a/x11/fbpanel/files/patch-default.cfg b/x11/fbpanel/files/patch-default.cfg
new file mode 100644
index 000000000000..b5da17af254d
--- /dev/null
+++ b/x11/fbpanel/files/patch-default.cfg
@@ -0,0 +1,15 @@
+--- config/default.cfg.orig Sat Jun 26 13:37:20 2004
++++ config/default.cfg Sat Jun 26 13:37:27 2004
+@@ -190,9 +190,9 @@
+ Plugin {
+ type = taskbar
+ expand = true
+- ShowIconified = true
+- ShowMapped = true
+- ShowAllDesks = false
++ #ShowIconified = true
++ #ShowMapped = true
++ #ShowAllDesks = false
+ config {
+ tooltips = true
+ iconsonly = false
diff --git a/x11/fbpanel/pkg-descr b/x11/fbpanel/pkg-descr
new file mode 100644
index 000000000000..cdd212571633
--- /dev/null
+++ b/x11/fbpanel/pkg-descr
@@ -0,0 +1,12 @@
+Fbpanel is a lightweight desktop panel that works with any
+NETWM (http://www.freedesktop.org/) compliant window manager.
+It features:
+ o taskbar - show list of open windows
+ o pager - thumbnailed view of the desktop(s)
+ o launchbar - buttons to launch applications
+ o show desktop - button to iconify or shade all windows
+ o image - display an image
+ o clock - show the current time and/or date
+ o sytem tray - tray for XEMBED icons (aka docklets)
+
+WWW: http://fbpanel.sourceforge.net/
diff --git a/x11/fbpanel/pkg-plist b/x11/fbpanel/pkg-plist
new file mode 100644
index 000000000000..0f94d5ea6db8
--- /dev/null
+++ b/x11/fbpanel/pkg-plist
@@ -0,0 +1,15 @@
+bin/fbpanel
+share/fbpanel/default
+share/fbpanel/pager
+share/fbpanel/images/Desktop2.png
+share/fbpanel/images/Editor.png
+share/fbpanel/images/Emacs.png
+share/fbpanel/images/GNOME-Terminal.png
+share/fbpanel/images/Menu.png
+share/fbpanel/images/Networking.png
+share/fbpanel/images/bottom-left.xpm
+share/fbpanel/images/bottom-right.xpm
+share/fbpanel/images/top-left.xpm
+share/fbpanel/images/top-right.xpm
+@dirrm share/fbpanel/images
+@dirrm share/fbpanel