aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-12-18 17:02:09 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-12-18 17:02:09 +0000
commitcf8f9e48af5d876fe19f45ae0646e846a5d6f023 (patch)
tree9313b0c853b8a10607143a9c68ac70641e32e301
parenta2957738903966e767dc87ed076e051509d07145 (diff)
downloadports-cf8f9e48af5d876fe19f45ae0646e846a5d6f023.tar.gz
ports-cf8f9e48af5d876fe19f45ae0646e846a5d6f023.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-game/Makefile37
-rw-r--r--devel/py-game/distinfo1
-rw-r--r--devel/py-game/files/patch-aa13
-rw-r--r--devel/py-game/files/patch-ab13
-rw-r--r--devel/py-game/pkg-comment1
-rw-r--r--devel/py-game/pkg-descr4
-rw-r--r--devel/py-game/pkg-plist33
8 files changed, 103 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4bff5cb082bb..0e27530e1349 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -279,6 +279,7 @@
SUBDIR += pth-devel
SUBDIR += py-coro
SUBDIR += py-functional
+ SUBDIR += py-game
SUBDIR += py-htmlkit
SUBDIR += py-kjbuckets
SUBDIR += py-kqueue
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
new file mode 100644
index 000000000000..45e2c8cd7e74
--- /dev/null
+++ b/devel/py-game/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-game
+# Date created: 14 December 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= py-game
+PORTVERSION= 0.4
+CATEGORIES= devel python
+MASTER_SITES= http://pygame.seul.org/ftp/
+DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+LIB_DEPENDS= SDL_ttf.2:${PORTSDIR}/graphics/sdl_ttf \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ smpeg.1:${PORTSDIR}/graphics/smpeg
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD}
+MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+do-configure:
+ ${SETUP_CMD} config.py
+
+do-build:
+ ${SETUP_CMD} setup.py build
+
+do-install:
+ ${SETUP_CMD} setup.py install
+
+.include <bsd.port.mk>
diff --git a/devel/py-game/distinfo b/devel/py-game/distinfo
new file mode 100644
index 000000000000..9185b3e686a4
--- /dev/null
+++ b/devel/py-game/distinfo
@@ -0,0 +1 @@
+MD5 (pygame-0.4.tar.gz) = 6575358c5f440cbaae9561e26c5a666c
diff --git a/devel/py-game/files/patch-aa b/devel/py-game/files/patch-aa
new file mode 100644
index 000000000000..3244d79d9bd0
--- /dev/null
+++ b/devel/py-game/files/patch-aa
@@ -0,0 +1,13 @@
+--- config_unix.py 2000/12/16 08:03:29 1.1
++++ config_unix.py 2000/12/16 08:23:56
+@@ -4,7 +4,9 @@
+ import os, sys, shutil
+ from glob import glob
+
+-configcommand = 'sdl-config --version --cflags --libs'
++try: configcommand = os.environ['SDL_CONFIG']
++except KeyError: configcommand = 'sdl-config'
++configcommand = configcommand + ' --version --cflags --libs'
+
+
+
diff --git a/devel/py-game/files/patch-ab b/devel/py-game/files/patch-ab
new file mode 100644
index 000000000000..cf068756dce4
--- /dev/null
+++ b/devel/py-game/files/patch-ab
@@ -0,0 +1,13 @@
+--- Setup.in 2000/12/16 09:11:55 1.1
++++ Setup.in 2000/12/16 09:12:14
+@@ -4,8 +4,8 @@
+ SDL = -I/usr/include/SDL -D_REENTRANT -lSDL
+ FONT = -lSDL_ttf
+ IMAGE = -lSDL_image
+-MIXER = -lSDL_mixer
+-SMPEG = -lsmpeg
++MIXER = -lSDL_mixer -lgcc_r
++SMPEG = -lsmpeg -lgcc_r
+ #--EndConfig
+
+
diff --git a/devel/py-game/pkg-comment b/devel/py-game/pkg-comment
new file mode 100644
index 000000000000..70c2cb435126
--- /dev/null
+++ b/devel/py-game/pkg-comment
@@ -0,0 +1 @@
+A module designed to write games in Python
diff --git a/devel/py-game/pkg-descr b/devel/py-game/pkg-descr
new file mode 100644
index 000000000000..a8d528d0dd74
--- /dev/null
+++ b/devel/py-game/pkg-descr
@@ -0,0 +1,4 @@
+Pygame is a cross-platfrom library designed to make it easy to write
+multimedia software, such as games, in Python.
+
+WWW: http://pygame.seul.org
diff --git a/devel/py-game/pkg-plist b/devel/py-game/pkg-plist
new file mode 100644
index 000000000000..b0a3d6ab4ac4
--- /dev/null
+++ b/devel/py-game/pkg-plist
@@ -0,0 +1,33 @@
+include/%%PYTHON_VERSION%%/pygame/font.h
+include/%%PYTHON_VERSION%%/pygame/mixer.h
+include/%%PYTHON_VERSION%%/pygame/pygame.h
+lib/%%PYTHON_VERSION%%/site-packages/pygame/UserRect.py
+lib/%%PYTHON_VERSION%%/site-packages/pygame/UserRect.pyc
+lib/%%PYTHON_VERSION%%/site-packages/pygame/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/pygame/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/pygame/base.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/bluebold.ttf
+lib/%%PYTHON_VERSION%%/site-packages/pygame/bluebold.txt
+lib/%%PYTHON_VERSION%%/site-packages/pygame/cdrom.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/constants.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/cursors.py
+lib/%%PYTHON_VERSION%%/site-packages/pygame/cursors.pyc
+lib/%%PYTHON_VERSION%%/site-packages/pygame/display.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/event.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/font.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/ignore.pth
+lib/%%PYTHON_VERSION%%/site-packages/pygame/image.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/joystick.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/key.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/locals.py
+lib/%%PYTHON_VERSION%%/site-packages/pygame/locals.pyc
+lib/%%PYTHON_VERSION%%/site-packages/pygame/mixer.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/mixer_music.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/mouse.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/rect.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/rwobject.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/surface.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/surfarray.so
+lib/%%PYTHON_VERSION%%/site-packages/pygame/time.so
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/pygame
+@dirrm include/%%PYTHON_VERSION%%/pygame