aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-09-01 14:43:05 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-09-01 14:43:05 +0000
commitd1a1be32bb370b8a08f8f3e7d0b79dfcc3c83a38 (patch)
tree8001364dc26e797d24637bb0664724a0641c7bc7
parent1423ac796148ec15c594a386281290fcba7301b7 (diff)
downloadports-d1a1be32bb370b8a08f8f3e7d0b79dfcc3c83a38.tar.gz
ports-d1a1be32bb370b8a08f8f3e7d0b79dfcc3c83a38.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Games-Bingo-Print/Makefile37
-rw-r--r--games/p5-Games-Bingo-Print/distinfo1
-rw-r--r--games/p5-Games-Bingo-Print/pkg-descr9
-rw-r--r--games/p5-Games-Bingo-Print/pkg-plist11
5 files changed, 59 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 45c734dcbfed..4be74d00c786 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -267,6 +267,7 @@
SUBDIR += openglad
SUBDIR += p5-Games-Bingo
SUBDIR += p5-Games-Bingo-Bot
+ SUBDIR += p5-Games-Bingo-Print
SUBDIR += pengpong
SUBDIR += penguin-command
SUBDIR += pentix
diff --git a/games/p5-Games-Bingo-Print/Makefile b/games/p5-Games-Bingo-Print/Makefile
new file mode 100644
index 000000000000..495d4f81eb5c
--- /dev/null
+++ b/games/p5-Games-Bingo-Print/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Games-Bingo
+# Date created: 14. August 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Bingo-Print
+PORTVERSION= 0.01
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Games::Bingo::Print - PDF Generation Class
+
+BUILD_DEPENDS= ${SITE_PERL}/Games/Bingo.pm:${PORTSDIR}/games/p5-Games-Bingo \
+ ${SITE_PERL}/PDFLib.pm:${PORTSDIR}/print/p5-PDFLib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::Bingo::Print.3 \
+ Games::Bingo::Print::Card.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingo_print.pl ${EXAMPLESDIR}
+.endif
+
+test:
+ @cd ${WRKSRC}; make test
+
+.include <bsd.port.mk>
diff --git a/games/p5-Games-Bingo-Print/distinfo b/games/p5-Games-Bingo-Print/distinfo
new file mode 100644
index 000000000000..aded9aa755f8
--- /dev/null
+++ b/games/p5-Games-Bingo-Print/distinfo
@@ -0,0 +1 @@
+MD5 (Games-Bingo-Print-0.01.tar.gz) = d35542672c7691549a1a096b9e70c0b0
diff --git a/games/p5-Games-Bingo-Print/pkg-descr b/games/p5-Games-Bingo-Print/pkg-descr
new file mode 100644
index 000000000000..aae3300934a1
--- /dev/null
+++ b/games/p5-Games-Bingo-Print/pkg-descr
@@ -0,0 +1,9 @@
+Games::Bingo::Print - PDF Generation Class
+
+This is that actual printing class. It generates a PDF file with pages
+containing bingo cards.
+
+WWW: http://search.cpan.org/dist/Games-Bingo-Print/
+
+- Lars Thegler
+lars@thegler.dk
diff --git a/games/p5-Games-Bingo-Print/pkg-plist b/games/p5-Games-Bingo-Print/pkg-plist
new file mode 100644
index 000000000000..907c4b965d8b
--- /dev/null
+++ b/games/p5-Games-Bingo-Print/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Games/Bingo/Print.pm
+%%SITE_PERL%%/Games/Bingo/Print/Card.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo/Print/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/bingo_print.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo/Print
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Games/Bingo/Print
+@unexec rmdir %D/%%SITE_PERL%%/Games/Bingo 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true