aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-24 16:42:59 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-24 16:42:59 +0000
commitd45fbf3040b3448bc804ff8be8a816d15ea3f92a (patch)
tree73abd51bbc7bd715261a06c070c1e731d552daf9
parent99b077f4d4a67e28e40efdac8b2e5d977e2d7366 (diff)
downloadports-d45fbf3040b3448bc804ff8be8a816d15ea3f92a.tar.gz
ports-d45fbf3040b3448bc804ff8be8a816d15ea3f92a.zip
Notes
-rw-r--r--news/hellanzb/Makefile5
-rw-r--r--news/papercut/Makefile2
-rw-r--r--news/py-pynzb/Makefile5
-rw-r--r--news/py-twistedNews/Makefile6
-rw-r--r--news/py-yenc/Makefile4
-rw-r--r--news/sabnzbdplus/Makefile3
-rw-r--r--news/xpn/Makefile4
-rw-r--r--print/biblio-py/Makefile5
-rw-r--r--print/cloudprint/Makefile4
-rw-r--r--print/cups-base/Makefile2
-rw-r--r--print/cups-cloud-print/Makefile3
-rw-r--r--print/dot2tex/Makefile5
-rw-r--r--print/frescobaldi/Makefile6
-rw-r--r--print/gnome-specimen/Makefile3
-rw-r--r--print/hplip-plugin/Makefile2
-rw-r--r--print/lilypond-devel/Makefile3
-rw-r--r--print/lilypond/Makefile3
-rw-r--r--print/lyx/Makefile3
-rw-r--r--print/mftrace/Makefile3
-rw-r--r--print/pkipplib/Makefile4
-rw-r--r--print/py-fonttools/Makefile5
-rw-r--r--print/py-pdf/Makefile6
-rw-r--r--print/py-pollyreports/Makefile5
-rw-r--r--print/py-preppy/Makefile5
-rw-r--r--print/py-pyscript/Makefile4
-rw-r--r--print/py-relatorio/Makefile5
-rw-r--r--print/py-reportlab/Makefile5
-rw-r--r--print/py-reportlab1/Makefile6
-rw-r--r--print/py-rtf/Makefile5
-rw-r--r--print/ttfquery/Makefile5
30 files changed, 49 insertions, 77 deletions
diff --git a/news/hellanzb/Makefile b/news/hellanzb/Makefile
index 8e86dc991f0a..6b7e7891b066 100644
--- a/news/hellanzb/Makefile
+++ b/news/hellanzb/Makefile
@@ -18,9 +18,8 @@ RUN_DEPENDS= par2:${PORTSDIR}/archivers/par2cmdline \
${PYTHON_PKGNAMEPREFIX}yenc>=0:${PORTSDIR}/news/py-yenc \
mac:${PORTSDIR}/audio/mac
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-USES= twisted:run,web
+USE_PYTHON= distutils
+USES= python:2 twisted:run,web
PORTDOCS= CHANGELOG CREDITS README
OPTIONS_DEFINE= DOCS
diff --git a/news/papercut/Makefile b/news/papercut/Makefile
index 2da914393373..38b1def0a760 100644
--- a/news/papercut/Makefile
+++ b/news/papercut/Makefile
@@ -11,7 +11,7 @@ COMMENT= Papercut is a news server written in Python, using a MySQL backend
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
-USE_PYTHON= yes
+USES= python
NO_BUILD= yes
do-configure:
diff --git a/news/py-pynzb/Makefile b/news/py-pynzb/Makefile
index dddb735b4a66..f1ec2b429846 100644
--- a/news/py-pynzb/Makefile
+++ b/news/py-pynzb/Makefile
@@ -13,9 +13,8 @@ COMMENT= Unified API for parsing NZB files
LICENSE= BSD3CLAUSE
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
OPTIONS_DEFINE= LXML
diff --git a/news/py-twistedNews/Makefile b/news/py-twistedNews/Makefile
index 9069b3ab72fa..7519155d452c 100644
--- a/news/py-twistedNews/Makefile
+++ b/news/py-twistedNews/Makefile
@@ -14,9 +14,7 @@ COMMENT= NNTP protocol implementation with client and server
LICENSE= MIT
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
-USES= tar:bzip2 twisted
+USE_PYTHON= distutils autoplist
+USES= python:2 tar:bzip2 twisted
.include <bsd.port.mk>
diff --git a/news/py-yenc/Makefile b/news/py-yenc/Makefile
index 3220eb983b2d..d874d71dfa8f 100644
--- a/news/py-yenc/Makefile
+++ b/news/py-yenc/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= yenc decoding module for Python in C
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
.include <bsd.port.mk>
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 3ff7a9f1f8e0..dea8c9fa8d12 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -64,8 +64,7 @@ LICENSE_NAME_SSMTPLIB= ssmtplib License
LICENSE_FILE_SSMTPLIB= ${WRKSRC}/licenses/License-ssmtplib.txt
LICENSE_PERMS_SSMTPLIB= auto-accept
-USE_PYTHON= yes
-USES= gettext
+USES= gettext python
NO_BUILD= yes
WRKSRC= ${WRKDIR}/SABnzbd-${PORTVERSION}
diff --git a/news/xpn/Makefile b/news/xpn/Makefile
index f791e0b63efe..cee03d62661c 100644
--- a/news/xpn/Makefile
+++ b/news/xpn/Makefile
@@ -15,15 +15,13 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolki
NO_BUILD= yes
-USE_PYTHON= yes
-
FIND_DIRS= -type d
FIND_DATA= -type f -mindepth 2 -not -name "*~"
SUB_FILES= ${PORTNAME}
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} XPN=${XPN}
-USES= gettext
+USES= gettext python
XPN= ${PORTNAME}.py
diff --git a/print/biblio-py/Makefile b/print/biblio-py/Makefile
index 873e449ec025..8d68777a146b 100644
--- a/print/biblio-py/Makefile
+++ b/print/biblio-py/Makefile
@@ -11,8 +11,7 @@ COMMENT= Package to manage bibliography written in python
LICENSE= GPLv2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/print/cloudprint/Makefile b/print/cloudprint/Makefile
index 2e7d015d4aa4..ea84936567b0 100644
--- a/print/cloudprint/Makefile
+++ b/print/cloudprint/Makefile
@@ -18,8 +18,8 @@ GH_ACCOUNT= armooo
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= d55435a
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
+USES= python:2
+USE_PYTHON= distutils
USE_RC_SUBR= ${PORTNAME}
USERS= cups
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 8fd3b6106648..94ebf98dc0cc 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -163,7 +163,7 @@ WANT_PHP_CGI= yes
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MPYTHON}
CONFIGURE_ARGS+= --with-python=${PYTHON_CMD}
-USE_PYTHON= yes
+USES+= python
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MLIBPAPER}
diff --git a/print/cups-cloud-print/Makefile b/print/cups-cloud-print/Makefile
index 37a9a6e2a7b6..fcb4c4aec0b7 100644
--- a/print/cups-cloud-print/Makefile
+++ b/print/cups-cloud-print/Makefile
@@ -21,9 +21,8 @@ GH_COMMIT= d7ce53b
GH_TAGNAME= ${GH_COMMIT}
HAS_CONFIGURE= yes
-USE_PYTHON= yes
-USES= gmake shebangfix
+USES= gmake python shebangfix
SHEBANG_FILES= full-test.sh
#CONFIGURE_ARGS= --cupsgroup=cups
diff --git a/print/dot2tex/Makefile b/print/dot2tex/Makefile
index 1c6e1b0f40e4..b3fd70de5b89 100644
--- a/print/dot2tex/Makefile
+++ b/print/dot2tex/Makefile
@@ -13,9 +13,8 @@ COMMENT= Graphviz to LaTeX converter
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing \
dot:${PORTSDIR}/graphics/graphviz
-USE_PYDISTUTILS=yes
-USE_PYTHON= yes
# The .tar.gz sucks!
-USES= zip
+USES= python zip
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/print/frescobaldi/Makefile b/print/frescobaldi/Makefile
index 7a5622b78a9f..9bc2fbba113c 100644
--- a/print/frescobaldi/Makefile
+++ b/print/frescobaldi/Makefile
@@ -16,12 +16,10 @@ LICENSE_COMB= dual
RUN_DEPENDS= lilypond:${PORTSDIR}/print/lilypond \
${PYTHON_PKGNAMEPREFIX}poppler-qt4>=0:${PORTSDIR}/graphics/py-poppler-qt4
-USES= gettext
+USES= gettext python
INSTALLS_ICONS= yes
USE_KDE4= kdeprefix kdelibs pykde4_build pykde4_run
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST=yes
+USE_PYTHON= distutils autoplist
post-patch:
@${REINPLACE_CMD} '/install-script=frescobaldi-wininst.py/d' ${WRKSRC}/setup.cfg
diff --git a/print/gnome-specimen/Makefile b/print/gnome-specimen/Makefile
index b26046dced2f..7935808c8b82 100644
--- a/print/gnome-specimen/Makefile
+++ b/print/gnome-specimen/Makefile
@@ -13,8 +13,7 @@ COMMENT= Gnome Specimen is a simple tool to preview and compare installed fonts
GNU_CONFIGURE= yes
USE_GNOME= pygnomedesktop
GCONF_SCHEMAS= gnome-specimen.schemas
-USE_PYTHON= yes
-USES= gettext gmake
+USES= gettext gmake python
USE_AUTOTOOLS= automake:env
INSTALLS_ICONS= yes
diff --git a/print/hplip-plugin/Makefile b/print/hplip-plugin/Makefile
index bef85f2612cd..855828cf58ba 100644
--- a/print/hplip-plugin/Makefile
+++ b/print/hplip-plugin/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= hp-plugin:${PORTSDIR}/print/hplip
RESTRICTED= License agreement is required
-USE_PYTHON= yes
+USES= python
NO_BUILD= yes
WRKSRC= ${WRKDIR}/plugin_tmp
HPLIP_FAKEDIR= ${WRKDIR}/hplip_fakedir
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index 8348dd93046c..fa2358f149cf 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -46,11 +46,10 @@ INFO= internals \
lilypond-web \
music-glossary
-USES= bison:build gettext gmake pkgconfig perl5 compiler:c++11-lib
+USES= bison:build gettext gmake pkgconfig perl5 compiler:c++11-lib python:-3
USE_CXXSTD= c++11
USE_GHOSTSCRIPT=9
USE_TEX= latex
-USE_PYTHON= -3
USE_PERL5= build
USE_GNOME= pango
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index f80b3b0c885f..6cfa060f07fc 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -47,10 +47,9 @@ INFO= internals \
lilypond-web \
music-glossary
-USES= bison:build gettext gmake pkgconfig perl5
+USES= bison:build gettext gmake pkgconfig perl5 python:-3
USE_GHOSTSCRIPT=9
USE_TEX= latex
-USE_PYTHON= -3
USE_PERL5= build
USE_GNOME= pango
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 6fa76901c042..3e246ebcc424 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs \
MAJOR_VERSION= 2.1
MINOR_VERSION= 2
-USES= desktop-file-utils gmake iconv pkgconfig perl5 tar:xz
-USE_PYTHON= 2
+USES= desktop-file-utils gmake iconv pkgconfig perl5 python:2 tar:xz
USE_QT4= corelib gui moc_build uic_build rcc_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-boost \
diff --git a/print/mftrace/Makefile b/print/mftrace/Makefile
index 24c6ccaddc4b..f1bd238cedb3 100644
--- a/print/mftrace/Makefile
+++ b/print/mftrace/Makefile
@@ -23,10 +23,9 @@ RUN_DEPENDS+= potrace:${PORTSDIR}/graphics/potrace
.endif
# Python3 ready
-USE_PYTHON= yes
USE_TEX= base texmf
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake python
MAKEFILE= GNUmakefile
diff --git a/print/pkipplib/Makefile b/print/pkipplib/Makefile
index 27247024f2d1..c71cf70b8d7e 100644
--- a/print/pkipplib/Makefile
+++ b/print/pkipplib/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.pykota.com/software/pkipplib/download/tarballs/
MAINTAINER= rafan@FreeBSD.org
COMMENT= Create and parse IPP requests
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
.include <bsd.port.mk>
diff --git a/print/py-fonttools/Makefile b/print/py-fonttools/Makefile
index da8f8b00ae14..9490204475f6 100644
--- a/print/py-fonttools/Makefile
+++ b/print/py-fonttools/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= ${PYNUMPY} ${PYXML}
OPTIONS_DEFINE= DOCS
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/py-fonttools
PORTDOCS= *
diff --git a/print/py-pdf/Makefile b/print/py-pdf/Makefile
index edf04b831464..b631830b1cfe 100644
--- a/print/py-pdf/Makefile
+++ b/print/py-pdf/Makefile
@@ -12,9 +12,7 @@ DISTNAME= pyPdf-${PORTVERSION}
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Pure-Python PDF toolkit
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= pyPdf
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/print/py-pollyreports/Makefile b/print/py-pollyreports/Makefile
index 00a7ce5a5e05..3cae0676efb2 100644
--- a/print/py-pollyreports/Makefile
+++ b/print/py-pollyreports/Makefile
@@ -12,9 +12,8 @@ COMMENT= Band-oriented PDF report generation from database query
LICENSE= BSD2CLAUSE
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}/options
OPTIONS_DEFINE= REPORTLAB
diff --git a/print/py-preppy/Makefile b/print/py-preppy/Makefile
index 9310d5d90caf..74f9a9dd2c7a 100644
--- a/print/py-preppy/Makefile
+++ b/print/py-preppy/Makefile
@@ -12,8 +12,7 @@ COMMENT= ReportLab's templating system
LICENSE= BSD3CLAUSE
-USE_PYTHON= 2.7-3.3
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2.7-3.3
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/print/py-pyscript/Makefile b/print/py-pyscript/Makefile
index 217bcfd820c1..4ba941c5b3e6 100644
--- a/print/py-pyscript/Makefile
+++ b/print/py-pyscript/Makefile
@@ -17,8 +17,8 @@ OPTIONS_DEFINE= DOCS EXAMPLES
PYSCRIPT_MANUAL=doc/manual/pyscript.pdf
-USE_PYDISTUTILS=yes
-USE_PYTHON= yes
+USES= python
+USE_PYTHON= distutils
USE_TEX= latex dvipsk
.include <bsd.port.options.mk>
diff --git a/print/py-relatorio/Makefile b/print/py-relatorio/Makefile
index 3ed8bd12c2ca..cb85d57246a7 100644
--- a/print/py-relatorio/Makefile
+++ b/print/py-relatorio/Makefile
@@ -16,8 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.5:${PORTSDIR}/textproc/py-genshi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycha>=0.5.0:${PORTSDIR}/graphics/py-pycha \
${PYTHON_PKGNAMEPREFIX}yaml>=3.07:${PORTSDIR}/devel/py-yaml
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index 45eb3ee69908..cfaa97c4239e 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -19,9 +19,8 @@ LICENSE= BSD
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
CONFLICTS= py*-reportlab[^3]-[^3].* \
py*-reportlab-[^3].*
diff --git a/print/py-reportlab1/Makefile b/print/py-reportlab1/Makefile
index 94840d99cb4f..66cab959e0c6 100644
--- a/print/py-reportlab1/Makefile
+++ b/print/py-reportlab1/Makefile
@@ -22,10 +22,8 @@ CONFLICTS= py*-reportlab[^1]-[^1].* \
PORTSCOUT= ignore:1 # Last version of 1.X branch
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-PYDISTUTILS_PKGNAME= Reportlab
+USES= python
+USE_PYTHON= distutils autoplist
WRKSRC= ${WRKDIR}/reportlab_${PORTVERSION:S/./_/g}/reportlab
MAKE_ENV= PACKAGE_PATH="${REPORTLABDIR}"
diff --git a/print/py-rtf/Makefile b/print/py-rtf/Makefile
index 4c493a114358..542c8df2c96d 100644
--- a/print/py-rtf/Makefile
+++ b/print/py-rtf/Makefile
@@ -11,9 +11,8 @@ DISTNAME= PyRTF-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to create RTF documents using the Python language
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
EXAMPLESDIR= ${PREFIX}/share/examples/py-rtf
PORTEXAMPLES= *
diff --git a/print/ttfquery/Makefile b/print/ttfquery/Makefile
index 2470802b6b0e..12d3a2d06dcc 100644
--- a/print/ttfquery/Makefile
+++ b/print/ttfquery/Makefile
@@ -17,8 +17,7 @@ LICENSE_FILE= ${WRKSRC}/license.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fonttools>0:${PORTSDIR}/print/py-fonttools \
${PYNUMPY}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>