aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-06-23 09:43:22 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-06-23 09:43:22 +0000
commitd4667e0972e85d003d3569836517f98e51d4af39 (patch)
tree463a00412daca80e74c14970acba81d5a3b12710
parent135c74a4f51dc4df42474c050a656c6e5d5b281f (diff)
downloadports-d4667e0972e85d003d3569836517f98e51d4af39.tar.gz
ports-d4667e0972e85d003d3569836517f98e51d4af39.zip
Notes
-rw-r--r--devel/api-sanity-autotest/Makefile28
-rw-r--r--devel/api-sanity-autotest/distinfo4
2 files changed, 19 insertions, 13 deletions
diff --git a/devel/api-sanity-autotest/Makefile b/devel/api-sanity-autotest/Makefile
index 3b54936e5819..4a1d5ca4fd19 100644
--- a/devel/api-sanity-autotest/Makefile
+++ b/devel/api-sanity-autotest/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= api-sanity-autotest
-PORTVERSION= 1.12.4
+PORTVERSION= 1.12.5
CATEGORIES= devel perl5
MASTER_SITES= http://linuxtesting.org/downloads/ \
LOCAL/bf
@@ -18,12 +18,15 @@ LICENSE= LGPL20 GPLv2
LICENSE_COMB= dual
NO_BUILD= yes
+.ifdef(MAINTAINER_MODE)
+USE_PERL5= yes
+.else
USE_PERL5_RUN= yes
+.endif
PLIST_FILES= bin/${PORTNAME}.pl
-CPPFILT?= c++filt
-READELF?= readelf
+READELF?= /usr/bin/readelf
.include <bsd.port.pre.mk>
@@ -35,20 +38,23 @@ PICFLAG?= -fpic
post-patch:
@${REINPLACE_CMD} \
- -e "\|ArCmd =|s|=.*|= \"${AR}\";|" \
- -e "\|CPP_FILT =|s|=.*|= \"${CPPFILT}\";|" \
- -e "\|GCC_PATH =|s|=.*|= \"${CC}\";|" \
- -e "\|GPP_PATH =|s|=.*|= \"${CXX}\";|" \
- -e "\|ObjdumpCmd =|s|=.*|= \"${OBJDUMP}\";|" \
- -e "\|ReadelfCmd =|s|=.*|= \"${READELF}\";|" \
- -e "s|-shared|& ${PICFLAG}|g" \
+ -e "\|get_CmdPath(\"ar\")|s|\"ar\"|\"${AR}\"|" \
+ -e "\|get_CmdPath(\"gcc\")|s|\"gcc\"|\"${CC}\"|" \
+ -e "\|get_CmdPath(\"g++\")|s|\"g++\"|\"${CXX}\"|" \
+ -e "\|get_CmdPath(\"objdump\")|s|\"objdump\"|\"${OBJDUMP}\"|" \
+ -e "\|get_CmdPath(\"pidof\")|s|\"pidof\"|\"pgrep\"|" \
+ -e "\|get_CmdPath(\"readelf\")|s|\"readelf\"|\"${READELF}\"|" \
+ -e "s| -shared|& ${PICFLAG}|g" \
${WRKSRC}/${PORTNAME}.pl
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin
+.ifdef(MAINTAINER_MODE)
check regression-test test: build
- @(cd ${WRKSRC} && ./${PORTNAME}.pl -test )
+ @(cd ${WRKSRC}; ${PERL} ./${PORTNAME}.pl -test )
+
+.endif
.ifndef(NOPORTDOCS)
PORTDOCS= Changes.html Descriptor.html Options.html Readme.html SpecType.html
diff --git a/devel/api-sanity-autotest/distinfo b/devel/api-sanity-autotest/distinfo
index dcfde11c42ad..2d37123f1d79 100644
--- a/devel/api-sanity-autotest/distinfo
+++ b/devel/api-sanity-autotest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (api-sanity-autotest-1.12.4.tar.gz) = a9c77e604be43de63cbe578a57edcca417ce662f28238af5b94453a484a3e530
-SIZE (api-sanity-autotest-1.12.4.tar.gz) = 162740
+SHA256 (api-sanity-autotest-1.12.5.tar.gz) = 5ded86ca1b71502a939124f43459583617ad7fc251713a507b824b981cbc4ab9
+SIZE (api-sanity-autotest-1.12.5.tar.gz) = 163596