aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-09-29 17:53:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-09-29 17:53:34 +0000
commitd52e796890f0d50e6403a9539d17fdcfb01ae253 (patch)
tree9d66157a1041a7e385ab592c9430f0812e1d9e0a
parent41819375386feab85ebd24f3f6f2c9b44932a298 (diff)
downloadports-d52e796890f0d50e6403a9539d17fdcfb01ae253.tar.gz
ports-d52e796890f0d50e6403a9539d17fdcfb01ae253.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-listen/Makefile22
-rw-r--r--devel/rubygem-listen/distinfo2
-rw-r--r--devel/rubygem-listen/pkg-descr15
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0a25c47a5408..5f053da8bdc7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3839,6 +3839,7 @@
SUBDIR += rubygem-kgio
SUBDIR += rubygem-launchy
SUBDIR += rubygem-linecache
+ SUBDIR += rubygem-listen
SUBDIR += rubygem-little_plugger
SUBDIR += rubygem-locale
SUBDIR += rubygem-lockfile
diff --git a/devel/rubygem-listen/Makefile b/devel/rubygem-listen/Makefile
new file mode 100644
index 000000000000..2613c64c44a5
--- /dev/null
+++ b/devel/rubygem-listen/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: rubygem-listen
+# Date created: 2012-06-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= listen
+PORTVERSION= 0.5.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Listen to file modifications and notify about the changes
+
+RUN_DEPENDS= rubygem-rb-inotify>=0.8.8:${PORTSDIR}/devel/rubygem-rb-inotify
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-listen/distinfo b/devel/rubygem-listen/distinfo
new file mode 100644
index 000000000000..e6b043366c02
--- /dev/null
+++ b/devel/rubygem-listen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/listen-0.5.2.gem) = 2fa1d2072b8e842dce388ca2b83b19ec01a708f3534fc6bbc4f7bc79a0cf076e
+SIZE (rubygem/listen-0.5.2.gem) = 19456
diff --git a/devel/rubygem-listen/pkg-descr b/devel/rubygem-listen/pkg-descr
new file mode 100644
index 000000000000..ef651a5fd9b6
--- /dev/null
+++ b/devel/rubygem-listen/pkg-descr
@@ -0,0 +1,15 @@
+The Listen gem listens to file modifications and notifies you about the changes.
+
+Features:
+- Works everywhere!
+- Supports watching multiple directories from a single listener.
+- OS-specific adapters for Mac OS X 10.6+, Linux and Windows.
+- Automatic fallback to polling if OS-specific adapter doesn't work.
+- Detects files modification, addidation and removal.
+- Checksum comparaison for modifications made under the same second.
+- Allows supplying regexp-patterns to ignore and filter paths for better
+ results.
+- Tested on all Ruby environments via travis-ci.
+
+WWW: https://github.com/guard/listen
+RG: https://rubygems.org/gems/listen