aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-11-17 02:31:57 +0000
committerSteve Wills <swills@FreeBSD.org>2020-11-17 02:31:57 +0000
commitdea575c5336dfa178d1f177d1c069d498d35598d (patch)
treeda75574f77ef028894a392d2ad93e748da8197c2
parentfc3cf49733ecf62144fbe6eae3269d6f5ebdb12f (diff)
downloadports-dea575c5336dfa178d1f177d1c069d498d35598d.tar.gz
ports-dea575c5336dfa178d1f177d1c069d498d35598d.zip
MFH: r555535
net-im/chatterino2: fix crash on startup Obtained from: https://github.com/Chatterino/chatterino2/pull/2192 Approved by: ports-secteam (implicit)
Notes
Notes: svn path=/branches/2020Q4/; revision=555536
-rw-r--r--net-im/chatterino2/Makefile3
-rw-r--r--net-im/chatterino2/files/patch-src_providers_ffz_FfzEmotes.cpp11
2 files changed, 13 insertions, 1 deletions
diff --git a/net-im/chatterino2/Makefile b/net-im/chatterino2/Makefile
index d293c1903905..25dd616049b5 100644
--- a/net-im/chatterino2/Makefile
+++ b/net-im/chatterino2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= chatterino2
PORTVERSION= g2020090101
+PORTREVISION= 1
CATEGORIES= net-im
MAINTAINER= swills@FreeBSD.org
@@ -46,7 +47,7 @@ QMAKE_ARGS= INCLUDEPATH+=${LOCALBASE}/include/qt5keychain \
PORTDOCS= README.md docs/Commands.md docs/ENV.md docs/IMAGEUPLOADER.md \
docs/README.md docs/Regex.md
-PORTSCOUT= skipv:v2.1.7,v2.1.0,v2.0.4,v2.0.3,v2.0.2,v2.0.1,v2.0.0
+PORTSCOUT= skipv:v2.2.2,v2.2.1,v2.2.0,v2.1.7,v2.1.6,v2.1.5,v2.1.4,v2.1.3,v2.1.2,v2.1.0,v2.0.4,v2.0.3,v2.0.2,v2.0.1,v2.0.0
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/docs
diff --git a/net-im/chatterino2/files/patch-src_providers_ffz_FfzEmotes.cpp b/net-im/chatterino2/files/patch-src_providers_ffz_FfzEmotes.cpp
new file mode 100644
index 000000000000..b3d2aa41e761
--- /dev/null
+++ b/net-im/chatterino2/files/patch-src_providers_ffz_FfzEmotes.cpp
@@ -0,0 +1,11 @@
+--- src/providers/ffz/FfzEmotes.cpp.orig 2020-11-16 21:05:47 UTC
++++ src/providers/ffz/FfzEmotes.cpp
+@@ -14,7 +14,7 @@ namespace {
+ Url getEmoteLink(const QJsonObject &urls, const QString &emoteScale)
+ {
+ auto emote = urls.value(emoteScale);
+- if (emote.isUndefined())
++ if (emote.isUndefined() || emote.type() == QJsonValue::Null)
+ {
+ return {""};
+ }