aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-22 06:55:47 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-22 06:55:47 +0000
commite017458a99ce3898ea54130a9e62b0323c9d0163 (patch)
tree8b3aff1c53bcee2ade91a66252a4df002ddd2a5f
parentbb939b0cacd316764e66a6fb7e331fb2f353dd97 (diff)
downloadports-e017458a99ce3898ea54130a9e62b0323c9d0163.tar.gz
ports-e017458a99ce3898ea54130a9e62b0323c9d0163.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/cocoon/Makefile131
-rw-r--r--textproc/cocoon/Makefile.options56
-rw-r--r--textproc/cocoon/Makefile.test-options250
-rw-r--r--textproc/cocoon/distinfo2
-rw-r--r--textproc/cocoon/files/cocoon.sh31
-rw-r--r--textproc/cocoon/files/cocoonctl48
-rw-r--r--textproc/cocoon/files/patch-cocoon.sh41
-rw-r--r--textproc/cocoon/files/pkg-deinstall61
-rw-r--r--textproc/cocoon/files/pkg-install55
-rw-r--r--textproc/cocoon/pkg-descr15
-rw-r--r--textproc/cocoon/pkg-message12
-rw-r--r--textproc/cocoon/pkg-plist135
-rw-r--r--www/Makefile1
-rw-r--r--www/cocoon/Makefile2
16 files changed, 3 insertions, 839 deletions
diff --git a/MOVED b/MOVED
index 7c657dee2ba3..98abe1450412 100644
--- a/MOVED
+++ b/MOVED
@@ -1199,3 +1199,4 @@ lang/php4-nms|lang/php4|2004-07-19|Useless with the new PHP modular infrastructu
www/mod_php4-twig|www/mod_php4|2004-07-19|Useless with the new PHP modular infrastructure
databases/php4-sybase|databases/php4-sybase_ct|2004-07-21|Switch to use the new working library
databases/php5-sybase|databases/php5-sybase_ct|2004-07-21|Switch to use the new working library
+textproc/cocoon|www/cocoon|2004-07-22|Moved to better category www
diff --git a/textproc/Makefile b/textproc/Makefile
index be5859e488cb..ddf87cae848d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -39,7 +39,6 @@
SUBDIR += cl-ppcre-cmucl
SUBDIR += cl-ppcre-sbcl
SUBDIR += coco
- SUBDIR += cocoon
SUBDIR += code2html
SUBDIR += cole
SUBDIR += cost
diff --git a/textproc/cocoon/Makefile b/textproc/cocoon/Makefile
deleted file mode 100644
index b4bfc5bc1683..000000000000
--- a/textproc/cocoon/Makefile
+++ /dev/null
@@ -1,131 +0,0 @@
-# New ports collection makefile for: Cocoon
-# Date created: 27 June 1999
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= cocoon
-PORTVERSION= 2.1.5.1
-CATEGORIES= textproc www java
-MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%,${PORTNAME},}
-DISTNAME= ${PDISTNAME}-src
-
-MAINTAINER= jb.quenot@caraldi.com
-COMMENT= XML Web Development Framework
-
-USE_JAVA= yes
-JAVA_VERSION= 1.3+
-USE_PYTHON= 1.6+
-MAKE_ENV= JAVA_HOME=${JAVA_HOME}
-WRKSRC= ${WRKDIR}/${PDISTNAME}
-APP_VERSION= ${PORTVERSION:C/\..*$//}
-APP_NAME?= ${PORTNAME}
-APP_HOME?= ${PREFIX}/${APP_NAME}
-LATEST_LINK= ${APP_NAME}
-PLIST= ${WRKDIR}/pkg-plist
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PDISTNAME= ${PORTNAME}-${PORTVERSION}
-PKGINSTALL= ${WRKDIR}/pkg-install
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-
-COCOON_LIB= ${JAVASHAREDIR}/${APP_NAME}
-PLIST_SUB+= "COCOON_LIB=${COCOON_LIB}"
-
-COPYDIRS= *.txt tools/jetty tools/loader legal
-
-PORT?= 8888
-PID_FILE?= /var/run/${APP_NAME}.pid
-RUNASUSER?= www
-RUNASUID?= 80
-GROUP?= www
-GID?= 80
-LOGFILE?= /var/log/${APP_NAME}.log
-
-SUBSTITUTIONS= \
- -e "s|%%APP_HOME%%|${APP_HOME}|g" \
- -e "s|%%APP_NAME%%|${APP_NAME}|g" \
- -e "s|%%PREFIX%%|${PREFIX}|g" \
- -e "s|%%PORT%%|${PORT}|g" \
- -e "s|%%COCOON_LIB%%|${COCOON_LIB}|g" \
- -e "s|%%JAVA_HOME%%|${JAVA_HOME}|g" \
- -e "s|%%PID_FILE%%|${PID_FILE}|g" \
- -e "s|%%RUNASUSER%%|${RUNASUSER}|g" \
- -e "s|%%RUNASUID%%|${RUNASUID}|g" \
- -e "s|%%GROUP%%|${GROUP}|g" \
- -e "s|%%GID%%|${GID}|g" \
- -e "s|%%LOGFILE%%|${LOGFILE}|g" \
- -e "s|%%PYTHON_CMD%%|${PYTHON_CMD}|g"
-
-# Load options (before including bsd.port.pre.mk)
-.include "${.CURDIR}/Makefile.options"
-
-.include <bsd.port.pre.mk>
-
-# Test for options
-.include "${MASTERDIR}/Makefile.test-options"
-
-.for BLOCK in ${BLOCKS}
-BLOCKSEXP+= -e 's/^include.block.${BLOCK}/\#include.block.${BLOCK}/'
-.endfor
-
-post-patch:
- @${ECHO_MSG} "===> Configuring blocks: ${BLOCKS}"
- ${SED} -e 's/^#include.block/include.block/' < ${WRKSRC}/blocks.properties | \
- ${SED} ${BLOCKSEXP} > ${WRKSRC}/local.blocks.properties
-.if (! defined(WITH_DOCS))
- ${SED} -e 's/^#exclude/exclude/' < ${WRKSRC}/build.properties \
- > ${WRKSRC}/local.build.properties
-.endif
-
-pre-build:
- ${CHMOD} a+rx ${WRKSRC}/build.sh
-
-do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./build.sh
-
-post-build:
- @${ECHO_MSG} "===> Building packing list"
- @> ${PLIST}
-
- @cd ${WRKSRC}/build && ${FIND} webapp -type f \
- | ${SED} -e "s|^|${APP_NAME}/|" >> ${PLIST}
-
- @cd ${WRKSRC}/build && ${FIND} -d webapp -type d \
- | ${SED} -e "s|^|@dirrm ${APP_NAME}/|" >> ${PLIST}
-
- @${CAT} ${MASTERDIR}/pkg-plist >> ${PLIST}
-
- @${SED} ${SUBSTITUTIONS} ${FILESDIR}/pkg-install > ${PKGINSTALL}
- @${SED} ${SUBSTITUTIONS} ${FILESDIR}/pkg-deinstall > ${PKGDEINSTALL}
-
-do-install:
- @${ECHO_MSG} "===> Installing ${COPYDIRS}"
- @${MKDIR} ${APP_HOME}
- @cd ${WRKSRC} && ${FIND} ${COPYDIRS} \
- | ${XARGS} ${TAR} -C ${WRKSRC} -cf- | ${TAR} -C ${APP_HOME} -xpf-
-
- @${ECHO_MSG} "===> Installing webapp"
- @cd ${WRKSRC}/build && ${FIND} webapp \
- | ${XARGS} ${TAR} -C ${WRKSRC}/build -cf- | ${TAR} -C ${APP_HOME} -xpf-
-
- @${ECHO_MSG} "===> Installing into ${PREFIX}/sbin"
- @${SED} ${SUBSTITUTIONS} ${WRKSRC}/cocoon.sh > ${WRKDIR}/${APP_NAME}.sh
- @${INSTALL} ${WRKDIR}/${APP_NAME}.sh ${PREFIX}/sbin
- @${SED} ${SUBSTITUTIONS} ${FILESDIR}/${APP_NAME}ctl > ${WRKDIR}/${APP_NAME}ctl
- @${INSTALL} ${WRKDIR}/${APP_NAME}ctl ${PREFIX}/sbin
-
- @${ECHO_MSG} "===> Installing ${PREFIX}/etc/rc.d/${APP_NAME}.sh"
- @${SED} ${SUBSTITUTIONS} ${FILESDIR}/${APP_NAME}.sh > ${WRKDIR}/${APP_NAME}.sh
- @${INSTALL} ${WRKDIR}/${APP_NAME}.sh ${PREFIX}/etc/rc.d
-
-post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${SED} ${SUBSTITUTIONS} ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
- @${ECHO_CMD}
- @${ECHO_CMD} "********************************************************************************"
- @${CAT} ${PKGMESSAGE} | fmt -w 80
- @${ECHO_CMD} "********************************************************************************"
- @${ECHO_CMD}
-
-.include <bsd.port.post.mk>
diff --git a/textproc/cocoon/Makefile.options b/textproc/cocoon/Makefile.options
deleted file mode 100644
index 1b84a4effba1..000000000000
--- a/textproc/cocoon/Makefile.options
+++ /dev/null
@@ -1,56 +0,0 @@
-# ex:ts=22
-#
-OPTIONS+= DOCS 'Include the documentation and samples' off
-
-OPTIONS+= AUTHENTICATION_FW 'Enable the authentication-fw block' off
-OPTIONS+= BATIK 'Enable the Batik block' off
-OPTIONS+= BSF 'Enable the bsf block' off
-OPTIONS+= CHAPERON 'Enable the chaperon block' off
-OPTIONS+= DATABASES 'Enable the databases block' off
-OPTIONS+= FOP 'Enable the FOP Block (implies BATIK)' off
-OPTIONS+= HSQLDB 'Enable the hsqldb block' off
-OPTIONS+= HTML 'Enable the html block' off
-OPTIONS+= ITEXT 'Enable the itext block' off
-OPTIONS+= JFOR 'Enable the JFOR Block' off
-OPTIONS+= JSP 'Enable the jsp block' off
-OPTIONS+= LINKREWRITER 'Enable the linkrewriter block' off
-OPTIONS+= LUCENE 'Enable the lucene block' off
-OPTIONS+= NAMING 'Enable the naming block' off
-OPTIONS+= PARANOID 'Enable the Paranoid Cocoon Servlet' off
-OPTIONS+= PHP 'Enable the php block' off
-OPTIONS+= POI 'Enable the poi block' off
-OPTIONS+= PORTAL_FW 'Enable the portal-fw block' off
-OPTIONS+= PROFILER 'Enable the profiler block' off
-OPTIONS+= PYTHON 'Enable the python block' off
-OPTIONS+= SESSION_FW 'Enable the session-fw block' off
-OPTIONS+= SWF 'Enable the swf block' off
-OPTIONS+= VELOCITY 'Enable the velocity block' off
-OPTIONS+= WEB3 'Enable the web3 block' off
-OPTIONS+= XMLDB 'Enable the xmldb block' off
-OPTIONS+= XSP 'Enable the xsp block' off
-OPTIONS+= APPLES 'Enable the apples block' off
-OPTIONS+= ASCIIART 'Enable the asciiart block' off
-OPTIONS+= AXIS 'Enable the axis block' off
-OPTIONS+= CRON 'Enable the cron block' off
-OPTIONS+= DELI 'Enable the deli block' off
-OPTIONS+= EVENTCACHE 'Enable the eventcache block' off
-OPTIONS+= FORMS 'Enable the forms block' off
-OPTIONS+= JAVAFLOW 'Enable the javaflow block' off
-OPTIONS+= JMS 'Enable the jms block' off
-OPTIONS+= LINOTYPE 'Enable the linotype block' off
-OPTIONS+= MAIL 'Enable the mail block' off
-OPTIONS+= MIDI 'Enable the midi block' off
-OPTIONS+= OJB 'Enable the ojb block' off
-OPTIONS+= PETSTORE 'Enable the petstore block' off
-OPTIONS+= PORTAL 'Enable the portal block' off
-OPTIONS+= PROXY 'Enable the proxy block' off
-OPTIONS+= QDOX 'Enable the qdox block' off
-OPTIONS+= REPOSITORY 'Enable the repository block' off
-OPTIONS+= SCRATCHPAD 'Enable the scratchpad block' off
-OPTIONS+= SERIALIZERS 'Enable the serializers block' off
-OPTIONS+= SLIDE 'Enable the slide block' off
-OPTIONS+= SLOP 'Enable the slop block' off
-OPTIONS+= STX 'Enable the stx block' off
-OPTIONS+= TAGLIB 'Enable the taglib block' off
-OPTIONS+= TOUR 'Enable the tour block' off
-OPTIONS+= WEBDAV 'Enable the webdav block' off
diff --git a/textproc/cocoon/Makefile.test-options b/textproc/cocoon/Makefile.test-options
deleted file mode 100644
index 0df6408d0f16..000000000000
--- a/textproc/cocoon/Makefile.test-options
+++ /dev/null
@@ -1,250 +0,0 @@
-.if defined(WITH_AUTHENTICATION_FW)
-BLOCKS+= authentication-fw
-BLOCKS+= session-fw
-.endif
-
-.if defined(WITH_BATIK)
-BLOCKS+= batik
-.endif
-
-.if defined(WITH_BSF)
-BLOCKS+= bsf
-.endif
-
-.if defined(WITH_CHAPERON)
-BLOCKS+= chaperon
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_DATABASES)
-BLOCKS+= databases
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_FOP)
-BLOCKS+= fop
-BLOCKS+= batik
-.endif
-
-.if defined(WITH_HSQLDB)
-BLOCKS+= hsqldb
-BLOCKS+= databases
-.endif
-
-.if defined(WITH_HTML)
-BLOCKS+= html
-.endif
-
-.if defined(WITH_ITEXT)
-BLOCKS+= itext
-.endif
-
-.if defined(WITH_JFOR)
-BLOCKS+= jfor
-.endif
-
-.if defined(WITH_JSP)
-BLOCKS+= jsp
-.endif
-
-.if defined(WITH_LINKREWRITER)
-BLOCKS+= linkrewriter
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_LUCENE)
-BLOCKS+= lucene
-.endif
-
-.if defined(WITH_NAMING)
-BLOCKS+= naming
-.endif
-
-.if defined(WITH_PARANOID)
-BLOCKS+= paranoid
-.endif
-
-.if defined(WITH_PHP)
-BLOCKS+= php
-.endif
-
-.if defined(WITH_POI)
-BLOCKS+= poi
-.endif
-
-.if defined(WITH_PORTAL_FW)
-BLOCKS+= portal-fw
-BLOCKS+= authentication-fw
-BLOCKS+= session-fw
-.endif
-
-.if defined(WITH_PROFILER)
-BLOCKS+= profiler
-.endif
-
-.if defined(WITH_PYTHON)
-BLOCKS+= python
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_SESSION_FW)
-BLOCKS+= session-fw
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_SWF)
-BLOCKS+= swf
-.endif
-
-.if defined(WITH_VELOCITY)
-BLOCKS+= velocity
-.endif
-
-.if defined(WITH_WEB3)
-BLOCKS+= web3
-.endif
-
-.if defined(WITH_XMLDB)
-BLOCKS+= xmldb
-BLOCKS+= databases
-.endif
-
-.if defined(WITH_XSP)
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_APPLES)
-BLOCKS+= apples
-BLOCKS+= forms
-.endif
-
-.if defined(WITH_ASCIIART)
-BLOCKS+= asciiart
-.endif
-
-.if defined(WITH_AXIS)
-BLOCKS+= axis
-.endif
-
-.if defined(WITH_CRON)
-BLOCKS+= cron
-.endif
-
-.if defined(WITH_DELI)
-BLOCKS+= deli
-.endif
-
-.if defined(WITH_EVENTCACHE)
-BLOCKS+= eventcache
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_FORMS)
-BLOCKS+= forms
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_JAVAFLOW)
-BLOCKS+= javaflow
-BLOCKS+= forms
-BLOCKS+= ojb
-.endif
-
-.if defined(WITH_JMS)
-BLOCKS+= jms
-BLOCKS+= databases
-BLOCKS+= eventcache
-BLOCKS+= hsqldb
-.endif
-
-.if defined(WITH_LINOTYPE)
-BLOCKS+= linotype
-.endif
-
-.if defined(WITH_MAIL)
-BLOCKS+= mail
-BLOCKS+= asciiart
-BLOCKS+= scratchpad
-.endif
-
-.if defined(WITH_MIDI)
-BLOCKS+= midi
-.endif
-
-.if defined(WITH_OJB)
-BLOCKS+= ojb
-BLOCKS+= databases
-BLOCKS+= forms
-.endif
-
-.if defined(WITH_PETSTORE)
-BLOCKS+= petstore
-BLOCKS+= databases
-BLOCKS+= forms
-BLOCKS+= hsqldb
-BLOCKS+= velocity
-.endif
-
-.if defined(WITH_PORTAL)
-BLOCKS+= portal
-BLOCKS+= authentication-fw
-BLOCKS+= html
-BLOCKS+= session-fw
-.endif
-
-.if defined(WITH_PROXY)
-BLOCKS+= proxy
-.endif
-
-.if defined(WITH_QDOX)
-BLOCKS+= qdox
-.endif
-
-.if defined(WITH_REPOSITORY)
-BLOCKS+= repository
-BLOCKS+= databases
-BLOCKS+= eventcache
-.endif
-
-.if defined(WITH_SCRATCHPAD)
-BLOCKS+= scratchpad
-BLOCKS+= batik
-BLOCKS+= cron
-BLOCKS+= velocity
-BLOCKS+= xsp
-.endif
-
-.if defined(WITH_SERIALIZERS)
-BLOCKS+= serializers
-.endif
-
-.if defined(WITH_SLIDE)
-BLOCKS+= slide
-BLOCKS+= jms
-BLOCKS+= repository
-.endif
-
-.if defined(WITH_SLOP)
-BLOCKS+= slop
-.endif
-
-.if defined(WITH_STX)
-BLOCKS+= stx
-.endif
-
-.if defined(WITH_TAGLIB)
-BLOCKS+= taglib
-.endif
-
-.if defined(WITH_TOUR)
-BLOCKS+= tour
-BLOCKS+= batik
-BLOCKS+= fop
-BLOCKS+= forms
-.endif
-
-.if defined(WITH_WEBDAV)
-BLOCKS+= webdav
-BLOCKS+= repository
-.endif
-
diff --git a/textproc/cocoon/distinfo b/textproc/cocoon/distinfo
deleted file mode 100644
index 172962b9fc8a..000000000000
--- a/textproc/cocoon/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (cocoon-2.1.5.1-src.tar.gz) = 0f6e58bd430db7cf6d98b1ccac2dcc99
-SIZE (cocoon-2.1.5.1-src.tar.gz) = 42035921
diff --git a/textproc/cocoon/files/cocoon.sh b/textproc/cocoon/files/cocoon.sh
deleted file mode 100644
index 8ca8b5719622..000000000000
--- a/textproc/cocoon/files/cocoon.sh
+++ /dev/null
@@ -1,31 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: %%APP_NAME%%
-
-#
-# Add the following line to /etc/rc.conf to enable %%APP_NAME%%:
-#
-# %%APP_NAME%%_enable="YES"
-#
-
-. /etc/rc.subr
-
-name=%%APP_NAME%%
-rcvar=`set_rcvar`
-
-command=%%PREFIX%%/sbin/%%APP_NAME%%ctl
-command_args="$1"
-pidfile=%%PID_FILE%%
-procname=java
-
-# set defaults
-
-%%APP_NAME%%_enable=${%%APP_NAME%%_enable:-"NO"}
-%%APP_NAME%%_user=${%%APP_NAME%%_user:-"www"}
-%%APP_NAME%%_group=${%%APP_NAME%%_group:-"www"}
-
-load_rc_config ${name}
-run_rc_command "$1"
diff --git a/textproc/cocoon/files/cocoonctl b/textproc/cocoon/files/cocoonctl
deleted file mode 100644
index fa62902ead55..000000000000
--- a/textproc/cocoon/files/cocoonctl
+++ /dev/null
@@ -1,48 +0,0 @@
-#! %%PYTHON_CMD%%
-
-################################################################################
-# Author: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
-# Purpose: Control cocoon process
-# Date Created: 2004-05-04 11:14:05
-# Revision: $FreeBSD$
-################################################################################
-
-import sys, os, signal, time
-
-LOGFILE = "%%LOGFILE%%"
-PREFIX = "%%PREFIX%%"
-APP_NAME = "%%APP_NAME%%"
-PID_FILE = "%%PID_FILE%%"
-
-if __name__ == '__main__':
- if sys.argv[1] == "start":
- # Append cocoon output to a log file
- l = open(LOGFILE, 'a')
- os.dup2(l.fileno(), sys.stdout.fileno())
- os.dup2(l.fileno(), sys.stderr.fileno())
-
- # Start cocoon in the background
- command = PREFIX + "/sbin/" + APP_NAME + ".sh"
- pid = os.spawnl(os.P_NOWAIT, command, command, "servlet")
-
- # Wait a little
- time.sleep(0.4)
-
- # Send a dummy signal to the process. If it died, an exception is
- # thrown
- os.kill(pid, signal.SIGCONT)
-
- # It's alive, so write down the process id
- f = open(PID_FILE, 'w')
- print >> f, pid
- f.close()
- elif sys.argv[1] == "stop":
- # Read the process id
- f = open(PID_FILE, 'r')
- pid = int(f.readline())
- f.close()
-
- # Terminate cocoon
- os.kill(pid, signal.SIGTERM)
- else:
- print "Usage: %s start|stop" % sys.argv[0]
diff --git a/textproc/cocoon/files/patch-cocoon.sh b/textproc/cocoon/files/patch-cocoon.sh
deleted file mode 100644
index 93a669d55bf3..000000000000
--- a/textproc/cocoon/files/patch-cocoon.sh
+++ /dev/null
@@ -1,41 +0,0 @@
-$FreeBSD$
-
---- cocoon.sh.orig Thu Feb 12 09:48:55 2004
-+++ cocoon.sh Tue May 4 14:44:24 2004
-@@ -57,8 +57,7 @@
- # ----- Verify and Set Required Environment Variables -------------------------
-
- if [ "$JAVA_HOME" = "" ] ; then
-- echo You must set JAVA_HOME to point at your Java Development Kit installation
-- exit 1
-+ JAVA_HOME="%%JAVA_HOME%%"
- fi
-
- if [ "$JAVA_OPTIONS" = "" ] ; then
-@@ -66,7 +65,7 @@
- fi
-
- if [ "$COCOON_HOME" = "" ] ; then
-- COCOON_HOME='.'
-+ COCOON_HOME="%%APP_HOME%%"
- fi
-
- if [ "$COCOON_WEBAPP_HOME" = "" ] ; then
-@@ -76,7 +75,7 @@
- COCOON_WEBAPP_HOME=$STANDALONE_WEBAPP
- else
- # when in the build environment
-- COCOON_WEBAPP_HOME="$COCOON_HOME/build/webapp"
-+ COCOON_WEBAPP_HOME="$COCOON_HOME/webapp"
- fi
- fi
- echo "$0: using $COCOON_WEBAPP_HOME as the webapp directory"
-@@ -111,7 +110,7 @@
-
- # ----- Set Local Variables ( used to minimize cut/paste) ---------------------
-
--JAVA="$JAVA_HOME/bin/java"
-+JAVA="exec $JAVA_HOME/bin/java"
- ENDORSED_LIBS="$COCOON_HOME/lib/endorsed"
- ENDORSED="-Djava.endorsed.dirs=$ENDORSED_LIBS"
- PARSER=-Dorg.xml.sax.parser=org.apache.xerces.parsers.SAXParser
diff --git a/textproc/cocoon/files/pkg-deinstall b/textproc/cocoon/files/pkg-deinstall
deleted file mode 100644
index 55134b973319..000000000000
--- a/textproc/cocoon/files/pkg-deinstall
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-#
-# This script does the following.
-#
-# * Checks if the PID file exists. If it does, it kills the
-# process and removes the PID file.
-#
-# * Checks if the 'www' user exists. If it does, then it displays
-# a message.
-#
-# $FreeBSD$
-#
-# Borrowed from the jakarta-tomcat port
-#
-
-set -e
-
-PID_FILE=%%PID_FILE%%
-RUNASUSER=%%RUNASUSER%%
-APP_NAME=%%APP_NAME%%
-LOGFILE=%%LOGFILE%%
-
-# Make sure we're in the right stage of the process
-if [ "$2" = "DEINSTALL" ]; then
-
- # Kill the process if it is still running
- if [ -s ${PID_FILE} ]; then
- PID=`cat ${PID_FILE}`
- echo -n ">> Killing ${APP_NAME} process (${PID})..."
-
- if /bin/kill ${PID} > /dev/null 2> /dev/null ; then
- echo " [ DONE ]"
- else
- echo " [ FAILED ]"
- fi
-
- echo -n ">> Removing PID file (${PID_FILE})..."
-
- if rm ${PID_FILE} > /dev/null 2> /dev/null ; then
- echo " [ DONE ]"
- else
- echo " [ FAILED ]"
- fi
- fi
-
- echo -n ">> Removing log file (${LOGFILE})..."
- if rm ${LOGFILE} > /dev/null 2> /dev/null ; then
- echo " [ DONE ]"
- else
- echo " [ FAILED ]"
- fi
-fi
-
-if [ "$2" = "POST-DEINSTALL" ]; then
- # If the user exists, then display a message
- if pw usershow "$RUNASUSER" 2>/dev/null 1>&2; then
- echo "To delete the $RUNASUSER user permanently, use 'pw userdel $RUNASUSER'"
- fi
-fi
-
-exit 0
diff --git a/textproc/cocoon/files/pkg-install b/textproc/cocoon/files/pkg-install
deleted file mode 100644
index 48ce6423e4fb..000000000000
--- a/textproc/cocoon/files/pkg-install
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/sh
-#
-# Checks if the requested user and group exist. If they don't, then
-# an attempt is made to create both.
-#
-# $FreeBSD$
-#
-# Borrowed from the jakarta-tomcat port
-#
-
-set -e
-
-RUNASUSER=%%RUNASUSER%%
-RUNASUID=%%RUNASUID%%
-GROUP=%%GROUP%%
-GID=%%GID%%
-APP_NAME=%%APP_NAME%%
-PID_FILE=%%PID_FILE%%
-LOGFILE=%%LOGFILE%%
-
-if [ "$2" = "POST-INSTALL" ]; then
- # We're called after the 'make install' process
- # See if the group already exists
- if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
-
- # If not, try to create it
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- # See if the user already exists
- if ! pw usershow "${RUNASUSER}" 2>/dev/null 1>&2; then
-
- # If not, try to create it
- if pw useradd ${RUNASUSER} -u ${RUNASUID} -g ${GROUP} -h - \
- -s "/sbin/nologin" -d "/nonexistent" \
- -c "World Wide Web Owner"; \
- then
- echo "Added user \"${RUNASUSER}\"."
- else
- echo "Adding user \"${RUNASUSER}\" failed..."
- exit 1
- fi
- fi
-
- chown -R ${RUNASUSER}:${GROUP} $PKG_PREFIX/${APP_NAME}
- touch ${LOGFILE} ${PID_FILE}
- chown ${RUNASUSER}:${GROUP} ${LOGFILE} ${PID_FILE}
-fi
-
-exit 0
diff --git a/textproc/cocoon/pkg-descr b/textproc/cocoon/pkg-descr
deleted file mode 100644
index 4e13d3db5fae..000000000000
--- a/textproc/cocoon/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-Apache Cocoon is a web development framework built around the
-concepts of separation of concerns and component-based web development.
-
-Cocoon implements these concepts around the notion of 'component
-pipelines', each component on the pipeline specializing on a
-particular operation. This makes it possible to use a Lego(tm)-like
-approach in building web solutions, hooking together components
-into pipelines without any required programming.
-
-Cocoon is "web glue for your web application development needs".
-It is a glue that keeps concerns separate and allows parallel
-evolution of all aspects of a web application, improving development
-pace and reducing the chance of conflicts.
-
-WWW: http://cocoon.apache.org/
diff --git a/textproc/cocoon/pkg-message b/textproc/cocoon/pkg-message
deleted file mode 100644
index cf783f8360ea..000000000000
--- a/textproc/cocoon/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-Cocoon is now installed in %%APP_HOME%%.
-
-In order to be able to run Cocoon, please add the following line to
-/etc/rc.conf:
-
-%%APP_NAME%%_enable="YES"
-
-If you wish to start cocoon right now, invoke the startup script with
-`%%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh start'
-and point your web browser to the default home page at
-http://localhost:%%PORT%%/ where you may read the documentation and test the
-samples.
diff --git a/textproc/cocoon/pkg-plist b/textproc/cocoon/pkg-plist
deleted file mode 100644
index e5f03d01d5a3..000000000000
--- a/textproc/cocoon/pkg-plist
+++ /dev/null
@@ -1,135 +0,0 @@
-cocoon/CREDITS.txt
-cocoon/INSTALL.txt
-cocoon/LICENSE.txt
-cocoon/NOTICE.txt
-cocoon/README.txt
-cocoon/legal/altrmi-client-impl-0.9.2.jar.license.txt
-cocoon/legal/altrmi-client-interfaces-0.9.2.jar.license.txt
-cocoon/legal/altrmi-common-0.9.2.jar.license.txt
-cocoon/legal/altrmi-registry-0.9.2.jar.license.txt
-cocoon/legal/altrmi-server-impl-0.9.2.jar.license.txt
-cocoon/legal/altrmi-server-interfacesl-0.9.2.jar.license.txt
-cocoon/legal/ant-contrib-0.6.jar.license.txt
-cocoon/legal/ant-junit.jar.license.txt
-cocoon/legal/ant-launcher.jar.license.txt
-cocoon/legal/ant-trax.jar.license.txt
-cocoon/legal/ant.jar.license.txt
-cocoon/legal/antlr-2.7.3.jar.license.txt
-cocoon/legal/asm-1.4.2.jar.license.txt
-cocoon/legal/avalon-framework-api-4.1.5.jar.license.txt
-cocoon/legal/avalon-framework-impl-4.1.5.jar.license.txt
-cocoon/legal/axis-1.1.jar.license.txt
-cocoon/legal/axis-jaxrpc-1.1.jar.license.txt
-cocoon/legal/axis-saaj-1.1.jar.license.txt
-cocoon/legal/batik-all-1.5.1.jar.license.txt
-cocoon/legal/bsf-2.3.0.jar.license.txt
-cocoon/legal/castor-0.9.5.3-xml.jar.license.txt
-cocoon/legal/chaperon-20040205.jar.license.txt
-cocoon/legal/commons-beanutils-1.6.1.jar.license.txt
-cocoon/legal/commons-betwixt-20030910.jar.license.txt
-cocoon/legal/commons-cli-1.0.jar.license.txt
-cocoon/legal/commons-collections-3.0.jar.license.txt
-cocoon/legal/commons-dbcp-1.1.jar.license.txt
-cocoon/legal/commons-digester-1.3.jar.license.txt
-cocoon/legal/commons-discovery-0.2.jar.license.txt
-cocoon/legal/commons-httpclient-2.0-final.jar.license.txt
-cocoon/legal/commons-jexl-1.0-beta-1-20040113.jar.license.txt
-cocoon/legal/commons-jxpath-20030909.jar.license.txt
-cocoon/legal/commons-lang-2.0.jar.license.txt
-cocoon/legal/commons-logging-1.0.3.jar.license.txt
-cocoon/legal/commons-pool-1.1.jar.license.txt
-cocoon/legal/db-ojb-1.0.rc6.jar.license.txt
-cocoon/legal/deli-0.9.8.jar.license.txt
-cocoon/legal/ehcache-0.8.jar.license.txt
-cocoon/legal/excalibur-component-1.2.jar.license.txt
-cocoon/legal/excalibur-datasource-1.1.1.jar.license.txt
-cocoon/legal/excalibur-event-api-1.1.jar.license.txt
-cocoon/legal/excalibur-event-impl-1.1.jar.license.txt
-cocoon/legal/excalibur-i18n-1.1.jar.license.txt
-cocoon/legal/excalibur-instrument-1.0.jar.license.txt
-cocoon/legal/excalibur-instrument-client-2003-03-31.jar.license.txt
-cocoon/legal/excalibur-instrument-manager-1.0.jar.license.txt
-cocoon/legal/excalibur-instrument-manager-interfaces-1.0.jar.license.txt
-cocoon/legal/excalibur-io-1.1.jar.license.txt
-cocoon/legal/excalibur-logger-1.1.jar.license.txt
-cocoon/legal/excalibur-monitor-1.0.2.jar.license.txt
-cocoon/legal/excalibur-naming-1.0.jar.license.txt
-cocoon/legal/excalibur-pool-1.2.jar.license.txt
-cocoon/legal/excalibur-sourceresolve-1.1.jar.license.txt
-cocoon/legal/excalibur-store-1.0.jar.license.txt
-cocoon/legal/excalibur-testcase-1.2.jar.license.txt
-cocoon/legal/excalibur-util-1.0.jar.license.txt
-cocoon/legal/excalibur-xmlutil-1.0.jar.license.txt
-cocoon/legal/fop-0.20.5.jar.license.txt
-cocoon/legal/geronimo-spec-jms-DEV-20031120.jar.license.txt
-cocoon/legal/geronimo-spec-jta-DEV-20040202.jar.license.txt
-cocoon/legal/groovy-20040415.114632.jar.license.txt
-cocoon/legal/hsqldb-1.7.1.jar.license.txt
-cocoon/legal/htmlarea.license.txt
-cocoon/legal/icu4j.jar.license.txt
-cocoon/legal/itext-1.02b.jar.license.txt
-cocoon/legal/itext-xml-1.02.jar.license.txt
-cocoon/legal/jakarta-bcel-20040329.jar.license.txt
-cocoon/legal/jakarta-oro-2.0.8.jar.license.txt
-cocoon/legal/jakarta-regexp-1.3.jar.license.txt
-cocoon/legal/jakarta-slide-webdavlib-2.0rc1.jar.license.txt
-cocoon/legal/jcs-1.0-dev.20040516.jar.license.txt
-cocoon/legal/jdom-b9.jar.license.txt
-cocoon/legal/jdtcore-2.1.3.jar.license.txt
-cocoon/legal/jena-2.0.0.jar.license.txt
-cocoon/legal/jetty-4.2.19.jar.license.html
-cocoon/legal/jfor-0.7.1.jar.license.txt
-cocoon/legal/jing-20030619.jar.license.txt
-cocoon/legal/jisp-2.5.1.jar.license.txt
-cocoon/legal/joost-20040330.jar.license.txt
-cocoon/legal/jstyle.jar.license.txt
-cocoon/legal/jtidy-04aug2000r7-dev.jar.license.txt
-cocoon/legal/junit.jar.license.txt
-cocoon/legal/log4j-1.2.8.jar.license.txt
-cocoon/legal/logkit-1.2.2.jar.license.txt
-cocoon/legal/lucene-1.3-final.jar.license.txt
-cocoon/legal/midi-license.txt
-cocoon/legal/pizza-1.1.jar.license.txt
-cocoon/legal/pluto-20040310.jar.license.txt
-cocoon/legal/poi-2.5-final-20040302.jar.license.txt
-cocoon/legal/portlet-api-20040310.jar.license.txt
-cocoon/legal/qdox-1.3.jar.license.txt
-cocoon/legal/quartz-1.3.2.jar.license.txt
-cocoon/legal/rhino1.5r4-continuations-20040228.jar.license.txt
-cocoon/legal/servlet-2.3.jar.license.txt
-cocoon/legal/servlet_2_2.jar.license.txt
-cocoon/legal/slide-kernel-2.0.jar.license.txt
-cocoon/legal/slide-stores-2.0.jar.license.txt
-cocoon/legal/slide-webdavservlet-2.0.jar.license.txt
-cocoon/legal/spark.fpl.license.txt
-cocoon/legal/spark.opl.license.txt
-cocoon/legal/util.concurrent-1.3.3.jar.license.txt
-cocoon/legal/velocity-1.4.jar.license.jtxt
-cocoon/legal/wsdl4j-1.4.jar.license.txt
-cocoon/legal/xalan-2.6.0.jar.license.txt
-cocoon/legal/xercesImpl-2.6.2.jar.license.txt
-cocoon/legal/xindice-1.1b4.jar.license.txt
-cocoon/legal/xml-apis.jar.license.txt
-cocoon/legal/xml-commons-resolver-1.1.jar.license.txt
-cocoon/legal/xmldb-api-20030701.jar.license.txt
-cocoon/legal/xmldb-common-20030701.jar.license.txt
-cocoon/legal/xmldb-xupdate-20040205.jar.license.txt
-cocoon/legal/xmlunit0.8.jar.license.txt
-cocoon/legal/xreporter-expression-20030725.jar.license.txt
-cocoon/tools/jetty/conf/admin.xml
-cocoon/tools/jetty/conf/main.xml
-cocoon/tools/jetty/conf/webdefaults.xml
-cocoon/tools/jetty/lib/jetty-4.2.19.jar
-cocoon/tools/jetty/lib/servlet-2.3.jar
-cocoon/tools/loader/Loader$RepositoryClassLoader.class
-cocoon/tools/loader/Loader.class
-@dirrm cocoon/legal
-@dirrm cocoon/tools/jetty/conf
-@dirrm cocoon/tools/jetty/lib
-@dirrm cocoon/tools/jetty
-@dirrm cocoon/tools/loader
-@dirrm cocoon/tools
-sbin/cocoon.sh
-sbin/cocoonctl
-etc/rc.d/cocoon.sh
-@dirrm cocoon
diff --git a/www/Makefile b/www/Makefile
index 140d495766a5..16e24265946e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -71,6 +71,7 @@
SUBDIR += cl-lml-sbcl
SUBDIR += clearsilver
SUBDIR += clearsilver-python
+ SUBDIR += cocoon
SUBDIR += comclear
SUBDIR += coppermine
SUBDIR += crawl
diff --git a/www/cocoon/Makefile b/www/cocoon/Makefile
index b4bfc5bc1683..473c1ed08c8d 100644
--- a/www/cocoon/Makefile
+++ b/www/cocoon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cocoon
PORTVERSION= 2.1.5.1
-CATEGORIES= textproc www java
+CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%,${PORTNAME},}
DISTNAME= ${PDISTNAME}-src