aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-02 10:59:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-02 10:59:22 +0000
commite11a8ad07415d5e98029026fc0b3514f27462986 (patch)
treed276e47b640ee0150bc8da2e1713e74b086a6006
parent12eaa77c7beb9a9382d2ef8c1d25f896eb9bc6af (diff)
downloadports-e11a8ad07415d5e98029026fc0b3514f27462986.tar.gz
ports-e11a8ad07415d5e98029026fc0b3514f27462986.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hg-git/Makefile29
-rw-r--r--devel/hg-git/distinfo3
-rw-r--r--devel/hg-git/pkg-descr14
-rw-r--r--devel/hg-git/pkg-message15
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 85f36cb38c50..9e1d96b01b0f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -500,6 +500,7 @@
SUBDIR += happydoc
SUBDIR += hapy
SUBDIR += hcs12mem
+ SUBDIR += hg-git
SUBDIR += hgsvn
SUBDIR += hgview
SUBDIR += highlighterkit
diff --git a/devel/hg-git/Makefile b/devel/hg-git/Makefile
new file mode 100644
index 000000000000..61c34605b613
--- /dev/null
+++ b/devel/hg-git/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: hg-git
+# Date created: 2009-10-24
+# Whom: Marco Broeder <marco.broeder@gmx.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hg-git
+PORTVERSION= 0.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= marco.broeder@gmx.eu
+COMMENT= Mercurial extension to pull from or push to a Git repository
+
+RUN_DEPENDS= ${PKGNAMEPREFIX}dulwich>=0.4.0:${PORTSDIR}/devel/dulwich \
+ hg:${PORTSDIR}/devel/mercurial
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+PLIST_SUB= VERSION=${PORTVERSION} PYVER=${PYTHON_VERSION:S/python//}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/hg_git-%%VERSION%%-py%%PYVER%%.egg
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/hg-git/distinfo b/devel/hg-git/distinfo
new file mode 100644
index 000000000000..5e9d876ffa61
--- /dev/null
+++ b/devel/hg-git/distinfo
@@ -0,0 +1,3 @@
+MD5 (hg-git-0.1.0.tar.gz) = 2c083d92dbf89f228ae28a0fc7805d9e
+SHA256 (hg-git-0.1.0.tar.gz) = 8745c331f010dbdda6b1343a852ef3fb242d5d29196c7dd1197e27e6051212d8
+SIZE (hg-git-0.1.0.tar.gz) = 11351
diff --git a/devel/hg-git/pkg-descr b/devel/hg-git/pkg-descr
new file mode 100644
index 000000000000..f2b9587d0bc4
--- /dev/null
+++ b/devel/hg-git/pkg-descr
@@ -0,0 +1,14 @@
+The Hg-Git plugin is an extension for Mercurial, adding the ability to push to
+and pull from a Git server repository from Mercurial. This means you can
+collaborate on Git based projects from Mercurial, or use a Git server as a
+collaboration point for a team with developers using both Git and Mercurial.
+
+The Hg-Git plugin can convert commits / changesets losslessly from one system
+to another, so you can push via a Mercurial repository and another Mercurial
+client can pull it and their changeset node ids will be identical - Mercurial
+data does not get lost in translation.
+
+This plugin is implemented entirely in Python - there are no Git binary
+dependencies, you do not need to have Git installed on your system.
+
+WWW: http://hg-git.github.com/
diff --git a/devel/hg-git/pkg-message b/devel/hg-git/pkg-message
new file mode 100644
index 000000000000..e2428aa5ee34
--- /dev/null
+++ b/devel/hg-git/pkg-message
@@ -0,0 +1,15 @@
+====
+
+*** Attention! ***
+
+To enable the Hg-Git extension make sure you have the following lines in your
+Mercurial global configuration file '~/.hgrc':
+
+[extensions]
+bookmarks =
+hggit =
+
+The bookmarks section is not compulsory, but it makes some things a bit nicer.
+Bookmarks will be translated to git heads when pushing.
+
+====