aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-09 09:09:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-09 09:09:28 +0000
commite281ec1426732282605ee099e3c2c6b0a8fd7dcd (patch)
tree0ec0568bc9b5a9addc042d6cc86f41c500f19186
parent55c0bc0a022af1ee4cdd5ce4b06fdfdbebfac584 (diff)
downloadports-e281ec1426732282605ee099e3c2c6b0a8fd7dcd.tar.gz
ports-e281ec1426732282605ee099e3c2c6b0a8fd7dcd.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer-Template-Xslate/Makefile29
-rw-r--r--www/p5-Dancer-Template-Xslate/distinfo2
-rw-r--r--www/p5-Dancer-Template-Xslate/files/patch-lib_Dancer_Template_Xslate.pm11
-rw-r--r--www/p5-Dancer-Template-Xslate/pkg-descr3
-rw-r--r--www/p5-Dancer-Template-Xslate/pkg-plist7
6 files changed, 53 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 990db1600545..c6a9ce331ba6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -877,6 +877,7 @@
SUBDIR += p5-Dancer-Plugin-DataFu
SUBDIR += p5-Dancer-Plugin-Feed
SUBDIR += p5-Dancer-Plugin-ValidationClass
+ SUBDIR += p5-Dancer-Template-Xslate
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-Emplacken
diff --git a/www/p5-Dancer-Template-Xslate/Makefile b/www/p5-Dancer-Template-Xslate/Makefile
new file mode 100644
index 000000000000..5147bc1dd8ab
--- /dev/null
+++ b/www/p5-Dancer-Template-Xslate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Dancer-Template-Xslate
+# Date created: 23 October 2011
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Template-Xslate
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:FRANCKC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Text::Xslate wrapper for Dancer
+
+RUN_DEPENDS= p5-Dancer>0:${PORTSDIR}/www/p5-Dancer \
+ p5-Text-Xslate>0:${PORTSDIR}/textproc/p5-Text-Xslate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Template::Xslate.3
+
+post-patch:
+ ${RM} ${WRKSRC}/lib/Dancer/Template/Xslate.pm.orig
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Template-Xslate/distinfo b/www/p5-Dancer-Template-Xslate/distinfo
new file mode 100644
index 000000000000..5a823e0e5fb9
--- /dev/null
+++ b/www/p5-Dancer-Template-Xslate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Template-Xslate-0.01.tar.gz) = 30890f260f3c714191b8e7520844568d1735a5a61f3d2eb9ec3050cb7c4806e1
+SIZE (Dancer-Template-Xslate-0.01.tar.gz) = 10828
diff --git a/www/p5-Dancer-Template-Xslate/files/patch-lib_Dancer_Template_Xslate.pm b/www/p5-Dancer-Template-Xslate/files/patch-lib_Dancer_Template_Xslate.pm
new file mode 100644
index 000000000000..e263880b56e9
--- /dev/null
+++ b/www/p5-Dancer-Template-Xslate/files/patch-lib_Dancer_Template_Xslate.pm
@@ -0,0 +1,11 @@
+--- lib/Dancer/Template/Xslate.pm.orig 2011-10-24 04:30:40.533601086 +0200
++++ lib/Dancer/Template/Xslate.pm 2011-10-24 04:32:01.720597646 +0200
+@@ -14,6 +14,8 @@
+
+ my $_engine;
+
++sub default_tmpl_ext { "tx" }
++
+ sub init {
+ my $self = shift;
+
diff --git a/www/p5-Dancer-Template-Xslate/pkg-descr b/www/p5-Dancer-Template-Xslate/pkg-descr
new file mode 100644
index 000000000000..faad124c2be0
--- /dev/null
+++ b/www/p5-Dancer-Template-Xslate/pkg-descr
@@ -0,0 +1,3 @@
+Xslate template engine for Dancer web framework
+
+WWW: http://search.cpan.org/dist/Dancer-Template-Xslate/
diff --git a/www/p5-Dancer-Template-Xslate/pkg-plist b/www/p5-Dancer-Template-Xslate/pkg-plist
new file mode 100644
index 000000000000..f4796119a835
--- /dev/null
+++ b/www/p5-Dancer-Template-Xslate/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Template/Xslate/.packlist
+%%SITE_PERL%%/Dancer/Template/Xslate.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Template/Xslate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Template
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer
+@dirrmtry %%SITE_PERL%%/Dancer/Template
+@dirrmtry %%SITE_PERL%%/Dancer