aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-27 23:47:28 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-27 23:47:28 +0000
commite900c39c7732e70fa6c8ec55c754e6bf7f4fd4a0 (patch)
tree8c9acda5d1a2fd4d3f2a498f1f3b6aff56de7eed
parent0921faba3199a18b6ec2f1cd4856434957f6b9fb (diff)
downloadports-e900c39c7732e70fa6c8ec55c754e6bf7f4fd4a0.tar.gz
ports-e900c39c7732e70fa6c8ec55c754e6bf7f4fd4a0.zip
MFH: r556467
java/sigar: fix build on powerpc64 Approved by: portmgr (fix build blanket)
Notes
Notes: svn path=/branches/2020Q4/; revision=556468
-rw-r--r--java/sigar/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/java/sigar/Makefile b/java/sigar/Makefile
index 5406fd3be61d..273989ed8569 100644
--- a/java/sigar/Makefile
+++ b/java/sigar/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/NOTICE
BROKEN_armv6= fails to compile: jni-build.xml: gcc failed with return code 1
BROKEN_armv7= fails to compile: jni-build.xml: gcc failed with return code 1
-BROKEN_powerpc64= fails to install: bindings/java/sigar-bin/lib/libsigar-powerpc64-freebsd-1.so: No such file or directory
BUILD_DEPENDS= ${ANT_CMD}:devel/apache-ant
LIB_DEPENDS= libsigar.so:devel/sigar
@@ -42,7 +41,7 @@ PLATFORM_VER= 1
IGNORE= ${OPSYS} platform is not supported
.endif
-LIBNAME= libsigar-${ARCH:S,i386,x86,}-${OPSYS:tl}-${PLATFORM_VER}.so
+LIBNAME= libsigar-${ARCH:S,i386,x86,:S,powerpc64,ppc64,}-${OPSYS:tl}-${PLATFORM_VER}.so
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
%%JAVAJARDIR%%/${LIBNAME}
@@ -61,7 +60,7 @@ do-build:
do-install:
${INSTALL_DATA} ${WRKSRC}/bindings/java/sigar-bin/lib/sigar.jar \
${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
- ${INSTALL_LIB} ${WRKSRC}/bindings/java/sigar-bin/lib/libsigar-${ARCH:S,i386,x86,}-freebsd-${PLATFORM_VER}.so \
+ ${INSTALL_LIB} ${WRKSRC}/bindings/java/sigar-bin/lib/libsigar-${ARCH:S,i386,x86,:S,powerpc64,ppc64,}-freebsd-${PLATFORM_VER}.so \
${STAGEDIR}${JAVAJARDIR}/${LIBNAME}
.include <bsd.port.post.mk>