aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-17 22:47:50 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-17 22:47:50 +0000
commite9cb0e0ba325f236bbd6d76368c45dd8708b7069 (patch)
treeb75cc24de263cba191e90851d04cdd19db6aa48b
parent19a6e51b22954673826f209480ba4fbd283eb1f8 (diff)
downloadports-e9cb0e0ba325f236bbd6d76368c45dd8708b7069.tar.gz
ports-e9cb0e0ba325f236bbd6d76368c45dd8708b7069.zip
Notes
-rw-r--r--biology/avida/Makefile8
-rw-r--r--cad/alliance/Makefile4
-rw-r--r--comms/aldo/Makefile4
-rw-r--r--emulators/adamem/Makefile8
-rw-r--r--games/alephone/Makefile8
-rw-r--r--games/asc/Makefile4
-rw-r--r--games/fgfs-base/Makefile8
-rw-r--r--games/flightgear-data/Makefile8
-rw-r--r--games/flightgear/Makefile8
-rw-r--r--games/rtb/Makefile8
-rw-r--r--sysutils/and/Makefile8
-rw-r--r--www/admuser/Makefile8
-rw-r--r--www/arena/Makefile8
13 files changed, 82 insertions, 10 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index 825a3dc3b317..430d244e5836 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -39,6 +39,12 @@ DIR2FIX= source/main/functional_testsuites/default.md5sum/genesis \
source/qt-viewer/setup_genesis.cc source/support/genesis \
source/support/genesis.4stack source/main/config.cc source/defs.hh
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-configure:
.for src in ${DIR2FIX}
@${REINPLACE_CMD} -e "s|../work/|${DATADIR}/|" ${WRKSRC}/${src}
@@ -53,4 +59,4 @@ post-install:
${INSTALL_PROGRAM} ${WRKSRC}/work/qt-viewer ${PREFIX}/bin
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index f70acbf8030e..2133a32f46ad 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -35,6 +35,10 @@ PKGMESSAGE_IN= ${FILESDIR}/pkg-message.in
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
ALLIANCE_TOP= ${PREFIX}/alliance
SRCDIRLIST!= ${CAT} ${FILESDIR}/srcdirs.list
CFLAGS+= ${SRCDIRLIST:S,^,-I${WRKSRC}/,}
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index c24eb85e6a5e..eac7f0422c05 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -22,6 +22,10 @@ PLIST_FILES= bin/aldo
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} < 500000
USE_GCC= 3.3
MAKE_ENV+= CXX="${CXX}"
diff --git a/emulators/adamem/Makefile b/emulators/adamem/Makefile
index 714798c99e60..53086cac5915 100644
--- a/emulators/adamem/Makefile
+++ b/emulators/adamem/Makefile
@@ -21,6 +21,12 @@ ALL_TARGET= x
PROGDIR= ${PREFIX}/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-install:
${MKDIR} ${PROGDIR}
${INSTALL_PROGRAM} ${WRKSRC}/adamem ${PROGDIR}
@@ -34,4 +40,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/adamem.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 8f677a4475c5..9ea6be5a6dd3 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -22,6 +22,12 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${PERL} -pi -e 's,^#include \"network_modem.h\".*,,' \
${WRKSRC}/Source_Files/Network/network.cpp \
@@ -32,4 +38,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/asc/Makefile b/games/asc/Makefile
index eb352b690e91..145be0e79edc 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -35,6 +35,10 @@ OPTIONS= MUSIC "Install extra music files" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if defined(WITH_MUSIC)
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} frontiers.mp3 time_to_strike.mp3 machine_wars.mp3
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/games/fgfs-base/Makefile b/games/fgfs-base/Makefile
index 5d16ec5d7e91..2852beed6f88 100644
--- a/games/fgfs-base/Makefile
+++ b/games/fgfs-base/Makefile
@@ -40,6 +40,12 @@ CONFIGURE_ARGS= --with-threads
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -53,4 +59,4 @@ do-install:
@(cd ${WRKSRC}/data && ${FIND} . -type f |\
${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index 5d16ec5d7e91..2852beed6f88 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -40,6 +40,12 @@ CONFIGURE_ARGS= --with-threads
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -53,4 +59,4 @@ do-install:
@(cd ${WRKSRC}/data && ${FIND} . -type f |\
${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 5d16ec5d7e91..2852beed6f88 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -40,6 +40,12 @@ CONFIGURE_ARGS= --with-threads
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -53,4 +59,4 @@ do-install:
@(cd ${WRKSRC}/data && ${FIND} . -type f |\
${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 03a2b485b0d5..e1e13d6f03e5 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -29,6 +29,12 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -37,4 +43,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/RealTimeBattle.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/and/Makefile b/sysutils/and/Makefile
index 9bacece634c1..1edd303300b9 100644
--- a/sysutils/and/Makefile
+++ b/sysutils/and/Makefile
@@ -22,4 +22,10 @@ ALL_TARGET= default
MAN5= and.conf.5 and.priorities.5
MAN8= and.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/admuser/Makefile b/www/admuser/Makefile
index 8333c7bd6fa1..7088e7798d58 100644
--- a/www/admuser/Makefile
+++ b/www/admuser/Makefile
@@ -20,9 +20,15 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/etc/admuser \
--enable-language=English \
--enable-cgidir=${PREFIX}/www/cgi-bin \
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-install:
@${MKDIR} ${PREFIX}/www/cgi-bin
#BROKEN= "Install fails"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/arena/Makefile b/www/arena/Makefile
index 8a6e993b6971..68fcc94830cc 100644
--- a/www/arena/Makefile
+++ b/www/arena/Makefile
@@ -21,6 +21,12 @@ PLIST_FILES= bin/arena
USE_XLIB= yes
WRKSRC= ${WRKDIR}/WWW
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-build:
cd ${WRKSRC}/Library/freebsd; ${MAKE}
cd ${WRKSRC}/Arena/freebsd; \
@@ -33,4 +39,4 @@ do-install:
cd ${WRKSRC}/Arena/freebsd; \
${INSTALL} -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} -s arena ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>