aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2011-10-16 20:02:56 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2011-10-16 20:02:56 +0000
commitec5f3deec985a72a6ce422e1609f4d5111e2ccd7 (patch)
tree086203e7a459eeb649b24be310a4302c09400a84
parentc66377013e24c518bbb494bf99cc425609cb0d6e (diff)
downloadports-ec5f3deec985a72a6ce422e1609f4d5111e2ccd7.tar.gz
ports-ec5f3deec985a72a6ce422e1609f4d5111e2ccd7.zip
Notes
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile5
-rw-r--r--ports-mgmt/tinderbox-devel/files/extra-tmpfs.patch4
-rw-r--r--ports-mgmt/tinderbox-devel/files/extra-tmpfs_para.patch4
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-sql__values.hooks8
4 files changed, 15 insertions, 6 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 50ead0d39231..2259d81fc86e 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -6,6 +6,7 @@
PORTNAME= tinderbox
DISTVERSION= 3.4${SNAP}
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
@@ -27,8 +28,8 @@ OPTIONS= PGSQL "With pgsql" Off \
EMAILS "Support for build failure/completion emails" On \
LSOF "For killMountProcesses() when using nullfs" On \
LOG_COMPRESS "Support bzip'ing the logs" On \
- TMPFS "Enable TMPFS extra patch" On \
- PARALLEL "Enable PARALLEL extra patch" On
+ PARALLEL "Enable PARALLEL extra patch" On \
+# TMPFS "Enable TMPFS extra patch" Off
NO_BUILD= yes
WANT_PERL= yes
diff --git a/ports-mgmt/tinderbox-devel/files/extra-tmpfs.patch b/ports-mgmt/tinderbox-devel/files/extra-tmpfs.patch
index bb3bdb18f8ed..ca45ca7ccb74 100644
--- a/ports-mgmt/tinderbox-devel/files/extra-tmpfs.patch
+++ b/ports-mgmt/tinderbox-devel/files/extra-tmpfs.patch
@@ -1,5 +1,5 @@
---- tinderd.orig 2010-01-04 21:12:37.000000000 +0100
-+++ tinderd 2010-01-04 21:14:28.000000000 +0100
+--- etc/rc.d/tinderd.orig 2010-01-04 21:12:37.000000000 +0100
++++ etc/rc.d/tinderd 2010-01-04 21:14:28.000000000 +0100
@@ -36,12 +36,14 @@
MAIL=$(echo ${ENTRY} | cut -d: -f5)
diff --git a/ports-mgmt/tinderbox-devel/files/extra-tmpfs_para.patch b/ports-mgmt/tinderbox-devel/files/extra-tmpfs_para.patch
index c4a1dacc2b42..cecfc03de140 100644
--- a/ports-mgmt/tinderbox-devel/files/extra-tmpfs_para.patch
+++ b/ports-mgmt/tinderbox-devel/files/extra-tmpfs_para.patch
@@ -1,5 +1,5 @@
---- tinderd.orig 2010-01-04 20:56:05.000000000 +0100
-+++ tinderd 2010-01-05 20:13:58.000000000 +0100
+--- etc/rc.d/tinderd.orig 2010-01-04 20:56:05.000000000 +0100
++++ etc/rc.d/tinderd 2010-01-05 20:13:58.000000000 +0100
@@ -28,7 +28,22 @@
do
trap "" 1
diff --git a/ports-mgmt/tinderbox-devel/files/patch-sql__values.hooks b/ports-mgmt/tinderbox-devel/files/patch-sql__values.hooks
new file mode 100644
index 000000000000..e559292c5831
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-sql__values.hooks
@@ -0,0 +1,8 @@
+--- ./sql/values.hooks.orig 2011-10-16 03:52:55.000000000 +0300
++++ ./sql/values.hooks 2011-10-16 22:39:42.000000000 +0300
+@@ -15,4 +15,4 @@
+ INSERT INTO hooks VALUES ('prePortBuild', NULL, 'Hook to run before building a port.\nIf this command returns a non-zero value, the port will not be built.\nThe following environment will be passed to the hook command:\n\tPACKAGE_NAME : Package name of the port\n\tBUILD : Build name for this port\n\tJAIL : Jail name for this Build\n\tPORTSTREE : PortsTree name for this Build\n\tCHROOT : Location of the Build root\n\tPORTDIR : Directory origin of this port\n\tPB : Tinderbox root\n\tTOTAL_SIZE : Estimated total size (in KB) required for this build');
+ INSERT INTO hooks VALUES ('postPortBuild', NULL, 'Hook to run after building a port.\nThe following environment will be passed to the hook command:\n\tPACKAGE_NAME : Package name of the port\n\tBUILD : Build name for this port\n\tJAIL : Jail name for this Build\n\tPORTSTREE : PortsTree name for this Build\n\tCHROOT : Location of the Build root\n\tPORTDIR : Directory origin of this port\n\tPB : Tinderbox root\n\tSTATUS : Status of the port build\n\tFAIL_REASON : Reason why the port build failed (if any)\n\tTOTAL_SIZE : Total size (in KB) used for this build');
+ INSERT INTO hooks VALUES ('prePortChecksum', NULL, 'Hook to run before checking a port''s distfile checksum(s).\nIf this command returns a non-zero value, the port will not be built.\nThe following environment will be passed to the hook command:\n\tPACKAGE_NAME : Package name of the port\n\tBUILD : Build name for this port\n\tJAIL : Jail name for this Build\n\tPORTSTREE : PortsTree name for this Build\n\tCHROOT : Location of the Build root\n\tPORTDIR : Directory origin of this port\n\tPB : Tinderbox root\n\tTOTAL_SIZE : Estimated total size (in KB) required for this build');
+- INSERT INTO hooks VALUES ('postPortChecksum', NULL, 'Hook to run after checking a port's distfie checksum(s).\nThe following environment will be passed to the hook command:\n\tPACKAGE_NAME : Package name of the port\n\tBUILD : Build name for this port\n\tJAIL : Jail name for this Build\n\tPORTSTREE : PortsTree name for this Build\n\tCHROOT : Location of the Build root\n\tPORTDIR : Directory origin of this port\n\tPB : Tinderbox root\n\tERROR : Error returned from the make checksum (0 means no error occurred)\n\tFAIL_REASON : Reason why the port build failed (if any)\n\tTOTAL_SIZE : Total size (in KB) used for this build'); INSERT INTO hooks VALUES ('postPortChecksum', NULL, 'Hook to run after checking a port''s distfie checksum(s).\nThe following environment will be passed to the hook command:\n\tPACKAGE_NAME : Package name of the port\n\tBUILD : Build name for this port\n\tJAIL : Jail name for this Build\n\tPORTSTREE : PortsTree name for this Build\n\tCHROOT : Location of the Build root\n\tPORTDIR : Directory origin of this port\n\tPB : Tinderbox root\n\tERROR : Error returned from the make checksum (0 means no error occurred)\n\tFAIL_REASON : Reason why the port build failed (if any)\n\tTOTAL_SIZE : Total size (in KB) used for this build');
++INSERT INTO hooks VALUES ('postPortChecksum', NULL, 'Hook to run after checking a port''s distfie checksum(s).\nThe following environment will be passed to the hook command:\n\tPACKAGE_NAME : Package name of the port\n\tBUILD : Build name for this port\n\tJAIL : Jail name for this Build\n\tPORTSTREE : PortsTree name for this Build\n\tCHROOT : Location of the Build root\n\tPORTDIR : Directory origin of this port\n\tPB : Tinderbox root\n\tERROR : Error returned from the make checksum (0 means no error occurred)\n\tFAIL_REASON : Reason why the port build failed (if any)\n\tTOTAL_SIZE : Total size (in KB) used for this build');