aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-29 08:08:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-29 08:08:49 +0000
commitf23d133db5f23fb793b9c0d556c2be9236f248ee (patch)
tree7d6934b22a27bec1d23fc922ef7952ee21d11abc
parent8c2deec1815d6f40c2aa8e7ceec8532ad23b84b1 (diff)
downloadports-f23d133db5f23fb793b9c0d556c2be9236f248ee.tar.gz
ports-f23d133db5f23fb793b9c0d556c2be9236f248ee.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/xfce4-mount-plugin/Makefile27
-rw-r--r--sysutils/xfce4-mount-plugin/distinfo2
-rw-r--r--sysutils/xfce4-mount-plugin/pkg-descr4
-rw-r--r--sysutils/xfce4-mount-plugin/pkg-plist57
5 files changed, 91 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ddb56e38ba2f..70c1aa29acf2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1006,6 +1006,7 @@
SUBDIR += xfce4-fsguard-plugin
SUBDIR += xfce4-genmon-plugin
SUBDIR += xfce4-minicmd-plugin
+ SUBDIR += xfce4-mount-plugin
SUBDIR += xfce4-netload-plugin
SUBDIR += xfce4-power-manager
SUBDIR += xfce4-settings
diff --git a/sysutils/xfce4-mount-plugin/Makefile b/sysutils/xfce4-mount-plugin/Makefile
new file mode 100644
index 000000000000..1294769fa492
--- /dev/null
+++ b/sysutils/xfce4-mount-plugin/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: xfce4-mount-plugin
+# Date created: 2012-04-17
+# Whom: Olivier Duchateau <duchateau.olivier@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-mount-plugin
+PORTVERSION= 0.6.4
+CATEGORIES= sysutils xfce
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Mount and umount utility for the Xfce4 panel
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack intltool intlhack pkgconfig
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+USE_XFCE= configenv libmenu panel
+
+.include <bsd.port.mk>
diff --git a/sysutils/xfce4-mount-plugin/distinfo b/sysutils/xfce4-mount-plugin/distinfo
new file mode 100644
index 000000000000..66294b92e286
--- /dev/null
+++ b/sysutils/xfce4-mount-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4/xfce4-mount-plugin-0.6.4.tar.bz2) = 541d7af84d7d0b00ae547aa1f438e2fac51ee4195c4d0a17173c4f72accb227d
+SIZE (xfce4/xfce4-mount-plugin-0.6.4.tar.bz2) = 390365
diff --git a/sysutils/xfce4-mount-plugin/pkg-descr b/sysutils/xfce4-mount-plugin/pkg-descr
new file mode 100644
index 000000000000..18d60fd8f186
--- /dev/null
+++ b/sysutils/xfce4-mount-plugin/pkg-descr
@@ -0,0 +1,4 @@
+Mount plugin allows to mount/umount external devices, cd/dvd-rom and
+networked filesystems listed in your /etc/fstab.
+
+WWW: http://goodies.xfce.org/projects/panel-plugins/xfce4-mount-plugin
diff --git a/sysutils/xfce4-mount-plugin/pkg-plist b/sysutils/xfce4-mount-plugin/pkg-plist
new file mode 100644
index 000000000000..d39968265e11
--- /dev/null
+++ b/sysutils/xfce4-mount-plugin/pkg-plist
@@ -0,0 +1,57 @@
+lib/xfce4/panel/plugins/libmount.la
+lib/xfce4/panel/plugins/libmount.so
+share/icons/hicolor/scalable/apps/xfce-mount.svg
+share/locale/ar/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ast/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ca/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/cs/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/da/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/de/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/el/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/en_GB/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/es/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/eu/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/fi/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/fr/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/gl/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/hr/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/hu/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/id/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/it/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ja/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ko/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/lt/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/lv/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/nb/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/nl/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/pa/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/pl/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/pt/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/pt_BR/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ru/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/sk/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/sq/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/sv/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/tr/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ug/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/uk/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ur/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/ur_PK/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/vi/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/zh_CN/LC_MESSAGES/xfce4-mount-plugin.mo
+share/locale/zh_TW/LC_MESSAGES/xfce4-mount-plugin.mo
+share/xfce4/panel/plugins/xfce4-mount-plugin.desktop
+@dirrmtry share/xfce4/panel/plugins
+@dirrmtry share/xfce4/panel
+@dirrmtry share/xfce4
+@dirrmtry share/locale/ur_PK/LC_MESSAGES
+@dirrmtry share/locale/ur_PK
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry lib/xfce4/panel/plugins
+@dirrmtry lib/xfce4/panel
+@dirrmtry lib/xfce4