aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-12-20 09:00:38 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-12-20 09:00:38 +0000
commitf565761baf9bb386631833cce7e0f433ab2c7619 (patch)
treed337bc92cba49de1934f00d57789c4efe4ed7168
parent87c875c2635c7c35e58ef68bddc4d6d1d489a220 (diff)
downloadports-f565761baf9bb386631833cce7e0f433ab2c7619.tar.gz
ports-f565761baf9bb386631833cce7e0f433ab2c7619.zip
Notes
-rw-r--r--graphics/freeimage/Makefile33
-rw-r--r--graphics/freeimage/distinfo5
-rw-r--r--graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h10
-rw-r--r--graphics/freeimage/pkg-descr11
4 files changed, 28 insertions, 31 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 367bf11283f7..0491aa8673da 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -1,12 +1,12 @@
-# New ports collection makefile for: freeimage
-# Date created: 2005-09-01
-# Whom: Choe, Cheng-Dae
+# New ports collection makefile for: FreeImage
+# Date created: 2005-09-01
+# Whom: Choe, Cheng-Dae <whitekid@gmail.com>
#
# $FreeBSD$
#
PORTNAME= freeimage
-PORTVERSION= 3.12.0
+PORTVERSION= 3.14.1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Source%20Distribution/${PORTVERSION}
DISTNAME= FreeImage${PORTVERSION:S/.//g}
@@ -14,12 +14,17 @@ DISTNAME= FreeImage${PORTVERSION:S/.//g}
MAINTAINER= gahr@FreeBSD.org
COMMENT= An open source graphics library
-WRKSRC= ${WRKDIR}/FreeImage
-USE_GMAKE= yes
USE_ZIP= yes
-# convert CRLF to LF for gcc-2.95
-EXTRACT_BEFORE_ARGS= -qoa
+USE_DOS2UNIX= Source/LibOpenJPEG/opj_malloc.h
+USE_GMAKE= yes
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/FreeImage
+
+PLIST_FILES= include/FreeImage.h \
+ lib/libfreeimage.a \
+ lib/libfreeimage-${PORTVERSION}.so \
+ lib/libfreeimage.so.3 \
+ lib/libfreeimage.so
.include <bsd.port.pre.mk>
@@ -27,16 +32,8 @@ USE_LDCONFIG= yes
CFLAGS+= -fPIC
.endif
-PLIST_FILES= include/FreeImage.h \
- lib/libfreeimage.a \
- lib/libfreeimage-3.12.0.so \
- lib/libfreeimage.so.3
-
post-patch:
- ${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g'
- ${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g; s|-g root|-g wheel|g' ${WRKSRC}/Makefile.gnu
-
-post-install:
- ${LN} -f ${PREFIX}/lib/libfreeimage-3.12.0.so ${PREFIX}/lib/libfreeimage.so.3
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}| ; s|-g root|-g wheel|' \
+ ${WRKSRC}/Makefile.gnu
.include <bsd.port.post.mk>
diff --git a/graphics/freeimage/distinfo b/graphics/freeimage/distinfo
index e8d69a8a2850..42d5ddc76592 100644
--- a/graphics/freeimage/distinfo
+++ b/graphics/freeimage/distinfo
@@ -1,3 +1,2 @@
-MD5 (FreeImage3120.zip) = 47b259102f776a4bcd7affc00942f3b4
-SHA256 (FreeImage3120.zip) = a431fccbfd7c06fd32155b39361d520a710ee878440cca3e11706c0bd1ae6cc3
-SIZE (FreeImage3120.zip) = 4335135
+SHA256 (FreeImage3141.zip) = d5c5b5ea96897f4b81e79a37b1149a12bb396039002f22d32f9f98f6b96cff65
+SIZE (FreeImage3141.zip) = 10865165
diff --git a/graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h b/graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h
index fc4362a3b6fd..119cef1f230c 100644
--- a/graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h
+++ b/graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h
@@ -1,12 +1,14 @@
---- Source/LibOpenJPEG/opj_malloc.h.orig 2008-12-03 16:48:35.000000000 +0100
-+++ Source/LibOpenJPEG/opj_malloc.h 2008-12-03 16:49:08.000000000 +0100
-@@ -77,7 +77,9 @@
+--- Source/LibOpenJPEG/opj_malloc.h.orig
++++ Source/LibOpenJPEG/opj_malloc.h
+@@ -85,8 +85,10 @@
#define HAVE_MEMALIGN
/* Linux x86_64 and OSX always align allocations to 16 bytes */
#elif !defined(__amd64__) && !defined(__APPLE__)
+ #ifndef __FreeBSD__
#define HAVE_MEMALIGN
+- #include <malloc.h>
+ #endif
- #include <malloc.h>
++ #include <stdlib.h>
#endif
#endif
+
diff --git a/graphics/freeimage/pkg-descr b/graphics/freeimage/pkg-descr
index 178aea424e0a..3c81f1d58fea 100644
--- a/graphics/freeimage/pkg-descr
+++ b/graphics/freeimage/pkg-descr
@@ -1,7 +1,6 @@
-FreeImage is an Open Source library project for developers who would like to
-support popular graphics image formats like PNG, BMP, JPEG, TIFF and others as
-needed by today's multimedia applications. FreeImage is easy to use, fast,
-multithreading safe, compatible with all 32-bit versions of Windows, and
-cross-platform (works both with Linux and Mac OS X).
+FreeImage is an open source library project for developers who would like to
+support popular graphics image formats like PNG, BMP, JPEG, TIFF and others
+as needed by today's multimedia applications. FreeImage is easy to use,
+fast, multithreading safe, and cross-platform.
-WWW: http://freeimage.sf.net
+WWW: http://freeimage.sourceforge.net/