aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-09-01 21:34:14 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-09-01 21:34:14 +0000
commitf73c5d7bee5ccfb05932f1aa5df48d87d321a1f0 (patch)
treee9125de1a9d21249458106c73d75f2bb2c38fbd5
parent1861b26d39ecd39b71d697d3a9805be7d3e6c77b (diff)
downloadports-f73c5d7bee5ccfb05932f1aa5df48d87d321a1f0.tar.gz
ports-f73c5d7bee5ccfb05932f1aa5df48d87d321a1f0.zip
Notes
-rw-r--r--audio/sdl_mixer/Makefile2
-rw-r--r--devel/sdl12/Makefile2
-rw-r--r--graphics/sdl_gfx/Makefile7
-rw-r--r--graphics/sdl_image/Makefile4
-rw-r--r--graphics/sdl_ttf/Makefile4
-rw-r--r--net/sdl_net/Makefile4
-rw-r--r--x11-toolkits/sdl_gui/Makefile7
7 files changed, 16 insertions, 14 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 3c03b3802678..532c62c55fef 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL_mixer-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= A sample multi-channel audio mixer library
USE_SDL= sdl
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index ad1e6c45d95b..cdf4f44f21c3 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -13,7 +13,7 @@ CATEGORIES= devel
MASTER_SITES= http://www.libsdl.org/release/
DISTNAME= SDL-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= Cross-platform multi-media development API
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index 403cd5e0c172..9f037eaed623 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -10,11 +10,12 @@ PORTNAME= sdl_gfx
PORTVERSION= 2.0.13
PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/
+MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/ \
+ http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
MASTER_SITE_SUBDIR= SDL_gfx-${PORTVERSION:R}
DISTNAME= SDL_gfx-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= SDL graphics drawing primitives and other support functions
USE_SDL= sdl
@@ -25,7 +26,7 @@ CONFIGURE_ARGS= --includedir=${PREFIX}/include/SDL11 \
--disable-mmx
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 1e4b95c129a2..2cddb43cb7ed 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL_image-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= A simple library to load images of various formats as SDL surfaces
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -27,7 +27,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
CONFIGURE_ARGS= --enable-tif --enable-xcf
MAKE_ARGS= LT_CURRENT=10 LT_REVISION=0 LT_AGE=0
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/showimage ${PREFIX}/bin
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index eca56d1cdfcd..ae116d263136 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL_ttf-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= A library to use TrueType fonts to render text in SDL applications
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
@@ -25,7 +25,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ARGS= LT_CURRENT=3 LT_REVISION=0 LT_AGE=0
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${PREFIX}/bin
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index f495421b9f6f..54efb1b9aa6f 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -12,13 +12,13 @@ CATEGORIES= net
MASTER_SITES= http://www.libsdl.org/projects/SDL_net/release/
DISTNAME= SDL_net-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= A small sample cross-platform networking library
USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-configure:
@${REINPLACE_CMD} -e \
diff --git a/x11-toolkits/sdl_gui/Makefile b/x11-toolkits/sdl_gui/Makefile
index 951838da7283..86331879db15 100644
--- a/x11-toolkits/sdl_gui/Makefile
+++ b/x11-toolkits/sdl_gui/Makefile
@@ -10,15 +10,16 @@ PORTNAME= sdl_gui
PORTVERSION= 0.10.3
PORTREVISION= 4
CATEGORIES= x11-toolkits
-MASTER_SITES= http://www.newimage.com/~rhk/SDL_gui/
+MASTER_SITES= http://www.newimage.com/~rhk/SDL_gui/ \
+ http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
DISTNAME= SDL_gui-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= A Graphical User Interface library for SDL
USE_SDL= sdl image ttf
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-configure:
${REINPLACE_CMD} -e "s/^CC=\"cc\"/CC=\"${CXX}\"/" ${WRKSRC}/libtool