aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2017-01-22 20:35:34 +0000
committerThierry Thomas <thierry@FreeBSD.org>2017-01-22 20:35:34 +0000
commitf8308bb9260d4b51f43fc2dc96a01c7c1bd9a2a6 (patch)
treed8053bc3bd470084a30514ef7aea97d5dea80175
parente39970ebe93c3b6919b349563a553ae543b6e75c (diff)
downloadports-f8308bb9260d4b51f43fc2dc96a01c7c1bd9a2a6.tar.gz
ports-f8308bb9260d4b51f43fc2dc96a01c7c1bd9a2a6.zip
Notes
-rw-r--r--french/aster/Makefile2
-rw-r--r--french/aster/files/patch-as_setup.py10
-rw-r--r--french/aster/pkg-plist1
3 files changed, 11 insertions, 2 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 6023de45d4b2..626a4c6fa55e 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aster
DISTVERSION= ${ASTER_DISTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= french cad
CATEGORIES= french cad
diff --git a/french/aster/files/patch-as_setup.py b/french/aster/files/patch-as_setup.py
index 502ec850d639..0836f467c458 100644
--- a/french/aster/files/patch-as_setup.py
+++ b/french/aster/files/patch-as_setup.py
@@ -17,7 +17,7 @@
self._print(self._fmt_title % _('Extraction'))
if kargs.get('external')<>None:
self._call_external(**kargs)
-@@ -518,6 +521,52 @@ class SETUP:
+@@ -518,6 +521,60 @@ class SETUP:
if iextr_as:
self.Clean(to_delete=path)
@@ -30,6 +30,14 @@
+ if nl > 0:
+ ligne =ligne.replace("self.check_cc", "# self.check_cc")
+ sys.stdout.write(ligne)
++ file2patch = os.path.join(self.workdir, self.content, 'bibcxx/wscript')
++ self._print('FreeBSD patch: explicit link with libc++ required since Gcc 4.9 => modify ' + file2patch)
++ for ligne in fileinput.input(file2patch, inplace=1):
++ nl = 0
++ nl = string.find(ligne, "uselib_store='CXX', lib='stdc++'")
++ if nl > 0:
++ ligne =ligne.replace("lib='stdc++'", "lib='c++ stdc++'")
++ sys.stdout.write(ligne)
+ file2patch = os.path.join(self.workdir, self.content, 'waftools/scotch.py')
+ self._print('FreeBSD patch: int64_t missing => modify ' + file2patch)
+ for ligne in fileinput.input(file2patch, inplace=1):
diff --git a/french/aster/pkg-plist b/french/aster/pkg-plist
index 8a04aa817328..9ba71c8f47c6 100644
--- a/french/aster/pkg-plist
+++ b/french/aster/pkg-plist
@@ -2610,6 +2610,7 @@ aster/%%VE%%/lib/aster/aster_pkginfo.pyo
aster/%%VE%%/lib/aster/aster_settings.py
aster/%%VE%%/lib/aster/aster_settings.pyc
aster/%%VE%%/lib/aster/aster_settings.pyo
+aster/%%VE%%/lib/aster/libAsterBehaviour.so
aster/%%VE%%/lib/aster/elem.1
aster/%%VE%%/profile.sh
aster/%%VE%%/share/aster/CTestTestfile.cmake