aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-06 18:56:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-06 18:56:00 +0000
commitf938e2c7bbcedd632876380a8a821d5abb37e33d (patch)
tree18fd3f05f42d716a6ee7892b2e67c6311747294c
parent9c3538b151a7e9474d73cd6fe3bcb6f38b7e6158 (diff)
downloadports-f938e2c7bbcedd632876380a8a821d5abb37e33d.tar.gz
ports-f938e2c7bbcedd632876380a8a821d5abb37e33d.zip
Notes
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-Cpanel-JSON-XS/Makefile23
-rw-r--r--converters/p5-Cpanel-JSON-XS/distinfo2
-rw-r--r--converters/p5-Cpanel-JSON-XS/pkg-descr10
-rw-r--r--converters/p5-Cpanel-JSON-XS/pkg-plist15
5 files changed, 51 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index cb985a53e882..a4b35a393369 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -71,6 +71,7 @@
SUBDIR += p5-Convert-TNEF
SUBDIR += p5-Convert-UU
SUBDIR += p5-Convert-UUlib
+ SUBDIR += p5-Cpanel-JSON-XS
SUBDIR += p5-Cstools
SUBDIR += p5-Data-AMF
SUBDIR += p5-Encode
diff --git a/converters/p5-Cpanel-JSON-XS/Makefile b/converters/p5-Cpanel-JSON-XS/Makefile
new file mode 100644
index 000000000000..25afc6d26e72
--- /dev/null
+++ b/converters/p5-Cpanel-JSON-XS/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Cpanel-JSON-XS
+PORTVERSION= 2.34.03
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RURBAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= JSON::XS for Cpanel, fast and correct serialising
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/converters/p5-Cpanel-JSON-XS/distinfo b/converters/p5-Cpanel-JSON-XS/distinfo
new file mode 100644
index 000000000000..b85a1b6ffa44
--- /dev/null
+++ b/converters/p5-Cpanel-JSON-XS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Cpanel-JSON-XS-2.3403.tar.gz) = c8ce1e07ad8d2991092f7a90810fe17d2240f729a750c5b6e731f14ff7468be3
+SIZE (Cpanel-JSON-XS-2.3403.tar.gz) = 129712
diff --git a/converters/p5-Cpanel-JSON-XS/pkg-descr b/converters/p5-Cpanel-JSON-XS/pkg-descr
new file mode 100644
index 000000000000..46027c20ab67
--- /dev/null
+++ b/converters/p5-Cpanel-JSON-XS/pkg-descr
@@ -0,0 +1,10 @@
+Cpanel::JSON::XS converts Perl data structures to JSON and vice versa. Its
+primary goal is to be correct and its secondary goal is to be fast. To reach the
+latter goal it was written in C.
+
+As this is the n-th-something JSON module on CPAN, what was the reason to write
+yet another JSON module? While it seems there are many JSON modules, none of
+them correctly handle all corner cases, and in most cases their maintainers are
+unresponsive, gone missing, or not listening to bug reports for other reasons.
+
+WWW: http://search.cpan.org/dist/Cpanel-JSON-XS/
diff --git a/converters/p5-Cpanel-JSON-XS/pkg-plist b/converters/p5-Cpanel-JSON-XS/pkg-plist
new file mode 100644
index 000000000000..db48a315fca2
--- /dev/null
+++ b/converters/p5-Cpanel-JSON-XS/pkg-plist
@@ -0,0 +1,15 @@
+bin/cpanel_json_xs
+%%SITE_PERL%%/%%PERL_ARCH%%/Cpanel/JSON/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Cpanel/JSON/XS/Boolean.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cpanel/JSON/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cpanel/JSON/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cpanel/JSON/XS/XS.so
+%%PERL5_MAN3%%/Cpanel::JSON::XS.3.gz
+%%PERL5_MAN3%%/Cpanel::JSON::XS::Boolean.3.gz
+man/man1/cpanel_json_xs.1.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cpanel/JSON/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cpanel/JSON
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cpanel
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Cpanel/JSON/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Cpanel/JSON
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Cpanel