aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-06-01 04:00:24 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-06-01 04:00:24 +0000
commit249914eb08ab68fb1bb2bbffed49901ea5f18b5d (patch)
treeab44825cc45e17b99a8e5dc4291d970ebd491d3c
parentdb57bba82a5e26a1394c28dabecce917483a36db (diff)
downloadports-249914eb08ab68fb1bb2bbffed49901ea5f18b5d.tar.gz
ports-249914eb08ab68fb1bb2bbffed49901ea5f18b5d.zip
Notes
-rw-r--r--dns/fpdns/Makefile2
-rw-r--r--dns/p5-Net-DNS/Makefile10
-rw-r--r--irc/sirc/Makefile2
-rw-r--r--net-mgmt/hawk/Makefile8
-rw-r--r--x11/xscreensaver/Makefile2
5 files changed, 12 insertions, 12 deletions
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
index 1b56055cdc34..4d458ea33ba4 100644
--- a/dns/fpdns/Makefile
+++ b/dns/fpdns/Makefile
@@ -17,7 +17,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dougb@FreeBSD.org
COMMENT= FPDNS - Fingerprinting DNS servers
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= p5-Net-DNS:${PORTSDIR}/dns/p5-Net-DNS
PERL_CONFIGURE= yes
diff --git a/dns/p5-Net-DNS/Makefile b/dns/p5-Net-DNS/Makefile
index 80730f4dde00..25e5a35ce68a 100644
--- a/dns/p5-Net-DNS/Makefile
+++ b/dns/p5-Net-DNS/Makefile
@@ -15,10 +15,10 @@ MAINTAINER= dougb@FreeBSD.org
COMMENT= Perl5 interface to the DNS resolver, and dynamic updates
# Warnings during build are harmless, the port does not need these to build
-RUN_DEPENDS= ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC
+RUN_DEPENDS= p5-Digest-HMAC:${PORTSDIR}/security/p5-Digest-HMAC
-TEST_DEPENDS= ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
- ${SITE_PERL}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble
+TEST_DEPENDS= p5-Test-Pod:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Digest-BubbleBabble:${PORTSDIR}/security/p5-Digest-BubbleBabble
MAKE_JOBS_SAFE= yes
@@ -62,11 +62,11 @@ RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
.endif
.if !defined(WITHOUT_IPV6)
-RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6
+RUN_DEPENDS+= p5-IO-Socket-INET6:${PORTSDIR}/net/p5-IO-Socket-INET6
.endif
.if defined(WITH_IDN)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/LibIDN.pm:${PORTSDIR}/dns/p5-Net-LibIDN
+RUN_DEPENDS+= p5-Net-LibIDN:${PORTSDIR}/dns/p5-Net-LibIDN
.endif
DOCSDIR= ${PREFIX}/share/doc/p5-Net-DNS
diff --git a/irc/sirc/Makefile b/irc/sirc/Makefile
index b0d9f559c985..fa09ba0acb05 100644
--- a/irc/sirc/Makefile
+++ b/irc/sirc/Makefile
@@ -34,7 +34,7 @@ PORTDOCS= ChangeLog PROGRAMMING README
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_IPV6)
-RUN_DEPENDS= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6
+RUN_DEPENDS= p5-IO-Socket-INET6:${PORTSDIR}/net/p5-IO-Socket-INET6
EXTRA_PATCHES= ${PATCHDIR}/dsirc-ipv6
.else
EXTRA_PATCHES= ${PATCHDIR}/dsirc-minimal
diff --git a/net-mgmt/hawk/Makefile b/net-mgmt/hawk/Makefile
index 7ab77d2fc8f5..979bd7c8cdc3 100644
--- a/net-mgmt/hawk/Makefile
+++ b/net-mgmt/hawk/Makefile
@@ -13,10 +13,10 @@ MASTER_SITES= SF/iphawk/iphawk/Hawk%20${PORTVERSION}/
MAINTAINER= dougb@FreeBSD.org
COMMENT= Track uptime and DNS status for machines on your networks
-RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
- ${SITE_PERL}/Net/Ping/External.pm:${PORTSDIR}/net/p5-Net-Ping-External \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS= p5-Net-Netmask:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
+ p5-Net-Ping-External:${PORTSDIR}/net/p5-Net-Ping-External \
+ p5-DBI:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-mysql:${PORTSDIR}/databases/p5-DBD-mysql
USE_PERL5= yes
USE_MYSQL= server
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 7df96997d421..3f4af317f7f0 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gle.4:${PORTSDIR}/graphics/gle \
xml2.5:${PORTSDIR}/textproc/libxml2 \
glade-2.0.0:${PORTSDIR}/devel/libglade2
-RUN_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
+RUN_DEPENDS= p5-libwww:${PORTSDIR}/www/p5-libwww \
giftopnm:${PORTSDIR}/graphics/netpbm
MAKE_JOBS_SAFE= yes