aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-02-13 19:56:37 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-02-13 19:56:37 +0000
commit3b036e835eae7d2c9fbafedcf9d9c04f811ba480 (patch)
tree0097d71e7c170ad53156ca9a649905934aceb73e
parentc9c43d75cab8221f8a04179e202a924c132a37eb (diff)
downloadports-3b036e835eae7d2c9fbafedcf9d9c04f811ba480.tar.gz
ports-3b036e835eae7d2c9fbafedcf9d9c04f811ba480.zip
Notes
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--www/Makefile1
-rw-r--r--www/osrm-backend/Makefile44
-rw-r--r--www/osrm-backend/distinfo3
-rw-r--r--www/osrm-backend/files/osrm.in62
-rw-r--r--www/osrm-backend/pkg-descr3
-rw-r--r--www/osrm-backend/pkg-plist95
8 files changed, 210 insertions, 2 deletions
diff --git a/GIDs b/GIDs
index 655c8e628eda..ecf04b1398ed 100644
--- a/GIDs
+++ b/GIDs
@@ -168,7 +168,7 @@ rtpproxy:*:222:
postgrey:*:225:
sqlgrey:*:226:
_hfm:*:227:
-# free: 228
+osrm:*:228:
kismet:*:229:
# free: 230
# free: 231
diff --git a/UIDs b/UIDs
index 001f49fef190..1be04a7c5620 100644
--- a/UIDs
+++ b/UIDs
@@ -173,7 +173,7 @@ rtpproxy:*:222:222::0:0:& user:/nonexistent:/sbin/nologin
postgrey:*:225:225::0:0:Postgrey Owner:/nonexistent:/usr/sbin/nologin
sqlgrey:*:226:226::0:0:SQLgrey Owner:/nonexistent:/usr/sbin/nologin
_hfm:*:227:227::0:0:hfm daemon:/nonexistent:/usr/sbin/nologin
-# free: 228
+osrm:*:228:228::0:0:osrm:/nonexistent:/usr/sbin/nologin
# free: 229
# free: 230
# free: 231
diff --git a/www/Makefile b/www/Makefile
index 6003b450228a..da4f0d2e1473 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -591,6 +591,7 @@
SUBDIR += opera-linuxplugins
SUBDIR += orangehrm
SUBDIR += oscommerce
+ SUBDIR += osrm-backend
SUBDIR += otrs
SUBDIR += otter-browser
SUBDIR += owncloud
diff --git a/www/osrm-backend/Makefile b/www/osrm-backend/Makefile
new file mode 100644
index 000000000000..51510206ee7c
--- /dev/null
+++ b/www/osrm-backend/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= osrm-backend
+DISTVERSIONPREFIX= v
+DISTVERSION= 5.15.2
+CATEGORIES= www
+
+MAINTAINER= a.andersson.thn@gmail.com
+COMMENT= Open Source Routing Machine (Backend)
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libstxxl.a:devel/stxxl
+LIB_DEPENDS= libtbb.so:devel/tbb \
+ libtbbmalloc.so:devel/tbb \
+ libluabind.so:devel/luabind \
+ libboost_program_options.so:devel/boost-libs \
+ libboost_date_time.so:devel/boost-libs \
+ libboost_chrono.so:devel/boost-libs \
+ libboost_filesystem.so:devel/boost-libs \
+ libboost_iostreams.so:devel/boost-libs \
+ libboost_thread.so:devel/boost-libs \
+ libboost_system.so:devel/boost-libs \
+ libboost_regex.so:devel/boost-libs \
+ libexpat.so:textproc/expat2
+
+USES= cmake:outsource lua:52 compiler:c++14-lang
+
+USE_LDCONFIG= yes
+OPTIONS_DEFINE= DEBUG
+
+USE_RC_SUBR= osrm
+USERS= osrm
+GROUPS= osrm
+
+USE_GITHUB= yes
+GH_ACCOUNT= Project-OSRM
+
+LUA_VER= 5.2
+
+pre-install:
+ ${MKDIR} ${STAGEDIR}/var/db/osrm-backend
+.include <bsd.port.mk>
diff --git a/www/osrm-backend/distinfo b/www/osrm-backend/distinfo
new file mode 100644
index 000000000000..9e60371a79e4
--- /dev/null
+++ b/www/osrm-backend/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518251752
+SHA256 (Project-OSRM-osrm-backend-v5.15.2_GH0.tar.gz) = ab966e9b38b4a64d3b43a83ae0b2b9ce4fddc040a230a0f4ed48e2d46ddaf229
+SIZE (Project-OSRM-osrm-backend-v5.15.2_GH0.tar.gz) = 5018331
diff --git a/www/osrm-backend/files/osrm.in b/www/osrm-backend/files/osrm.in
new file mode 100644
index 000000000000..93cead6dc50f
--- /dev/null
+++ b/www/osrm-backend/files/osrm.in
@@ -0,0 +1,62 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# PROVIDE: osrm
+# REQUIRE: LOGIN cleanvar
+# KEYWORD: shutdown
+#
+#
+# osrm_enable (bool): Set to NO by default.
+# Set it to YES to enable osrm-backend.
+# osrm_flags (flags): Empty by default
+# Adjust it to your needs.
+# osrm_file (path): The path to the osrm-file you intend
+# to use with osrm.
+# osrm_shared_memory (bool): Set to NO by default.
+# When enabled it will ignore osrm_file
+# and assume osrm-datastore has set up
+# the data in shared memory.
+# osrm will fail to start if this is
+# enbled and osrm-datastore hasnt set
+# up the shared memory.
+
+. /etc/rc.subr
+
+name="osrm"
+rcvar=${name}_enable
+load_rc_config $name
+
+: ${osrm_enable:="NO"}
+: ${osrm_user:="osrm"}
+: ${osrm_group:="osrm"}
+: ${osrm_flags:=""}
+: ${osrm_shared_memory:="NO"}
+: ${osrm_file:=""}
+
+
+
+
+pidfile="/var/run/osrm.pid"
+procname="/usr/local/bin/osrm-routed"
+command=/usr/sbin/daemon
+start_precmd="osrm_precmd"
+
+osrm_precmd()
+{
+ if checkyesno osrm_shared_memory; then
+ command_args="-f -c -p ${pidfile} ${procname} --shared-memory=yes ${osrm_flags}"
+ else
+
+ if [ -f "$osrm_file" ]; then
+ chown ${osrm_user}:${osrm_group} ${osrm_file}
+ command_args="-f -c -p ${pidfile} ${procname} ${osrm_flags} ${osrm_file}"
+ else
+ err 1 "Osrm file not found or osrm_file variable empty."
+ fi
+ fi
+ install -o $osrm_user -m 644 /dev/null ${pidfile}
+}
+
+
+run_rc_command "$1"
diff --git a/www/osrm-backend/pkg-descr b/www/osrm-backend/pkg-descr
new file mode 100644
index 000000000000..96d9818abb64
--- /dev/null
+++ b/www/osrm-backend/pkg-descr
@@ -0,0 +1,3 @@
+This is a port of osrm-backend of the open-streetmap project.
+
+WWW: http://project-osrm.org/
diff --git a/www/osrm-backend/pkg-plist b/www/osrm-backend/pkg-plist
new file mode 100644
index 000000000000..d02d17040ab1
--- /dev/null
+++ b/www/osrm-backend/pkg-plist
@@ -0,0 +1,95 @@
+bin/osrm-components
+bin/osrm-contract
+bin/osrm-customize
+bin/osrm-datastore
+bin/osrm-extract
+bin/osrm-partition
+bin/osrm-routed
+include/mapbox/optional.hpp
+include/mapbox/recursive_wrapper.hpp
+include/mapbox/variant.hpp
+include/mapbox/variant_io.hpp
+include/mapbox/variant_visitor.hpp
+include/osrm/approach.hpp
+include/osrm/bearing.hpp
+include/osrm/contractor.hpp
+include/osrm/contractor/contractor.hpp
+include/osrm/contractor/contractor_config.hpp
+include/osrm/contractor_config.hpp
+include/osrm/coordinate.hpp
+include/osrm/engine/api/base_parameters.hpp
+include/osrm/engine/api/match_parameters.hpp
+include/osrm/engine/api/nearest_parameters.hpp
+include/osrm/engine/api/route_parameters.hpp
+include/osrm/engine/api/table_parameters.hpp
+include/osrm/engine/api/tile_parameters.hpp
+include/osrm/engine/api/trip_parameters.hpp
+include/osrm/engine/approach.hpp
+include/osrm/engine/bearing.hpp
+include/osrm/engine/engine_config.hpp
+include/osrm/engine/hint.hpp
+include/osrm/engine/phantom_node.hpp
+include/osrm/engine/status.hpp
+include/osrm/engine_config.hpp
+include/osrm/error_codes.hpp
+include/osrm/exception.hpp
+include/osrm/extractor.hpp
+include/osrm/extractor/extractor.hpp
+include/osrm/extractor/extractor_config.hpp
+include/osrm/extractor/io_config.hpp
+include/osrm/extractor/travel_mode.hpp
+include/osrm/extractor_config.hpp
+include/osrm/json_container.hpp
+include/osrm/match_parameters.hpp
+include/osrm/nearest_parameters.hpp
+include/osrm/osrm.hpp
+include/osrm/osrm_fwd.hpp
+include/osrm/partition/partition_config.hpp
+include/osrm/partition/partitioner.hpp
+include/osrm/route_parameters.hpp
+include/osrm/status.hpp
+include/osrm/storage/io_config.hpp
+include/osrm/storage/storage.hpp
+include/osrm/storage/storage_config.hpp
+include/osrm/storage_config.hpp
+include/osrm/table_parameters.hpp
+include/osrm/tile_parameters.hpp
+include/osrm/trip_parameters.hpp
+include/osrm/util/alias.hpp
+include/osrm/util/bearing.hpp
+include/osrm/util/coordinate.hpp
+include/osrm/util/exception.hpp
+include/osrm/util/json_container.hpp
+include/osrm/util/typedefs.hpp
+%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm.a
+%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_contract.a
+%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_customize.a
+%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_extract.a
+%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_partition.a
+%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_store.a
+%%LUA_LIBDIR%%/%%LUA_LIBDIR%%osrm_update.a
+%%LUA_LIBDIR%%data/pkgconfig/%%LUA_LIBDIR%%osrm.pc
+share/osrm/profiles/bicycle.lua
+share/osrm/profiles/car.lua
+share/osrm/profiles/debug_example.lua
+share/osrm/profiles/examples/postgis.lua
+share/osrm/profiles/foot.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/access.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/destination.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/guidance.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/maxspeed.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/measure.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/pprint.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/profile_debugger.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/relations.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/sequence.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/set.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/tags.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/utils.lua
+share/osrm/profiles/%%LUA_LIBDIR%%/way_handlers.lua
+share/osrm/profiles/rasterbot.lua
+share/osrm/profiles/rasterbotinterp.lua
+share/osrm/profiles/test.lua
+share/osrm/profiles/testbot.lua
+share/osrm/profiles/turnbot.lua
+@dir /var/db/osrm-backend