aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 12:52:55 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 12:52:55 +0000
commit47828d0fce172b8afae396ba1cbcf459e396ef95 (patch)
treefc522cacf5b7a223abfda5c9bd7fe272ed4a0589
parentecd23c06ac78386c05267fbe96845fbe6cfb3815 (diff)
downloadports-47828d0fce172b8afae396ba1cbcf459e396ef95.tar.gz
ports-47828d0fce172b8afae396ba1cbcf459e396ef95.zip
Notes
-rw-r--r--converters/siconv/Makefile2
-rw-r--r--databases/sqlrelay/Makefile1
-rw-r--r--devel/gettext/Makefile5
-rw-r--r--devel/gtranslator/Makefile2
-rw-r--r--devel/styx/Makefile2
-rw-r--r--editors/AbiWord/Makefile2
-rw-r--r--editors/AbiWord2/Makefile2
-rw-r--r--editors/abiword-devel/Makefile2
-rw-r--r--editors/abiword/Makefile2
-rw-r--r--editors/dedit/Makefile2
-rw-r--r--editors/poedit/Makefile2
-rw-r--r--irc/xchat-gnome/Makefile2
-rw-r--r--irc/xchat/Makefile2
-rw-r--r--irc/xchat1/Makefile2
-rw-r--r--irc/xchat2/Makefile2
-rw-r--r--mail/balsa/Makefile2
-rw-r--r--mail/balsa2/Makefile2
-rw-r--r--math/gnumeric/Makefile2
-rw-r--r--math/gnumeric2/Makefile2
-rw-r--r--net-im/gnomeicu/Makefile2
-rw-r--r--net-im/gnomeicu2/Makefile2
-rw-r--r--net/gnomeicu/Makefile2
-rw-r--r--net/gnomeicu/gnomeicu/Makefile2
-rw-r--r--net/gnomeicu2/Makefile2
-rw-r--r--net/wol/Makefile2
-rw-r--r--science/vis5d+/Makefile2
-rw-r--r--x11-fm/nautilus/Makefile2
-rw-r--r--x11-fm/nautilus/files/patch-aa27
-rw-r--r--x11-fm/nautilus2/Makefile2
-rw-r--r--x11-fm/nautilus2/files/patch-aa27
-rw-r--r--x11-toolkits/wxgtk-devel/Makefile2
-rw-r--r--x11/gdkxft/Makefile2
32 files changed, 28 insertions, 88 deletions
diff --git a/converters/siconv/Makefile b/converters/siconv/Makefile
index 98e10b85aa13..71b5c225a560 100644
--- a/converters/siconv/Makefile
+++ b/converters/siconv/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ijliao@FreeBSD.org
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
do-build:
- ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -o ${WRKSRC}/siconv ${WRKSRC}/siconv.c -lgiconv
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -o ${WRKSRC}/siconv ${WRKSRC}/siconv.c -liconv
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/siconv ${PREFIX}/bin
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index c5a3055056e1..607a867a9d13 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -136,7 +136,6 @@ post-extract:
post-patch:
${PERL} -i -p \
- -e 's,\blibiconv\b,libgiconv,g;s,-liconv\b,-lgiconv,g;' \
-e 's,/usr/local\b,${PREFIX},g;' \
-e 's,\bgtk-config\b,${GTK_CONFIG:T},g;' \
${WRKSRC}/configure
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index ed39a7621c26..2ee6d2f46344 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -30,11 +30,6 @@ MAN3= bind_textdomain_codeset.3 bindtextdomain.3 dcgettext.3 \
dcngettext.3 dgettext.3 dngettext.3 gettext.3 ngettext.3 \
textdomain.3
-# X X X - I know, but it doesn't work with BSD iconv yet. :(((
-post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e \
- 's|-liconv|-lgiconv|g ; s|iconv\.h|giconv\.h|g'
-
pre-configure:
${RM} ${WRKSRC}/doc/gettext.info*
diff --git a/devel/gtranslator/Makefile b/devel/gtranslator/Makefile
index 59b26ba64bed..e42efff44a86 100644
--- a/devel/gtranslator/Makefile
+++ b/devel/gtranslator/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-debug
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lgiconv -lgnuregex" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -liconv -lgnuregex" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new \
XGETTEXT=${LOCALBASE}/bin/xgettext-new
diff --git a/devel/styx/Makefile b/devel/styx/Makefile
index 10d30bc1d385..f04b6ccb79a6 100644
--- a/devel/styx/Makefile
+++ b/devel/styx/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${PREFIX}/include ${PTHREAD_FLAGS}" \
- LIBS="-L${PREFIX}/lib -lgiconv ${PTHREAD_LIBS}"
+ LIBS="-L${PREFIX}/lib -liconv ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --includedir=${PREFIX}/include/styx \
--datadir=${PREFIX}/share/doc/styx
diff --git a/editors/AbiWord/Makefile b/editors/AbiWord/Makefile
index 1052618764d6..55c62efb8e9b 100644
--- a/editors/AbiWord/Makefile
+++ b/editors/AbiWord/Makefile
@@ -38,7 +38,7 @@ WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
+ LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index 1052618764d6..55c62efb8e9b 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -38,7 +38,7 @@ WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
+ LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index 1052618764d6..55c62efb8e9b 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -38,7 +38,7 @@ WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
+ LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 1052618764d6..55c62efb8e9b 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -38,7 +38,7 @@ WANT_GNOME= yes
AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ARGS= --datadir=${PREFIX}/share
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgiconv"
+ LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${PERL} -pi -e \
's|\$$\(libdir\)/\@PACKAGE\@|\$$\(datadir\)/\@PACKAGE\@|g ; \
diff --git a/editors/dedit/Makefile b/editors/dedit/Makefile
index af4fff0e150a..66c099ebf0de 100644
--- a/editors/dedit/Makefile
+++ b/editors/dedit/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgiconv"
+ LIBS="-L${LOCALBASE}/lib -liconv"
MAN1= dedit.1
MANLANG= "" ja
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
index 2e6cdb9eac3f..2a4245a5fbc1 100644
--- a/editors/poedit/Makefile
+++ b/editors/poedit/Makefile
@@ -27,7 +27,7 @@ USE_X_PREFIX= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgiconv"
+ LIBS="-L${LOCALBASE}/lib -liconv"
USE_GMAKE= yes
MAN1= poedit.1
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 95fe629e7a99..7da23716f296 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -30,7 +30,7 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
# Assign with `+=' for slave ports
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl -lgiconv" \
+ LIBS="-L${LOCALBASE}/lib -lintl -liconv" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 95fe629e7a99..7da23716f296 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -30,7 +30,7 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
# Assign with `+=' for slave ports
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl -lgiconv" \
+ LIBS="-L${LOCALBASE}/lib -lintl -liconv" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index 95fe629e7a99..7da23716f296 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -30,7 +30,7 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
# Assign with `+=' for slave ports
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl -lgiconv" \
+ LIBS="-L${LOCALBASE}/lib -lintl -liconv" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 95fe629e7a99..7da23716f296 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -30,7 +30,7 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
# Assign with `+=' for slave ports
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl -lgiconv" \
+ LIBS="-L${LOCALBASE}/lib -lintl -liconv" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 336425e176c5..374cb2ac703e 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS= --enable-threads \
--disable-more-warnings \
--with-ssl
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib -lgiconv"
+ LIBS="-L${LOCALBASE}/lib -liconv"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= balsa.1
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index 336425e176c5..374cb2ac703e 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS= --enable-threads \
--disable-more-warnings \
--with-ssl
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib -lgiconv"
+ LIBS="-L${LOCALBASE}/lib -liconv"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= balsa.1
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index d3e11934e889..810c77408cf7 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-evolution
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib -lintl -lgiconv ${PTHREAD_LIBS}"
+ LIBS="-L${LOCALBASE}/lib -lintl -liconv ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}-bonobo
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index d3e11934e889..810c77408cf7 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-evolution
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib -lintl -lgiconv ${PTHREAD_LIBS}"
+ LIBS="-L${LOCALBASE}/lib -lintl -liconv ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}-bonobo
diff --git a/net-im/gnomeicu/Makefile b/net-im/gnomeicu/Makefile
index 9bbaa0c92fc5..345ac0645a81 100644
--- a/net-im/gnomeicu/Makefile
+++ b/net-im/gnomeicu/Makefile
@@ -37,7 +37,7 @@ SOCKSLIBS= -lsocks5
CONFIGURE_ARGS= --with-statusmenu
CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lgiconv ${SOCKSLIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv ${SOCKSLIBS}" \
CFLAGS="${CFLAGS}"
pre-patch:
diff --git a/net-im/gnomeicu2/Makefile b/net-im/gnomeicu2/Makefile
index 9bbaa0c92fc5..345ac0645a81 100644
--- a/net-im/gnomeicu2/Makefile
+++ b/net-im/gnomeicu2/Makefile
@@ -37,7 +37,7 @@ SOCKSLIBS= -lsocks5
CONFIGURE_ARGS= --with-statusmenu
CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lgiconv ${SOCKSLIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv ${SOCKSLIBS}" \
CFLAGS="${CFLAGS}"
pre-patch:
diff --git a/net/gnomeicu/Makefile b/net/gnomeicu/Makefile
index 9bbaa0c92fc5..345ac0645a81 100644
--- a/net/gnomeicu/Makefile
+++ b/net/gnomeicu/Makefile
@@ -37,7 +37,7 @@ SOCKSLIBS= -lsocks5
CONFIGURE_ARGS= --with-statusmenu
CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lgiconv ${SOCKSLIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv ${SOCKSLIBS}" \
CFLAGS="${CFLAGS}"
pre-patch:
diff --git a/net/gnomeicu/gnomeicu/Makefile b/net/gnomeicu/gnomeicu/Makefile
index 9bbaa0c92fc5..345ac0645a81 100644
--- a/net/gnomeicu/gnomeicu/Makefile
+++ b/net/gnomeicu/gnomeicu/Makefile
@@ -37,7 +37,7 @@ SOCKSLIBS= -lsocks5
CONFIGURE_ARGS= --with-statusmenu
CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lgiconv ${SOCKSLIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv ${SOCKSLIBS}" \
CFLAGS="${CFLAGS}"
pre-patch:
diff --git a/net/gnomeicu2/Makefile b/net/gnomeicu2/Makefile
index 9bbaa0c92fc5..345ac0645a81 100644
--- a/net/gnomeicu2/Makefile
+++ b/net/gnomeicu2/Makefile
@@ -37,7 +37,7 @@ SOCKSLIBS= -lsocks5
CONFIGURE_ARGS= --with-statusmenu
CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lgiconv ${SOCKSLIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv ${SOCKSLIBS}" \
CFLAGS="${CFLAGS}"
pre-patch:
diff --git a/net/wol/Makefile b/net/wol/Makefile
index c782c1b331c2..f61e453337e8 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -21,6 +21,6 @@ LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext-old \
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgiconv -lgnugetopt"
+ LDFLAGS="-L${LOCALBASE}/lib -liconv -lgnugetopt"
.include <bsd.port.mk>
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index 5a1ac49ba927..b8998d061fc4 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -29,7 +29,7 @@ USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= \
CPPFLAGS="${CXXFLAGS} ${PTHREAD_FLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -lgiconv -lintl -L${X11BASE}/lib"
+ LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -liconv -lintl -L${X11BASE}/lib"
CONFIGURE_ARGS= --enable-gtk --enable-threads --with-mesa --with-netcdf \
--with-mixkit=${LOCALBASE}/lib/libmix.a --with-x
INSTALLS_SHLIB= yes
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 95daea13b8ea..7348985c029d 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -40,7 +40,7 @@ USE_GNOME= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -fno-rtti -fno-exceptions" \
- LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -lgiconv" \
+ LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -liconv" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new \
XGETTEXT=${LOCALBASE}/bin/xgettext-new
diff --git a/x11-fm/nautilus/files/patch-aa b/x11-fm/nautilus/files/patch-aa
index 45dcf1f7b504..d50ac2068a3a 100644
--- a/x11-fm/nautilus/files/patch-aa
+++ b/x11-fm/nautilus/files/patch-aa
@@ -30,33 +30,6 @@ $FreeBSD$
cat > conftest.$ac_ext <<EOF
#line 7063 "configure"
#include "confdefs.h"
-@@ -7585,14 +7585,14 @@
- #
- # Check for libiconv
- #
-- echo $ac_n "checking for libiconv_open in -liconv""... $ac_c" 1>&6
--echo "configure:7590: checking for libiconv_open in -liconv" >&5
-+ echo $ac_n "checking for libiconv_open in -lgiconv""... $ac_c" 1>&6
-+echo "configure:7590: checking for libiconv_open in -lgiconv" >&5
- ac_lib_var=`echo iconv'_'libiconv_open | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-liconv $LIBS"
-+LIBS="-lgiconv $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 7598 "configure"
- #include "confdefs.h"
-@@ -7632,7 +7632,7 @@
- fi
-
- if test "x$with_libiconv" = "xyes" ; then
-- ICONV_LIBS="-liconv"
-+ ICONV_LIBS="-lgiconv"
- fi
-
-
@@ -9141,7 +9141,7 @@
fi
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index 95daea13b8ea..7348985c029d 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -40,7 +40,7 @@ USE_GNOME= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -fno-rtti -fno-exceptions" \
- LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -lgiconv" \
+ LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -liconv" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new \
XGETTEXT=${LOCALBASE}/bin/xgettext-new
diff --git a/x11-fm/nautilus2/files/patch-aa b/x11-fm/nautilus2/files/patch-aa
index 45dcf1f7b504..d50ac2068a3a 100644
--- a/x11-fm/nautilus2/files/patch-aa
+++ b/x11-fm/nautilus2/files/patch-aa
@@ -30,33 +30,6 @@ $FreeBSD$
cat > conftest.$ac_ext <<EOF
#line 7063 "configure"
#include "confdefs.h"
-@@ -7585,14 +7585,14 @@
- #
- # Check for libiconv
- #
-- echo $ac_n "checking for libiconv_open in -liconv""... $ac_c" 1>&6
--echo "configure:7590: checking for libiconv_open in -liconv" >&5
-+ echo $ac_n "checking for libiconv_open in -lgiconv""... $ac_c" 1>&6
-+echo "configure:7590: checking for libiconv_open in -lgiconv" >&5
- ac_lib_var=`echo iconv'_'libiconv_open | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-liconv $LIBS"
-+LIBS="-lgiconv $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 7598 "configure"
- #include "confdefs.h"
-@@ -7632,7 +7632,7 @@
- fi
-
- if test "x$with_libiconv" = "xyes" ; then
-- ICONV_LIBS="-liconv"
-+ ICONV_LIBS="-lgiconv"
- fi
-
-
@@ -9141,7 +9141,7 @@
fi
diff --git a/x11-toolkits/wxgtk-devel/Makefile b/x11-toolkits/wxgtk-devel/Makefile
index db8ae437f620..068f81da9d2e 100644
--- a/x11-toolkits/wxgtk-devel/Makefile
+++ b/x11-toolkits/wxgtk-devel/Makefile
@@ -36,7 +36,7 @@ CONFIGURE_ARGS= --with-libpng=sys \
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include \
-I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgiconv \
+ LDFLAGS="-L${LOCALBASE}/lib -liconv \
-L${X11BASE}/lib" \
GTK_CONFIG_2_0="no"
diff --git a/x11/gdkxft/Makefile b/x11/gdkxft/Makefile
index dbbddb12404c..cc044f26aeec 100644
--- a/x11/gdkxft/Makefile
+++ b/x11/gdkxft/Makefile
@@ -21,7 +21,7 @@ USE_GTK= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lgnuregex -lgiconv"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lgnuregex -liconv"
CONFIGURE_ARGS= --sbindir=${PREFIX}/bin
INSTALLS_SHLIB= yes