aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-09-22 21:13:27 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-09-22 21:13:27 +0000
commit4d57ba3460aababdff8d5c145d2197f60c5c069a (patch)
tree97192c7effcd5d6bc9854a21173275e3b66a4371
parent2a400db18a4c026670840300713d442720716c3c (diff)
downloadports-4d57ba3460aababdff8d5c145d2197f60c5c069a.tar.gz
ports-4d57ba3460aababdff8d5c145d2197f60c5c069a.zip
Notes
-rw-r--r--sysutils/busybox/Makefile15
-rw-r--r--sysutils/busybox/distinfo10
-rw-r--r--sysutils/busybox/files/patch-archival__unzip.c11
-rw-r--r--sysutils/busybox/files/patch-coreutils__cp.c11
-rw-r--r--sysutils/busybox/files/patch-coreutils__dirname.c11
-rw-r--r--sysutils/busybox/files/patch-coreutils__install.c11
-rw-r--r--sysutils/busybox/files/patch-coreutils__rmdir.c11
-rw-r--r--sysutils/busybox/files/patch-include__platform.h6
8 files changed, 79 insertions, 7 deletions
diff --git a/sysutils/busybox/Makefile b/sysutils/busybox/Makefile
index 345bf21179cf..600023aed31f 100644
--- a/sysutils/busybox/Makefile
+++ b/sysutils/busybox/Makefile
@@ -7,12 +7,19 @@
PORTNAME= busybox
PORTVERSION= 1.19.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= sysutils misc shells
MASTER_SITES= http://www.busybox.net/downloads/
PATCH_SITES= http://www.busybox.net/downloads/fixes-${PORTVERSION}/
-PATCHFILES= busybox-1.19.2-crond.patch
+PATCHFILES= \
+ busybox-1.19.2-buildsys.patch \
+ busybox-1.19.2-chpasswd.patch \
+ busybox-1.19.2-crond.patch \
+ busybox-1.19.2-inetd.patch \
+ busybox-1.19.2-syslogd.patch \
+ busybox-1.19.2-tail.patch \
+
PATCH_DIST_STRIP= -p1
MAINTAINER= mandree@FreeBSD.org
@@ -26,8 +33,8 @@ MAKE_JOBS_SAFE= yes
MAKE_ARGS+= SKIP_STRIP=y
USE_BZIP2= yes
USE_GMAKE= yes
-CPPFLAGS+= -include libgen.h
-# avoid clang, breaks in findutils/find.c l. 752+:
+# avoid clang, breaks in findutils/find.c l. 752+,
+# uses a GCC extension/invalid C code:
USE_GCC= 4.2+
PLIST_FILES= bin/busybox
diff --git a/sysutils/busybox/distinfo b/sysutils/busybox/distinfo
index ffeffac0c52b..6c0bf4f19ad5 100644
--- a/sysutils/busybox/distinfo
+++ b/sysutils/busybox/distinfo
@@ -1,4 +1,14 @@
SHA256 (busybox-1.19.2.tar.bz2) = ea7ec9b6df70b8c528f4a2b6300e9913431c7223308fb08dfafa7508d75a0cb9
SIZE (busybox-1.19.2.tar.bz2) = 2168055
+SHA256 (busybox-1.19.2-buildsys.patch) = a3f5e0da5264e31c0c1fa6bed5a5cfe19d1217b8b02e7942830ee4cdf7bd56d3
+SIZE (busybox-1.19.2-buildsys.patch) = 643
+SHA256 (busybox-1.19.2-chpasswd.patch) = 908366dc98aab1936dce48ca4849d3dd6e9d28ec138c1dbf5c787e667b4b4384
+SIZE (busybox-1.19.2-chpasswd.patch) = 1542
SHA256 (busybox-1.19.2-crond.patch) = b2b465389ac22fbfd608a055e816cf94bda65eb163e06d07983f167c9e542c7d
SIZE (busybox-1.19.2-crond.patch) = 555
+SHA256 (busybox-1.19.2-inetd.patch) = e883c6d8723cf7f18d58c116f164c6dc658e0ad45ff12fd5ef98f3f177589d3a
+SIZE (busybox-1.19.2-inetd.patch) = 1616
+SHA256 (busybox-1.19.2-syslogd.patch) = e772510323fb85e59005b80c7fa63072a6fbdb94216f425b14b742f1730b0472
+SIZE (busybox-1.19.2-syslogd.patch) = 708
+SHA256 (busybox-1.19.2-tail.patch) = d114d432ec828fe6b66155224284cbe5d202c56f6de6d4d358eed1822c06ea9d
+SIZE (busybox-1.19.2-tail.patch) = 1320
diff --git a/sysutils/busybox/files/patch-archival__unzip.c b/sysutils/busybox/files/patch-archival__unzip.c
new file mode 100644
index 000000000000..eac33fb50f90
--- /dev/null
+++ b/sysutils/busybox/files/patch-archival__unzip.c
@@ -0,0 +1,11 @@
+--- ./archival/unzip.c.orig 2011-08-22 04:57:49.000000000 +0200
++++ ./archival/unzip.c 2011-09-22 23:05:09.000000000 +0200
+@@ -34,6 +34,8 @@
+ #include "libbb.h"
+ #include "archive.h"
+
++#include <libgen.h>
++
+ enum {
+ #if BB_BIG_ENDIAN
+ ZIP_FILEHEADER_MAGIC = 0x504b0304,
diff --git a/sysutils/busybox/files/patch-coreutils__cp.c b/sysutils/busybox/files/patch-coreutils__cp.c
new file mode 100644
index 000000000000..02fa9ad1baf4
--- /dev/null
+++ b/sysutils/busybox/files/patch-coreutils__cp.c
@@ -0,0 +1,11 @@
+--- ./coreutils/cp.c.orig 2011-08-22 04:57:49.000000000 +0200
++++ ./coreutils/cp.c 2011-09-22 23:05:23.000000000 +0200
+@@ -35,6 +35,8 @@
+ #include "libbb.h"
+ #include "libcoreutils/coreutils.h"
+
++#include <libgen.h>
++
+ /* This is a NOEXEC applet. Be very careful! */
+
+ int cp_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
diff --git a/sysutils/busybox/files/patch-coreutils__dirname.c b/sysutils/busybox/files/patch-coreutils__dirname.c
new file mode 100644
index 000000000000..df7f42cf35b0
--- /dev/null
+++ b/sysutils/busybox/files/patch-coreutils__dirname.c
@@ -0,0 +1,11 @@
+--- ./coreutils/dirname.c.orig 2011-08-22 04:57:49.000000000 +0200
++++ ./coreutils/dirname.c 2011-09-22 23:05:09.000000000 +0200
+@@ -23,6 +23,8 @@
+
+ #include "libbb.h"
+
++#include <libgen.h>
++
+ /* This is a NOFORK applet. Be very careful! */
+
+ int dirname_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
diff --git a/sysutils/busybox/files/patch-coreutils__install.c b/sysutils/busybox/files/patch-coreutils__install.c
new file mode 100644
index 000000000000..31fb603ebd2a
--- /dev/null
+++ b/sysutils/busybox/files/patch-coreutils__install.c
@@ -0,0 +1,11 @@
+--- ./coreutils/install.c.orig 2011-08-22 04:57:49.000000000 +0200
++++ ./coreutils/install.c 2011-09-22 23:05:09.000000000 +0200
+@@ -26,6 +26,8 @@
+ #include "libbb.h"
+ #include "libcoreutils/coreutils.h"
+
++#include <libgen.h>
++
+ #if ENABLE_FEATURE_INSTALL_LONG_OPTIONS
+ static const char install_longopts[] ALIGN1 =
+ "directory\0" No_argument "d"
diff --git a/sysutils/busybox/files/patch-coreutils__rmdir.c b/sysutils/busybox/files/patch-coreutils__rmdir.c
new file mode 100644
index 000000000000..a3bac877fff7
--- /dev/null
+++ b/sysutils/busybox/files/patch-coreutils__rmdir.c
@@ -0,0 +1,11 @@
+--- ./coreutils/rmdir.c.orig 2011-08-22 04:57:49.000000000 +0200
++++ ./coreutils/rmdir.c 2011-09-22 23:05:09.000000000 +0200
+@@ -27,6 +27,8 @@
+
+ #include "libbb.h"
+
++#include <libgen.h>
++
+ /* This is a NOFORK applet. Be very careful! */
+
+
diff --git a/sysutils/busybox/files/patch-include__platform.h b/sysutils/busybox/files/patch-include__platform.h
index 0049cfb5b70f..2c4e93b0daf7 100644
--- a/sysutils/busybox/files/patch-include__platform.h
+++ b/sysutils/busybox/files/patch-include__platform.h
@@ -1,6 +1,6 @@
---- ./include/platform.h.orig 2011-08-11 02:23:58.000000000 +0200
-+++ ./include/platform.h 2011-08-28 12:58:14.000000000 +0200
-@@ -421,6 +421,15 @@
+--- ./include/platform.h.orig 2011-08-28 12:59:56.000000000 +0200
++++ ./include/platform.h 2011-09-22 23:05:09.000000000 +0200
+@@ -423,6 +423,15 @@
#if defined(__FreeBSD__)
# undef HAVE_STRCHRNUL