aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-07-10 00:59:37 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-07-10 00:59:37 +0000
commit530a2aa601621e300fb7020abff2b82d7c810041 (patch)
tree1759cd937905c79fa0ebb3865eedc85db35a4daa
parent2c0555e1186fef5a0cf5d1bdd91a4c7ee27c8772 (diff)
downloadports-530a2aa601621e300fb7020abff2b82d7c810041.tar.gz
ports-530a2aa601621e300fb7020abff2b82d7c810041.zip
Notes
-rw-r--r--audio/hs-libmpd/Makefile5
-rw-r--r--audio/hs-libmpd/distinfo4
-rw-r--r--audio/hs-libmpd/files/patch-libmpd.cabal33
3 files changed, 23 insertions, 19 deletions
diff --git a/audio/hs-libmpd/Makefile b/audio/hs-libmpd/Makefile
index 3c71b70f3300..2dc0832fd46e 100644
--- a/audio/hs-libmpd/Makefile
+++ b/audio/hs-libmpd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libmpd
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= audio haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +14,7 @@ COMMENT= An MPD client library
LICENSE= LGPL21
-USE_CABAL= mtl>=1.1 network>=2.1 utf8-string>=0.3.1
+USE_CABAL= mtl>=2.0 network>=2.1 utf8-string>=0.3.1
CONFIGURE_ARGS+= --flags="-test -coverage"
diff --git a/audio/hs-libmpd/distinfo b/audio/hs-libmpd/distinfo
index 516b91279b88..fc4a56fb121a 100644
--- a/audio/hs-libmpd/distinfo
+++ b/audio/hs-libmpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/libmpd-0.5.0.tar.gz) = 528d4a3420f3fa00360a5955def57019a3da84bc0ad8214b50b9bb0fcbbde205
-SIZE (cabal/libmpd-0.5.0.tar.gz) = 37305
+SHA256 (cabal/libmpd-0.6.0.tar.gz) = 753bb22bb6c214b8ea9e396bae89862f57e077256aea543d8cd397b3a39bc7d2
+SIZE (cabal/libmpd-0.6.0.tar.gz) = 38216
diff --git a/audio/hs-libmpd/files/patch-libmpd.cabal b/audio/hs-libmpd/files/patch-libmpd.cabal
index 25bd19418fd7..33f3471e3b37 100644
--- a/audio/hs-libmpd/files/patch-libmpd.cabal
+++ b/audio/hs-libmpd/files/patch-libmpd.cabal
@@ -1,18 +1,23 @@
---- ./libmpd.cabal.orig 2010-09-08 15:47:02.000000000 +0200
-+++ ./libmpd.cabal 2011-03-13 04:15:05.157038443 +0100
-@@ -41,11 +41,11 @@
- else
- Build-Depends: base >= 4 && < 5
+--- ./libmpd.cabal.orig 2011-04-01 17:52:19.000000000 +0200
++++ ./libmpd.cabal 2011-05-22 14:39:35.000000000 +0200
+@@ -33,13 +33,13 @@
-- Build-Depends: network >= 2.1 && < 2.3,
-- mtl >= 1.1 && < 1.2, filepath >= 1.0 && < 1.2,
-+ Build-Depends: network >= 2.1,
-+ mtl >= 1.1, filepath >= 1.0,
- utf8-string >= 0.3.1 && < 0.4,
-- containers >= 0.3 && < 0.4,
-- time >= 1.1 && < 1.2,
-+ containers >= 0.3,
+ Library
+ Build-Depends: base >= 4 && < 5,
+- mtl >= 2.0 && < 2.1,
+- network >= 2.1 && < 2.4,
+- filepath >= 1.0 && < 1.3,
+- utf8-string >= 0.3.1 && < 0.4,
+- old-locale >= 1.0 && < 2.0,
+- time >= 1.1 && < 2.0,
+- containers >= 0.4 && < 0.5
++ mtl >= 2.0,
++ network >= 2.1,
++ filepath >= 1.0,
++ utf8-string >= 0.3.1,
++ old-locale >= 1.0,
+ time >= 1.1,
- old-locale >= 1.0 && < 1.1
++ containers >= 0.4
Exposed-Modules: Network.MPD, Network.MPD.Commands.Extensions,
Network.MPD.Core
+ Other-Modules: Network.MPD.Core.Class,